none
Probleme mit dem EF 6 mit SQl-Server CE RRS feed

  • Frage

  • Hallo NG,

    ich erstellen den Context mit folgenden connection string:

    data source=C:\Users\Ingo\Documents\Visual Studio 2015\UserInstallation\Data\Databases\WPF.sdf;password=passwort

    Wenn ich die Datenbank erstellen will, bekomme ich folgende Excepetion:

    Der Vorgang kann nicht abgeschlossen werden. Die bereitgestellte SqlConnection gibt keinen ursprünglichen Katalog oder AttachDBFileName an.
    Methode: GetOrGenerateDatabaseNameAndGetFileNames

    Der Name der Datei ist doch angegeben. Was mache ich hier falsch?

    Danke im voraus für jeden Hinweis und Tipp.

    Grüße  Ingo

    Samstag, 31. Oktober 2015 17:30

Antworten

  • Hallo NG,

    ich habe das Problem gelöst!

    Die Ursache war das in der App.Config folgender Eintrag nicht so vorhanden war:

    <defaultConnectionFactory  type = "System.Data.Entity.Infrastructure.SqlCeConnectionFactory, EntityFramework" >
          <parameters>
            <parameter  value = "System.Data.SqlServerCe.4.0"  />
          </parameters>
        </defaultConnectionFactory>

    Grüße  Ingo

    Samstag, 31. Oktober 2015 19:40

Alle Antworten

  • Hallo Ingo,

    für SQL Server CE solltest Du auch die Klassen aus dem System.Data.SqlServerCe Namespace verwenden, also bspw. auch SqlCeConnection, nicht SqlConnection. Siehe dazu:

      https://msdn.microsoft.com/de-de/library/system.data.sqlserverce.aspx


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    Samstag, 31. Oktober 2015 18:30
    Moderator
  • Hallo Stefan,

    Danke für den Tipp. Will es mal versuchen.

    Aber ich habe den connection string aus der App.config genommen und auch keine SqlConnection genutzt.

    Grüße  Ingo

    Samstag, 31. Oktober 2015 18:54
  • Hallo Stefan,

    ich habe leider immer noch das selbe Problem:

    SqlCeConnectionStringBuilder sqlConnection = new SqlCeConnectionStringBuilder() {
    
    Password = _DBoptions.DatabaseFile,
    
     DataSource = Path.Combine(MaPath.ProjectPath(ProjectPaths.Data), _DBoptions.Password),
    
    
    
    };
    Auch der connection string hat sich nicht geändert:

    Data Source="C:\Users\Ingo\Documents\Visual Studio 2015\UserInstallation\Data\Passwort";Password=Test2.sdf

    Auch immer noch die selbe Fehlermeldung:

    Grüße  Ingo

    Samstag, 31. Oktober 2015 19:20
  • Hallo NG,

    ich habe das Problem gelöst!

    Die Ursache war das in der App.Config folgender Eintrag nicht so vorhanden war:

    <defaultConnectionFactory  type = "System.Data.Entity.Infrastructure.SqlCeConnectionFactory, EntityFramework" >
          <parameters>
            <parameter  value = "System.Data.SqlServerCe.4.0"  />
          </parameters>
        </defaultConnectionFactory>

    Grüße  Ingo

    Samstag, 31. Oktober 2015 19:40