none
Kann Visual Studio 2015 nicht installieren

    Frage

  • Hallo,

    ich hatte Visual Studio 2015 Professional Update 2 bereits erfolgreich auf meinem Windows 10 x64 installiert und konnte damit auch arbeiten. Ein Update-Versuch auf VS2015 Update 3 wurde durch einen Fehler abgebrochen. 

    Seitdem kann ich VS2015 egal in welcher Version nicht mehr installieren. Es kommt folgender Fehler:

    Team Explorerfor Microsoft Visual Studio 2015 Update 3 CTP1 schwerwiegender Fehler
    (leider kann ich in diesem Forum noch keine Bilder oder Links senden, da lt. Anzeige mein Konto noch nicht geprüft wurde)

    Ich habe schon folgendes probiert:

    1. Deinstallation und Löschen des Installationsverzeichnisses "C:\Program Files (x86)\Microsoft Visual Studio 14.0"

    2. Deinstallation und Neuinstallation der c++ redistributables 2015 

    3. Überprüfung der c++ redistributables 2015 (wie in einem anderen Forum beschrieben (Solution 6)

    http://stackoverflow.com/questions/33855177/multiple-errors-installing-visual-studio-2015-community-edition

    kann es zu Problemen kommen wenn falsche Versionen der  c++ redistributables installiert sind. 

    4. Deinstallation des Virenscanners

    5.Leeren des Installationscaches und der Temp-Ordner

    Es ist nichts zu machen, VS2015 lässt sich nicht mehr installieren, könnte mir da jemand einen Tipp geben?

    Gruß

    Jörg

    Dienstag, 19. Juli 2016 08:11

Antworten

  • Danke für die Antwort. 

    Gerade habe ich es hinbekommen, allerdings wäre ich da nie alleine drauf gekommen. Das Setup des teamexplorers wurde lt. Install-Log mit Fehlernummer 1722 beendet. Ich bin dann auf diesen Forumsbetrag gestoßen:

    https://blogs.msdn.microsoft.com/vsnetsetup/2016/05/06/error-1722-there-is-a-problem-with-this-windows-installer-package/

    Und tatsächlich: Es lag an dem Studio 5000 von Rockwell, das eingentlich schon lange auf meinem Rechner installiert ist. Scheinbar wurde hier die gleiche GUID in der Registry benutzt wie auch der Team Explorer von MS. Nach einer Deinstallation der Rockwell-SW lief das VS2015-Setup problemlos durch.

    So, der Tag ist gerettet, danke für die Unterstützung.

    Jörg

    Dienstag, 19. Juli 2016 13:19

Alle Antworten

  • Hallo Jörg Vermehren,

    folgendes solltest Du tun:

    - Überlege mit welchen Fehler die Installation abgebrochen wurde
    - Nutze den Wiederherstellungspunkt deines Windowssystems
    - Wende dich an den Support

    Möglicherweise hilft nach den genannten Experimenten deinerseits nur noch eine Windows Neuinstallation.

    Gruß


    - Florian

    Dienstag, 19. Juli 2016 08:56
  • Hallo,

    Ja, eine Neuinstallation wäre die letzte Alternative, die ich gerne verhindern würde. Die vorhandenen Wiederherstellungspunkte wurden alle nach Beginn meiner VS2015-Probleme angelegt, somit helfen Sie mir momentan leider nicht weiter.

    Folgendes finde ich zum Fehler im Installationslog:

    [1DE0:266C][2016-07-19T14:05:32]i000: MUX:  ExecutePackageBegin PackageId: vs_teamExplorerCore
    [08B8:2650][2016-07-19T14:05:32]i301: Applying execute package: vs_teamExplorerCore, action: Install, path: C:\ProgramData\Package Cache\{791295AE-3B0A-3222-9E69-26C8C106E8D1}v14.0.23102\packages\TeamExplorer\Core\vs_teamExplorerCore.msi, arguments: ' MSIFASTINSTALL="7" USING_EXUIH="1"'
    [1DE0:266C][2016-07-19T14:05:37]i000: MUX:  ExecuteError: Package (vs_teamExplorerCore) failed: Error Message Id: 1722 ErrorMessage: There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  
    [08B8:2650][2016-07-19T14:05:38]e000: Error 0x80070643: Failed to install MSI package.
    [08B8:2650][2016-07-19T14:05:38]e000: Error 0x80070643: Failed to execute MSI package.
    [1DE0:266C][2016-07-19T14:05:38]e000: Error 0x80070643: Failed to configure per-machine MSI package.
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  Installation size in bytes for package: vs_teamExplorerCore MaxAppDrive: 0  MaxSysDrive: 177664000  AppDrive: 0  SysDrive: 6139904
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  Return Code:0x80070643 Msi Messages:There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.   Result Detail:0 Restart:None
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  Set Result: Return Code=-2147023293 (0x80070643), Error Message=There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  , Result Detail=, Vital=True, Package Action=Install, Package Id=vs_teamExplorerCore
    [1DE0:266C][2016-07-19T14:05:38]i000: Setting string variable 'BundleResult' to value '1603'
    [1DE0:266C][2016-07-19T14:05:38]i319: Applied execute package: vs_teamExplorerCore, result: 0x80070643, restart: None
    [1DE0:266C][2016-07-19T14:05:38]e000: Error 0x80070643: Failed to execute MSI package.
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  ExecutePackageBegin PackageId: vs_teamExplorerCore
    [08B8:2650][2016-07-19T14:05:38]i318: Skipped rollback of package: vs_teamExplorerCore, action: Uninstall, already: Absent
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  Installation size in bytes for package: vs_teamExplorerCore MaxAppDrive: 0  MaxSysDrive: 0  AppDrive: 0  SysDrive: 0
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  Return Code:0x0 Msi Messages:There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.   Result Detail:0 Restart:None
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  Reset execution Result
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  Reset Result
    [1DE0:266C][2016-07-19T14:05:38]i000: Setting string variable 'BundleResult' to value '1603'
    [1DE0:266C][2016-07-19T14:05:38]i319: Applied rollback package: vs_teamExplorerCore, result: 0x0, restart: None
    [08B8:2650][2016-07-19T14:05:38]i351: Removing cached package: vs_teamExplorerCore, from path: C:\ProgramData\Package Cache\{791295AE-3B0A-3222-9E69-26C8C106E8D1}v14.0.23102\
    [08B8:2650][2016-07-19T14:05:38]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{df9c38de-e276-422a-a845-04c5f8a9d243}, resume: ARP, restart: None, disable resume: No
    [08B8:2650][2016-07-19T14:05:38]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{df9c38de-e276-422a-a845-04c5f8a9d243}, resume: ARP, restart initiated: No, disable resume: No
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  Apply Complete: Disk Space Used in bytes for Installation:  MaxAppDrive: 0  MaxSysDrive: 250429440  AppDrive: 0  SysDrive: 31113216
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  Free Disk Space after install:  SystemDrive C:\ 348411584512 bytes  AppDrive C:\ 348411584512 bytes
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  Go to Finished page.
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  Watson Bucketting Parameters
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  P1 - vs_professional
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  P2 - 14.0.23107.10.05
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  P3 - 14.0.23107
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  P4 - Install
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  P5 - Team Explorer for Microsoft Visual Studio 2015
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  P6 - Install
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  P7 - 0x80070643
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  P8 - There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  
    [1DE0:266C][2016-07-19T14:05:38]i000: MUX:  P9 - 
    [1DE0:266C][2016-07-19T14:05:38]i399: Apply complete, result: 0x80070643, restart: None, ba requested restart:  No

    Das Problem kommt also aus dem Pachage vs_teamExplorerCore.msi. Kann mir dazu jemand weiterhelfen?

    Gruß Jörg

    Dienstag, 19. Juli 2016 12:15
  • Die vorhandenen Wiederherstellungspunkte wurden alle nach Beginn meiner VS2015-Probleme angelegt, somit helfen Sie mir momentan leider nicht weiter.

    Schade.

    Ein paar Tipps die weiter helfen könnten, findest Du hier:
    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/32741c40-94a3-4abd-9b28-bb5993bc5d73/visual-studio-2015-community-edition-installation-fails-under-window-server-2012r2?forum=vssetup

    In dem verlinkten Beitrag stand ebenso ein Fehler wie Du hier nennst.


    - Florian

    Dienstag, 19. Juli 2016 12:53
  • Danke für die Antwort. 

    Gerade habe ich es hinbekommen, allerdings wäre ich da nie alleine drauf gekommen. Das Setup des teamexplorers wurde lt. Install-Log mit Fehlernummer 1722 beendet. Ich bin dann auf diesen Forumsbetrag gestoßen:

    https://blogs.msdn.microsoft.com/vsnetsetup/2016/05/06/error-1722-there-is-a-problem-with-this-windows-installer-package/

    Und tatsächlich: Es lag an dem Studio 5000 von Rockwell, das eingentlich schon lange auf meinem Rechner installiert ist. Scheinbar wurde hier die gleiche GUID in der Registry benutzt wie auch der Team Explorer von MS. Nach einer Deinstallation der Rockwell-SW lief das VS2015-Setup problemlos durch.

    So, der Tag ist gerettet, danke für die Unterstützung.

    Jörg

    Dienstag, 19. Juli 2016 13:19