none
Schlüsseldatei kann nicht importiert werden RRS feed

  • Frage

  • Hallo,

    ich habe mir ein neues Notebook zugelegt ( um bei diesem schönen Wetter auch draußen an mein Projekt etwas basteln zu können) nun hab ich mir das neue VB2010 auf das Notebook gezogen (benutze es auf meinen PC bereits ohne Probleme). Danach den Projektordner kopiert und wollte dann schön beim strahlendem Sonnenschein Bugfinding betreiben. Leider kam nach starten des Debugers zwei Fehlermeldungen die ich so auf meinen PC nie hatte. :

    Fehler 1 Die folgende Schlüsseldatei kann nicht importiert werden: "Bremshundertstel_TemporaryKey.pfx". Die Schlüsseldatei ist möglicherweise kennwortgeschützt. Importieren Sie das Zertifikat erneut, oder importieren Sie das Zertifikat manuell in den persönlichen Zertifikatspeicher des aktuellen Benutzers, um das Problem zu beheben. Bremshundertstel

    und :

    Fehler 2 Der Import der Schlüsseldatei "Bremshundertstel_1_TemporaryKey.pfx" wurde abgebrochen. Bremshundertstel

    habe bereits Versucht über die Ssamb.-Eigenschaften das Schlüsselkennwort anzugeben aber ohne Erfolg.

    Kann mir jemand weiter helfen und vielleicht auch gleich mal das Prinzip mit den Zertifikaten erklären (z.B. muß ich dann für jeden Rechner ein eigendes Zertifikat haben?)

    Dank euch für die Hilfe

    Gruß

    Daniel


    Dienstag, 20. Juli 2010 08:56

Antworten

  • Hallo Daniel,

    erstmal folgender Tipp:

    Lösche einfach den Schlüssel aus deinen Projekteinstellungen, dann kannst Du auch arbeiten.

    zweitens:

    Ich kenne kaum jemanden der ein so hohes Sicherheitsbedürfnis hat, das er ein *.pfx - Schlüssel braucht. "Normale" *.snk -Schlüssel (also ohne zusätzliches Kennwort) reichen auch.

    >>Kann mir jemand weiter helfen und vielleicht auch gleich mal das Prinzip mit den Zertifikaten erklären (z.B. muß ich dann für jeden >>Rechner ein eigendes Zertifikat haben?)

    Zumindestens auf jedem Rechner, wo Du damit entwickeln willst muß die gleiche Zertikatsstruktur bestehen.

    Schöne Grüße

    Oliver

    • Als Antwort markiert B00NE Samstag, 24. Juli 2010 08:21
    Dienstag, 20. Juli 2010 14:16

Alle Antworten

  • Hallo Daniel,

    erstmal folgender Tipp:

    Lösche einfach den Schlüssel aus deinen Projekteinstellungen, dann kannst Du auch arbeiten.

    zweitens:

    Ich kenne kaum jemanden der ein so hohes Sicherheitsbedürfnis hat, das er ein *.pfx - Schlüssel braucht. "Normale" *.snk -Schlüssel (also ohne zusätzliches Kennwort) reichen auch.

    >>Kann mir jemand weiter helfen und vielleicht auch gleich mal das Prinzip mit den Zertifikaten erklären (z.B. muß ich dann für jeden >>Rechner ein eigendes Zertifikat haben?)

    Zumindestens auf jedem Rechner, wo Du damit entwickeln willst muß die gleiche Zertikatsstruktur bestehen.

    Schöne Grüße

    Oliver

    • Als Antwort markiert B00NE Samstag, 24. Juli 2010 08:21
    Dienstag, 20. Juli 2010 14:16
  • Hallo Daniel,

     

    das hatte ich auch schon mal als ich einen neuen PC angeschafft habe.

    Ich gehe davon aus, dass du alle Projekte 1 zu 1 kopiert und gesichert hast und diese auch wieder auf deinem PC verfügbar sind.

     

    Das mit dem Löschen der Projektschlüssel wie von Oliver beschrieben hat seinerzeit bei mir nicht geklappt, war aber auch damals schon eine Empfehlung im Forum.

     

    Mit hat folgendes geholfen:

    1. Ich bin auf die Eigenschaften meiner Anwendung
    2. Habe Register Signieren ausgewählt
    3. Button „Aus Datei wählen“ geklickt.

     

    Es öffnet sich ein File-Select-Dialog der aktiven Anwendung  (Vorausgesetzt, dass die Arbeitsverweise korrekt sind).

    Dort findest du dann die DeineAnwendung.pfx Datei

     

    Ich hoffe, das löst dein Problem


    Liebe Grüße Stefan
    • Als Antwort markiert B00NE Samstag, 24. Juli 2010 08:20
    • Tag als Antwort aufgehoben B00NE Samstag, 24. Juli 2010 08:20
    Mittwoch, 21. Juli 2010 16:48
  • Hallo Daniel,

    bist du weitergekommen?


    Liebe Grüße Stefan
    • Als Antwort markiert B00NE Samstag, 24. Juli 2010 08:20
    • Tag als Antwort aufgehoben B00NE Samstag, 24. Juli 2010 08:20
    Freitag, 23. Juli 2010 18:36
  • Hallo Stefan,

     

    Das Problem hatte sich bei mir mit dem Löschen des Schlüssels behoben. Habe dann noch in den Einstellungen zum Project bei Assembly signieren weg gemacht und seither läuft alles wieder.
    Weiß auch garnicht waurm ich dort n Häckchen hatte.

    War bestimmt zu meinen Anfangszeiten als ich noch Wild rumexperementiert habe ;-)

     

    Aber dank euch für die Unterstützung

     

    Gruß

     

    Daniel

     

    Samstag, 24. Juli 2010 08:20