none
SharePoint 2013 blockt das Iframe im CRM Online 2013

    Frage

  • Hallo

    Ich habe aktuell das Problem, dass ich ScharePoint Online 2013 nicht im CRM Online 2013 über einen Datensatz geöffnet bekomme. Dies zeigt sich darin, dass man die Meldung bekommt das öffnen in einem IFrame ist untersagt. Es gibt auch einen KB Artikel dafür, aber der hat weder eine Lösung noch ist er aktuell. Dieser Hinweis mit dem Iframe ist auch durchaus bekannt, allerdings nur in Verbindung mit dem CRM Outlook-Client.

    Fakten:

    Beides ist die gleiche Organisation

    Listkomponente ist installiert und aktiv

    CRM ist mit dem SharePoint verbunden und kann auch Ordner anlegen.

    Trusted Sites sind im Browser hinterlegt

    Die Sicherheitsstufe ist für IFrame und gemischten Inhalt aktiv

    Der User hat das Recht SharePoint und CRM zu benutzen (Admin)

    Sollte es jemanden geben, der einen Klugen Vorschlag hat oder bereits eine funktionierende Lösung, bitte ich dies hier zu beantworten.

    DANKE

    Montag, 17. Februar 2014 11:29

Alle Antworten

  • HalloAvatar von lehmann.rlehmann.r,

    siehst du mit F12(im geöffneten IE Fenster) auf welche URL er verscuht zuzugreifen? Kannst du diese URL in einem neuen Browser öffnen? Kommt der Fehler via Browser oder outlook plugin?

    Welche Broserversion nutzt du, bzw. hast du schon vorherige IE versionen probiert und evetnuell von einem anderen PC aus, einfach um lokale problem auszuschliessen und eventuell auch die firewall loakl ausgeschalten.

    Ich habe das Problem nicht, wenn du schreibst datensatz meinst du eine entität wie z.b. kontakte? der punkt doks wird links angezeigt und wenn du darauf klickst kommt der fehler? Hast du schon einen trace mit fiddler laufen lassen während der aktionen?


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Montag, 17. Februar 2014 14:54
  • Hallo

    Der Fehler tritt leider nicht nur im Outlook Addin auf sondern jetzt auch im Browser.

    Ich hab es mit IE10, IE11; Chrome (unter Win und Mac) und Safari probiert.

    Ich habe es auch nochmal mit einer komplett neuen 30Tage Testversion versucht.

    Ich habe ebenfalls verschiedenen PC (Real und Virtuel) und auch einen MAC probiert.

    Unter Datensatz meinte ich einen bsp. Account. und die Übergabe an SharePoint funktioniert, da der Ordner im Hintergrund angelegt wird. Es ist halt lediglich die Anzeige die Geblockt wird.

    Ich habe eine CRM Onlineumgebung in der Version 2013 und auch SharePoint ist Online in der Version 2013.

    Da ich nicht sonderlich bewandert mit dem Fiddler bin hab ich hier nichts gemacht, da ich davon ausgehe, das dies auch ohne sonderliche Analyse einfach laufen sollte. Ich habe bei der Integration SharePoint und CRM komplett den Standard verwendet, und die Organisation ist noch nicht angepasst, also alles im Auslieferungszustand seitens MS. Als OfficePlan hab ich den E3 für 30Tage ebenfalls im Test.

    Montag, 17. Februar 2014 15:18
  • Würde dir empfehlen die listcomponent zu deinstallieren und dann neu herunterladen und wieder installieren, das ganze dann von einem frischen PC aus testen und nebenbei fiddler laufen lassen.

    Den Kompatibilitätsmodus IE nehme ich an, hast du schon getestet und im privaten modus öffnen...

    Den Artikel hatte ich für mein testszenario genutzt: http://www.powerobjects.com/blog/2012/02/28/crm-2011-sharepoint-2010-configuration-and-folder-structure/

    Bist du so vorgegangen?


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Dienstag, 18. Februar 2014 14:59
  • Hi

    hat leider etwas länger gedauert, aber ich war nicht online.

    Also ich habe alles nochmal neu durprobiert und konnte zu keinem neuen Ergebnis gelangen, das Iframe wird im IE geblockt und im Chrome bekomme ich es erst gar nicht angezeigt.

    Fehlermeldung im IE lautet wörtlich:

    Dieser Inhalt kann nicht in einem Frame angezeigt werden.

    Um die Information zu schützen, die Sie auf dieser Website eingeben, hat der Herausgeber dieser Inhalte das Anzeigen der Inhalte in einem Frame untersagt.

    Erstaunlicher weise habe ich das nun auch mal mit dem Firefox probiert und siehe da SharePoint kann im CRM angezeigt werden. Somit ist die Listcomponente richtig installiert und auch der Zugriff von CRM sowie SharePoint funktioniert.

    Die Frage die sich mir nun stellt, warum geht das nicht auch mit dem IE und warum will SharePoint nicht im Frame angezeigt werden?

    Mittwoch, 5. März 2014 09:11
  • Wenn das "nur" auf diesem PC nicht im IE läuft, dann kann es durchaus an der loaklen office installation liegen. Falls dem so ist deinstalliere office räume die pfade auf und installiere es neu. Geht um die addins für den IE, so ähnlich:

    http://garagebox.org/tips/334-sharepoint-when-multiple-upload-documents-greyed-out-in-internet-explorer.html


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Mittwoch, 19. März 2014 14:01