none
Benutzerdefinierte Menüleiste wird nicht angezeigt

    Frage

  • Hallo zusammen,

    folgendes merkwürdige Problem:

    eine Access-ADE-Anwendung wird per Starteranwendung verteilt, sodass jeder Anwender automatisch immer die aktuellste Version - und alle immer die gleiche - erhalten. Die Anwendung enthält eine aus Acc2003 übernommene Menüleiste, die auch als einzige angezeigt wird(keine Ribbons; die Anwendung wurde ursprünglich mit Acc2003 entwickelt).

    Auf einem Arbeitsplatz wird diese Menüleiste seit heute nicht mehr angezeigt. Auch nach Umgehung der Starteinstellungen erscheint der Add-Ins-Tab nicht mit dem Menü. Unter Access-Optionen | Aktuelle Datenbank wird das Menü angezeigt und ist auch ausgewählt.

    Habe schon im Direktfenster "Application.Commandbars("Mein Menü").enabled = True" eingegeben - ohne Erfolg.

    Hat jemand eine Idee?
    Vielen Dank im Voraus.

    Viele Grüße,
    Michael Schörner

    Donnerstag, 10. März 2011 12:32

Antworten

  • Hallo Michael,

    Michael Schörner schrieb folgendes:

    eine Access-ADE-Anwendung wird per Starteranwendung verteilt, sodass
    jeder Anwender automatisch immer die aktuellste Version - und alle
    immer die gleiche - erhalten. Die Anwendung enthält eine aus
    Acc2003 übernommene Menüleiste, die auch als einzige angezeigt
    wird(keine Ribbons; die Anwendung wurde ursprünglich mit Acc2003
    entwickelt).

    Auf einem Arbeitsplatz wird diese Menüleiste seit heute nicht mehr
    angezeigt. Auch nach Umgehung der Starteinstellungen erscheint der
    Add-Ins-Tab nicht mit dem Menü. Unter Access-Optionen | Aktuelle
    Datenbank wird das Menü angezeigt und ist auch ausgewählt.

    Habe schon im Direktfenster "Application.Commandbars("Mein
    Menü").enabled = True" eingegeben - ohne Erfolg.

    Probiere folgendes:

    1. Lösche das Menü aus der Accdb

       Application.Commandbars("Mein Menü").delete

    2. Starte die accdb neu
    3. Importiere das Menü aus der alten mdb.
    4 Neustart der accdb.

    Gruß
    Gunter


    Access FAQ: http://www.donkarl.com

          http://www.avenius.de - http://www.AccessRibbon.de
    http://www.ribboncreator.de - http://www.ribboncreator2010.de

    Donnerstag, 10. März 2011 12:53
    Moderator

Alle Antworten

  • Hallo Michael,

    Michael Schörner schrieb folgendes:

    eine Access-ADE-Anwendung wird per Starteranwendung verteilt, sodass
    jeder Anwender automatisch immer die aktuellste Version - und alle
    immer die gleiche - erhalten. Die Anwendung enthält eine aus
    Acc2003 übernommene Menüleiste, die auch als einzige angezeigt
    wird(keine Ribbons; die Anwendung wurde ursprünglich mit Acc2003
    entwickelt).

    Auf einem Arbeitsplatz wird diese Menüleiste seit heute nicht mehr
    angezeigt. Auch nach Umgehung der Starteinstellungen erscheint der
    Add-Ins-Tab nicht mit dem Menü. Unter Access-Optionen | Aktuelle
    Datenbank wird das Menü angezeigt und ist auch ausgewählt.

    Habe schon im Direktfenster "Application.Commandbars("Mein
    Menü").enabled = True" eingegeben - ohne Erfolg.

    Probiere folgendes:

    1. Lösche das Menü aus der Accdb

       Application.Commandbars("Mein Menü").delete

    2. Starte die accdb neu
    3. Importiere das Menü aus der alten mdb.
    4 Neustart der accdb.

    Gruß
    Gunter


    Access FAQ: http://www.donkarl.com

          http://www.avenius.de - http://www.AccessRibbon.de
    http://www.ribboncreator.de - http://www.ribboncreator2010.de

    Donnerstag, 10. März 2011 12:53
    Moderator
  • Hallo Gunter,

    besten Dank, das hat´s gebracht.

    Was mich aber irritiert, ist, dass ich die Anwendungsdatei durch die auf dem Server ersetzt habe, die ja augenscheinlich bei allen anderen funktioniert, aber in diesem Fall nicht. Aber, wie es so schön heißt: Wenn's schee macht...

    Viele Grüße,
    Michael

    Donnerstag, 10. März 2011 13:17