none
Fehleranzeige #Name? oder #Typ?

    Frage

  • Hallo,

    ich wollte eine Tabelle "Monster" mit der Tabelle "Runen" verbinden, was auch funktioniert. Dann möchte ich in einem darauf basierenden Formular ungebundene Felder einrichten, in denen die Werte zu jedem Monster addiert werden. Es ist keine mathematische Herausforderung und die Ausdrücke und Formeln sind alle da. Im Formular bekomme ich #Name?.

    Dann habe ich eine Abfrage gemacht und die aufaddierten Werte sind alle korrekt und ich kann sie auch in einem Formular anzeigen. Jetzt brauche ich eigentlich nur den Wert aus der Abfrage mit dem ungebundenen Feld in meinem "Monster Runen"- Formular verbinden und müsste die Werte angezeigt bekommen. Nein! Wieder #Name?! Und zwar wenn ich die Werte direkt aus der Abfrage nehme. Mache ich aus der Abfrage ein neues Formular, bekomme ich die Werte in "Monster Runen" angezeigt, aber nur wenn ich das Abfrageformular geladen habe. Der Hinweis zu dem Fehler #Name?, dass Felder mit gleichem Namen verwendet werden, kann nicht richtig sein, denn in der Abfrage heißen die Felder "SummevonHP" usw.

    Normalerweise mache ich solchen Sachen mit Excel und ich hab dies auch in diesem Fall gemacht, dachte aber, es wäre schöner über Access. Das ist doch einfachste Datenbankerstellung mit Summenberechnung und normalerweise in 2 Stunden erledigt. Ich bin frustriert...das ist für mich kein Fortschritt! Was mache ich falsch?

    Gruß, Broncho

    Sonntag, 23. August 2015 11:20

Alle Antworten

  • [...]

     Wieder #Name?! Und zwar wenn ich die Werte direkt aus der Abfrage nehme. Mache ich aus der Abfrage ein neues Formular, bekomme ich die Werte in "Monster Runen" angezeigt, aber nur wenn ich das Abfrageformular geladen habe. [...]

    Das deutet für mich darauf, dass im ungebundene Feld etwas nicht richtig referenziert wird. Wenn du Felder aus der Abfrage verwenden willst, musst du sie in der Datensatzquelle des Formulars einbinden, oder die Werte mit Hilfe von VBA Code einfüllen. Kannst du den genauen Ausdruck angeben, der den #Name?-Fehler verursacht?

    Matthias Kläy, Kläy Computing AG

    Sonntag, 23. August 2015 18:16