none
Probleme mit Windows Azure SDK

    Frage

  • Hallo an alle,

    Nach der Installation des Windows Azure SDK 1.4 auf meinem Laptop habe ich versucht, ein bestehendes Azure Projekt zu starten und bekomme, sobald das Visual Studio den Compute/Storage Emulator starten will folgende Fehlermeldung:

    System.ServiceModel.FaultException`1 was unhandled
    Message: Diese Zugriffssteuerungsliste liegt nicht in der kanonischen Form vor und kann aus diesem Grund nicht geändert werden.

    In den Details zu der Exception steht noch folgendes

    {Ein ExceptionDetail, vermutlich erstellt durch IncludeExceptionDetailInFaults=TRUE, mit dem Wert:
    System.InvalidOperationException: Diese Zugriffssteuerungsliste liegt nicht in der kanonischen Form vor und kann aus diesem Grund nicht geändert werden.
       bei System.Security.AccessControl.CommonAcl.ThrowIfNotCanonical()
       bei System.Security.AccessControl.CommonAcl.AddQualifiedAce(SecurityIdentifier sid, AceQualifier qualifier, Int32 accessMask, AceFlags flags, ObjectAceFlags objectFlags, Guid objectType, Guid inheritedObjectType)
       bei System.Security.AccessControl.DiscretionaryAcl.AddAccess(AccessControlType accessType, SecurityIdentifier sid, Int32 accessMask, InheritanceFlags inheritanceFlags, PropagationFlags propagationFlags)
       bei System.Security.AccessControl.CommonObjectSecurity.ModifyAccess(AccessControlModification modification, AccessRule rule, Boolean& modified)
       bei System.Security.AccessControl.CommonObjectSecurity.AddAccessRule(AccessRule rule)
       bei Microsoft.WindowsAzure.Internal.Common.RuntimeEnvironmentContext.AddPermissions(String rootPath, RegistryKey regKey, IdentityReference[] identites)
       bei Microsoft.WindowsAzure.ServiceRuntime.IISConfigurator.Security.AddAppPoolToDevFabricCloudDriveUser(RegistryKey devPathKey, DirectoryInfo devPath, String appPoolName, String appPoolSid)
       bei Microsoft.WindowsAzure.ServiceRuntime.IISConfigurator.IISConfigurator.Deploy(String roleId, WebAppModel appModel, String roleRootDirectory, String sitesDestinationDirectory, String diagnosticsRootFolder, String roleGuid, Dictionary`2 globalEnvironment)
       bei SyncInvokeDeploy(Object , Object[] , Object[] )
       bei System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
       bei System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
       bei System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
       bei System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage4(MessageRpc& rpc)
       bei System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)}

    Ich habe daraufhin geprüft ob der IIS in der Windows Systemsteuerung aktiviert ist, aber das ist nicht das Problem.

    Sowohl Visual Studio als auch die Azure Tools wurden mit Admin-Rechten gestartet.

    Kann mir jemand mit dem Problem weiterhelfen?

     

    Vielen Dank schoneinmal für Antworten,

    Tino

     

    Mittwoch, 10. August 2011 11:48

Alle Antworten