none
W7-64 Access97

    Frage

  • Hallo Guru's

    Wie bekommt mann unter W7-64 Access97 am laufen, bekomme die Fehlermeldung das system.mdw nicht in c:\windows\system32 gefunden werden kan!!!

    Wo komt diese Datei her?

    Dieser Fehler kommt sowohl bei Programm.mdb als auch bei Access.exe starten.

    Gr.

    Jan

    Donnerstag, 3. November 2011 14:37

Antworten

Alle Antworten

  • Am einfachsten in einer virtuellen Maschine. Dafür gibt es im Speziellen den Windows XP-Modus.

    Donnerstag, 3. November 2011 14:50
    Moderator
  • Hallo Iemhoff,

    Iemhoff schrieb folgendes:

    Wie bekommt mann unter W7-64 Access97 am laufen, bekomme die
    Fehlermeldung das system.mdw nicht in c:\windows\system32 gefunden
    werden kan!!!

    Wo komt diese Datei her?

    Dieser Fehler kommt sowohl bei Programm._mdb_ als auch bei
    Access._exe_ starten.

    C:\Windows ist schreibgeschützt. Das beste ist wie von Stefan
    geschrieben eine Virtuelle Maschine. Was Du nicht machen solltest wäre
    die UAC abzuschalten.

    Gruß
    Gunter


    Access FAQ: http://www.donkarl.com

          http://www.avenius.de - http://www.AccessRibbon.de
    http://www.ribboncreator.de - http://www.ribboncreator2010.de

    Donnerstag, 3. November 2011 15:37
    Moderator
  • Hallo Gunter

    Du schriebst:     Was Du nicht machen solltest wäre die UAC abzuschalten.  

    Aber morgen will ich das  einfach mal  austesten.

          http://www.windows-faq.de/2009/10/23/uac-ausschalten-unter-windows-7-user-account-control/

    Beim starten von der "Virtuelle Maschine" geht Zeit flöhten oder gibt es da auch noch trickse?

     

    Ich muß jetzt auf Access97 zurück greifen weil die ÜBERSETZUNG von 97 auf 2010 nicht klappt.

    1001 Fehler und oder es kommen einfach keine Formular auf dem CRT (ohne irgend welche Meldungen)

    Shape-Fehler und und...

     

    Gruß

    Jan

     

     

     

     

     

    Donnerstag, 3. November 2011 17:19
  • Hallo Iemhoff,

    Iemhoff schrieb folgendes:

    Beim starten von der "Virtuelle Maschine" geht Zeit flöhten oder gibt es da auch noch trickse?

    Du startest im Prinzip einen neuen PC mit Betriebssystem. Viel zu trixen gibt es nicht.

    Ich muß jetzt auf Access97 zurück greifen weil die ÜBERSETZUNG von 97 auf 2010 nicht klappt.

    1001 Fehler und oder es kommen einfach keine Formular auf dem CRT (ohne irgend welche Meldungen)

    Du wirst einen Fehler nach dem anderen beseitigen müssen.
    Fange zuerst bei den Verweisen an und arbeite Dich durch alle
    restlichen Formulare / Berichte und Modulen durch.

    Gruß
    Gunter


    Access FAQ: http://www.donkarl.com

          http://www.avenius.de - http://www.AccessRibbon.de
    http://www.ribboncreator.de - http://www.ribboncreator2010.de

    Donnerstag, 3. November 2011 18:32
    Moderator
  • Hallo,

    Iemhoff wrote:

    Hallo Gunter

    Du schriebst:     *Was Du nicht machen solltest wäre die UAC abzuschalten.*  

    Aber morgen will ich das  einfach mal  austesten.

    Ich muß jetzt auf Access97 zurück greifen weil die ÜBERSETZUNG von 97 auf
    2010 nicht klappt. 1001 Fehler und oder es kommen einfach keine Formular
    auf dem CRT (ohne irgend welche Meldungen) Shape-Fehler und und...

    A97-DBs funktionieren i.d.R. nach der Konvertierung zu A2010 problemlos.
    Wenn das bei dir nicht der Fall ist, solltest du der Sache auf den Grund
    gehen. UAC abschalten ist wie Haustuer offenlassen, oder weisst du
    ausnahmslos, was sich hinter dem naechsten Click verbirgt? ;-)

    Gruss - Peter


    Mitglied im http://www.dbdev.org
    FAQ: http://www.donkarl.com

    Donnerstag, 3. November 2011 20:36
    Moderator
  • 1001 Fehler und oder es kommen einfach keine Formular auf dem CRT (ohne irgend welche Meldungen)
    hmm, du meinst jetzt hoffentlich keinen Röhrenmonitor.
    Freitag, 4. November 2011 08:17
    Moderator
  • CRT hätte LCD sein müssen!!!  :-) Aber die PROBLEME BLEIBEN.   :-(

     

    Aber das 97 so unter 2010 läuft muß mir einmal eine(r) ZEIGEN!!!

     

    (Siehe:A97-DBs funktionieren i.d.R. nach der Konvertierung zu A2010 problemlos.)

     

    Malzeit

    Jan

     

    Freitag, 4. November 2011 11:14
  • Hallo Iemhoff,

    Iemhoff schrieb folgendes:

    Aber das 97 so unter 2010 läuft muß mir einmal eine(r) ZEIGEN!!!
    (Siehe:A97-DBs funktionieren i.d.R. nach der Konvertierung zu A2010 problemlos.)

    Diese Aussage kann ich bestätigen solange Du keine ocx Controls
    verwendet wurden und die Datenbank keine aus < A97 konvertierte
    Datenbank ist.

    Anderenfalls ist halt einiges zum Anpassen, welches aber auch lösbar
    sein sollte.

    Gruß
    Gunter


    Access FAQ: http://www.donkarl.com

          http://www.avenius.de - http://www.AccessRibbon.de
    http://www.ribboncreator.de - http://www.ribboncreator2010.de

    Freitag, 4. November 2011 11:19
    Moderator
  • Hallo,

    Iemhoff wrote:

    Aber das 97 so unter 2010 läuft muß mir einmal eine(r) ZEIGEN!!!
    (Siehe:A97-DBs funktionieren i.d.R. nach der Konvertierung zu A2010 problemlos.)

    Meine Antwort bezog sich auf A97 in A2010 generell, nicht bezogen auf ULS,
    welche dort fuer das neue accdb-Format bekanntlich nicht mehr unterstuetzt
    wird.

    Du koenntest den Zwischenschritt ueber A02/A03 gehen, dort wird auch ULS
    sauber konvertiert. Diese DB laesst sich auch unter A2010 mit ULS oeffnen
    und man kann sogar den ULS-Assistenten per Direktfenster aufrufen.

    Weiteres Wissenswertes zum Thema:

    http://office.microsoft.com/en-us/access-help/set-or-change-access-2003-user-level-security-in-access-2010-HA010341994.aspx#BM3

    Gruss - Peter


    Mitglied im http://www.dbdev.org
    FAQ: http://www.donkarl.com

    Freitag, 4. November 2011 13:06
    Moderator
  • Hallo Peter,

    Peter Doering [MVP] schrieb folgendes:

    Iemhoff wrote:

    Aber das 97 so unter 2010 läuft muß mir einmal eine(r) ZEIGEN!!!
    (Siehe:A97-DBs funktionieren i.d.R. nach der Konvertierung zu A2010 problemlos.)

    Meine Antwort bezog sich auf A97 in A2010 generell, nicht bezogen auf ULS,

    habe ich was verpasst? Wo wird von ULS gesprochen bzw. geschrieben?

    Gruß
    Gunter


    Access FAQ: http://www.donkarl.com

          http://www.avenius.de - http://www.AccessRibbon.de
    http://www.ribboncreator.de - http://www.ribboncreator2010.de

    Freitag, 4. November 2011 13:59
    Moderator
  • Hallo Gunter,

    Am 04.11.2011 14:59, schrieb Gunter Avenius [MVP]:

    habe ich was verpasst? Wo wird von ULS gesprochen bzw. geschrieben?

    ich denke, dieser Film läuft gerade in einem anderen (privaten) Kino. ;-)

    CU


    Thomas

    Homepage: www.Team-Moeller.de

    Freitag, 4. November 2011 17:39
  • Hallo Gunter,

    Gunter Avenius [MVP] wrote:

    Peter Doering [MVP] schrieb folgendes:

    Iemhoff wrote:

    Aber das 97 so unter 2010 läuft muß mir einmal eine(r) ZEIGEN!!!
    (Siehe:A97-DBs funktionieren i.d.R. nach der Konvertierung zu A2010 problemlos.)

    Meine Antwort bezog sich auf A97 in A2010 generell, nicht bezogen auf ULS,

    habe ich was verpasst? Wo wird von ULS gesprochen bzw. geschrieben?

    Aufgrund des Kommentars ...

    | Aber das 97 so unter 2010 läuft muß mir einmal eine(r) ZEIGEN!!!

    ... hab ich verzweifelt nach Gruenden gesucht, warum es wohl nicht klappen
    sollte und im OP folgendes gefunden:

    | Wie bekommt mann unter W7-64 Access97 am laufen, bekomme die
    | Fehlermeldung das system.mdw nicht in c:\windows\system32 gefunden
    | werden kan!!!

    Daher nahm ich an, dass seine A97-DB wohl per ULS geschuetzt ist, und in
    der Tabelle "Conversion Errors" ein Eintrag fuer -3831 stehen sollte.

    Alles klar? ;-)

    Gruss - Peter


    Mitglied im http://www.dbdev.org
    FAQ: http://www.donkarl.com

    Freitag, 4. November 2011 18:30
    Moderator
  • Hallo Thomas,

    Thomas Möller [MVP] wrote:

    Am 04.11.2011 14:59, schrieb Gunter Avenius [MVP]:

    habe ich was verpasst? Wo wird von ULS gesprochen bzw. geschrieben?

    ich denke, dieser Film läuft gerade in einem anderen (privaten) Kino. ;-)

    Schon in diesem Kino, aber als Vorfilm ;-)
    Urspruenglich ging es dem OP ja darum, dass sich die A97-mdb nicht
    problemlos nach A2010 konvertieren lassen wollte ...

    | Ich muß jetzt auf Access97 zurück greifen weil die ÜBERSETZUNG von 97 auf
    | 2010 nicht klappt.

    ... was ich in Abrede stelle.

    Mir geht es in meinen Antworten nicht darum, A97 unter W7/64 zum laufen zu
    bringen, was wohl der Hauptfilm des Threads ist ;-)

    Gruss - Peter


    Mitglied im http://www.dbdev.org
    FAQ: http://www.donkarl.com

    Freitag, 4. November 2011 18:37
    Moderator