none
Warum wird mit Firefox die session_start Methode in der Gloabal.asax bei einem Seitenwechsel nochmals aufgerufen. InternetExplorer ruft die Session_Start nicht auf RRS feed

  • Allgemeine Diskussion

  • Hallo Welt,

    Ich habe eine Seite(CA.cs) in der ein wert einer Session["probertychanged"]="true" oder "false" zugewiesen wird. In der Masterpage wird dieser Wert geprüft. Wenn er true ist, wird ein linkButton auf visible=true gesetzt.

    Wenn ich jetzt mit Firefox auf diesen linkbutton klicke, springt das Programm wieder in die Session_Start methode, was nicht sein sollte. Wenn ich InternetEexplorer benutze pasiert das nicht.

    Der Link hat einen relativen Pfad

    Response.Redirect(@"~/Contents/Stammdaten/Benutzerdatenaenderung.aspx");

    Kann mir einer Sagen, woran es liegen könnte das die Session_Start in der Gloabal.asax wieder aufgerufen wird.

    Danke im Voraus

    I.Zaytoun
    Dienstag, 15. November 2011 09:42

Alle Antworten

  • Hallo intern2011,

    Man sollte die Cookies Einstellung in Firefox aktivieren:

    Enabling cookies in Mozilla/Firefox

    Viele Grüße,

    Bogdan


    Ich bin gerne bei den Foren. Es kommt von Herzen. Es wird aber keine implizite oder sonstige Garantie für die geposteten Antworte / Informationen gewährt. Hier auch die Forenregeln.
    Freitag, 18. November 2011 15:41
  •  

    Hallo Bogdan,

    danke für die Antwort. Die habe ich aktiviert und es hat sich trotzdem nichts geändert. 

    viele Grüße

    I.zaytoun

    Sonntag, 20. November 2011 21:43
  • Hallo intern2011,

    leer im Firefox mal bitte deinen Cache und lösch alle Cookies und teste das Verhalten dann erneut. Sollte das Problem weiterhin bestehen, schnapp Dir die Internet Explorer Developer Toolbar (http://www.microsoft.com/download/en/details.aspx?id=18359) und für Firefox den Firebug (https://addons.mozilla.org/de/firefox/addon/firebug/) und schau Dir in der Netzwerkansicht die Requests an, die beide Browser abschicken. Evtl. helfen die Informationen weiter. Vorher aber am besten in beiden Browsern die Cookies löschen und die Seite neu ansurfen, um ein möglichst ähnliches Startbild zu bekommen.

    Mittwoch, 21. Dezember 2011 22:43