none
Access 2016 dbase-Import Umlaute falsch

    Frage

  • Hallo,

    Access 2016 kann plötzlich dbase-Dateien importieren. Das ist wunderbar. Leider sind die Umlaute falsch bzw. die Einstellung des Zeichensatzes ist nicht analog wie bei Access 2010 in der Registry unter LocalMachine\SOFTWARE\Microsoft\Office\16.0\Access Connectivity Engine\Engines\Xbase\DataCodePage" möglich. Gibt es andere Einstellung? Oder wurde es vergessen?

    Gruß

    Reinhold

    Freitag, 4. November 2016 16:19

Alle Antworten

  • Hallo Reinhold,

    Wenn Du die 32-Bit Version installiert hast, käme im Registpfad noch  WOW6432Node hinzu, dort solltest Du dann ggf. noch mal schauen. Sollte sich dort auch nichts finden schau Dir mal die Anleitung an:
    Enabling xbase/DBF support in Microsoft Office/Access 2013

    Die Registry Einträge sollten mit Anpassung der Version auch für Access 2016 funktionieren, so man nicht was ganz Neues erfunden hat - was ich bezweifle. Beachte das Wow6432Node nur bei Office 32 Bit gilt - bei 64 Bit entfernen. Vorher bestehende Einträge sicherheitshalber über den Registry Editor sichern.

    Gruß Elmar

    Freitag, 4. November 2016 19:22
  • Hallo Elmar,

    ich hatte den ganzen Baum "Access Connectivity Engine" von 14.0 nach 16.0 kopiert. Zeigt aber keine Wirkung.

    In 16.0 ist der ganze Baum nicht vorhanden gewesen und der dBase-Zugriff funktioniert. Nur fehlt halt die Einstellmöglich der DataCodePage. Ich denke das wurde doch etwas anders gelöst.

    Gruß
    Reinhold

    Samstag, 5. November 2016 18:54
  • Am 05.11.2016 schrieb Gerard, Reinhold:

    ich hatte den ganzen Baum "Access Connectivity Engine" von 14.0 nach 16.0 kopiert. Zeigt aber keine Wirkung.

    Und da ist auch ganz sicher WOW6432Node dabei? Wenn nein, dann mußt
    Du den natürlich im richtigen Teil anlegen.

    Servus
    Winfried


    Access-FAQ: http://www.donkarl.com/AccessFAQ.htm Access-Stammtisch: http://www.access-muenchen.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/
    vbeTwister: http://www.vbetwister.com/

    Samstag, 5. November 2016 20:28
  • Ich teste das bei einem 64bit Access und habe es hier angelegt:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Access\Access Connectivity Engine\Engines\Xbase

    DataCodePage=ANSI

    Gruß
    Reinhold

    Sonntag, 6. November 2016 12:53
  • Ich habe es jetzt gefunden. Das ist jetzt im Bereich "ClicktoRun"

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\Software\Microsoft\Office\16.0\Access Connectivity Engine\Engines\Xbase

    Gruß
    Reinhold

    Sonntag, 6. November 2016 13:04
  • Hallo Reinhold,

    Abseits des <Kopfschütteln ein>idiotisch langen Registry Pfade<Kopfschütteln aus/>, hat sich also nichts geändert, nur bist Du Opfer von Click To Run geworden ;(

    Gruß Elmar

    Sonntag, 6. November 2016 17:53
  • Am 06.11.2016 schrieb Elmar Boye:

    Abseits des <Kopfschütteln ein>/idiotisch langen Registry Pfade/<Kopfschütteln aus/>, hat sich also nichts geändert, nur bist Du Opfer vonClick To Run <https://technet.microsoft.com/en-us/library/jj219427.aspx> geworden ;(

    Nett ist ja auch das hier:

    Benefits of using Click-to-Run:
    Up-to-date from the start and kept up-to-date automatically. No need
    to download and install updates manually.

    Wenn Updates anstehen, wird das komplette Paket erneut gedownloadet
    und installiert.
    Servus
    Winfried


    Access-FAQ: http://www.donkarl.com/AccessFAQ.htm Access-Stammtisch: http://www.access-muenchen.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/
    vbeTwister: http://www.vbetwister.com/

    Sonntag, 6. November 2016 19:26
  • Hallo,

    leider installiert sich der dbase-Import nicht bei der Runtime. Zumindest nicht bei meinem Testrechner. Da die meisten meiner Kunden keine Vollversion von Access haben muss ich weiter bei Access 2010 blieben. Schade.

    Viele Grüße
    Reinhold

    Donnerstag, 10. November 2016 18:18
  • Hallo, hatte das gleiche Problem.

    Wer nicht in der Registry hantieren möchte, kann einen kleinen Umweg über Excel nehmen.
    Excel öffnen und Datei XXX.dbf öffnen. Sonderzeichen werden falsch angezeigt.

    Datei als XXXX.csv mit CSV-MSDOS speichern.
    Excel erneut öffnen und Datei anklicken.
    Sonderzeichen sind weg. Dann Datei im gewünschten Format speichern.

    Funktioniert nur bis maximale Azahl Datensätze in Excel.

    Grüße Dirk

    Donnerstag, 4. Januar 2018 11:29