none
UWP app fails to start because of 'Entry Point Not Found' exception RRS feed

  • Frage

  • We are not able to start the release version of our app. Error in output is "Entry Point Not Found". I googled for the error, other people seem to have the same problem, but no solution. They say it works without the option "Compile with .NET Native tool chain' ot if you reduce the minimum target version to creators update instead of fall creatrs update, but we need the fall creators update for suscriptions.
    Donnerstag, 15. März 2018 09:26

Alle Antworten

  • Hallo,

    Du bist hier im deutschen MS Forum, schreib deswegen auch bitte deutsch.

    Um die App an den Store zu schicken ist .NET Native zwingend erforderlich. Versuch die App auf Release zu debuggen. Dafür solltest Du das "Code optimieren" in den Build Einstellungen ausschalten. .NET Native ist strickter als .NET Framework. NULL Werte sind oft ein Problem. Debugging .NET Native Windows Universal Apps


    Gruß Thomas
    Sage nie, ich kann es nicht - sage nur, ich kann es noch nicht!
    Dev Apps von mir: Icon für UWP,  UI Strings
    Andere Dev Apps: UWP Community Toolkit Sample App

    Donnerstag, 15. März 2018 15:29
  • Danke für den Hinweis. Debuggen ist nicht möglich, er kommt nicht einmal zum ersten Befehl.


    MS

    Dienstag, 20. März 2018 23:44
  • Na das ist hart und hatte das so auch noch nicht. Dir wird nichts anderes übrig bleiben als einen neue App zu erstellen und nach und nach den Code zu kopieren. Du kannst natürlich auch in der jetzigen App ganze Blöcke auskommentieren.

    Bist Du dir ganz sicher da der Debugger noch nicht mal in die Main Methode in der App.xaml.cs springt

    public App()
    {
        this.InitializeComponent();
        this.Suspending += OnSuspending;
    }


    Gruß Thomas
    Sage nie, ich kann es nicht - sage nur, ich kann es noch nicht!
    Dev Apps von mir: Icon für UWP,  UI Strings
    Andere Dev Apps: UWP Community Toolkit Sample App

    Mittwoch, 21. März 2018 00:06
  • Ja ganz sicher. Wenn cih in der Debug Variante die .NET Tool Chain aktiviere habe ich das gleiche Problem.  Ich werde morgen ein neues Projekt erstellen und es einmal versuchen.

    MS

    Mittwoch, 21. März 2018 00:50
  • Tut mir leid dann weiß ich leider auch nicht mehr weiter.

    Du könntest versuch eine neue App zu erstellen und diese sofort im Release zu bauen. Es könnte ja auch an der SDK liegen


    Gruß Thomas
    Sage nie, ich kann es nicht - sage nur, ich kann es noch nicht!
    Dev Apps von mir: Icon für UWP,  UI Strings
    Andere Dev Apps: UWP Community Toolkit Sample App


    Mittwoch, 21. März 2018 12:57