none
net.Framework zerschossen RRS feed

  • Frage

  • Hallo Leute,

    wahrscheinlich bin ich der dümmste anzunehmende User, jedenfalls habe ich mein Framework komplett zerlegt. Ursache war das KB2656353, welches nicht installiert werden konnte. In anderen Foren fand ich dann den Hinweis, das Framework 1.1 und 2.0 bedenkenlos deinstalliert werden können. Leider war das wohl nicht richtig. Jetzt funktioniert auch 3.5 und 4.0 nicht mehr. Auch der Netzmanager von t-online funktioniert nicht mehr. Ich kann allerdings auch das 2.0, das 3.5 und das 4.0 nicht mehr richtig installieren. Das setup bricht immer ab.

    Was kann ich tun, damit ich das alles wieder ans laufen bekomme?

    Samstag, 18. Februar 2012 11:05

Antworten

  • Hallo Helmut,

    das Framework 2.0 kann/darf man nicht deinstallieren, wenn man das Framework 3.5 einsetzen will/muss. Denn 3.5 setzt auf 2.0 auf.

    Das Framework 4.0 läuft eigenständig und dürfte von der Deinstallation der Versionen 1.1 und 2.0 nicht beeinträchtigt werden.

    Welche Version nun das T-Online Dingens verwendet, weiß ich nicht.

    ---

    Ich würde dir empfehlen, nochmal komplett alles, was nach .NET Framework aussieht, zu deinstallieren (soweit möglich, je nach Betriebssystem geht das nämlich gar nicht so einfach) und dann erneut zu installieren.

    Wenn gar nichts funktioniert, schau dir bitte mal das .NET Framework Cleanup Tool an. Damit wäre es dann ggfs. möglich, die einzelnen Versionen zu entfernen.

      http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    Samstag, 18. Februar 2012 11:48
    Moderator

Alle Antworten

  • Hallo Helmut,

    das Framework 2.0 kann/darf man nicht deinstallieren, wenn man das Framework 3.5 einsetzen will/muss. Denn 3.5 setzt auf 2.0 auf.

    Das Framework 4.0 läuft eigenständig und dürfte von der Deinstallation der Versionen 1.1 und 2.0 nicht beeinträchtigt werden.

    Welche Version nun das T-Online Dingens verwendet, weiß ich nicht.

    ---

    Ich würde dir empfehlen, nochmal komplett alles, was nach .NET Framework aussieht, zu deinstallieren (soweit möglich, je nach Betriebssystem geht das nämlich gar nicht so einfach) und dann erneut zu installieren.

    Wenn gar nichts funktioniert, schau dir bitte mal das .NET Framework Cleanup Tool an. Damit wäre es dann ggfs. möglich, die einzelnen Versionen zu entfernen.

      http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    Samstag, 18. Februar 2012 11:48
    Moderator
  • Hallo Stefan,

    vielen Dank für Deine Hilfe. Ich habe gestern den ganzen Tag Framework neu aufgesetzt und jetzt funktioniert alles wieder auch der Netzmanager.

    Das Tool hat mir sehr geholfen. Vielen Dank.

    Montag, 20. Februar 2012 11:21