none
Access Web Datenbank funktioniert nicht mehr nach Dienstupdate Office 365 auf Version 2013. Microsoft Support reagiert nicht.

    Frage

  • Hallo Zusammen,

    am 1. Mai wurde für unser Office 365 ein Dienst-Upgrade auf Office 2013 durchgeführt.

    Seitdem funktioniert unsere Access-Datenbank nicht mehr. Die Tabellen sind im Frontend zwar noch sichtbar, das System

    meldet aber einen Fehler sobald wir eine Tabelle aufrufen.

    Wir haben uns direkt am 2. Mai an den Microsoft Support gewendet. Der Support konnte das Problem aber nicht lösen.

    Uns wurde zugesichert, dass der Second Level Support uns kontaktiert. Das ist aber bis heute (!) nicht geschehen.

    Eine entsprechende Serviceanfrage wurde gestellt und steht auf dem Status "Escalated". Auch auf mehrere Nachfragen

    unsererseits wurde nur in der Form reagiert "Entschuldigung, aber wir können auch nicht verstehen, dass der Second

    Level Support Sie noch nicht kontaktiert hat. Wir kümmern uns darum." Passiert ist dann aber nichts.

    Die Webdatenbank ist sehr umfangreich (ca. 60 Tabellen und zugehörige Abfragen, Forms, Code...). Sie ist auch

    essentiell wichtig für unsere Arbeit. 10 Personen arbeiten eigentlich ständig damit.

    Die Webdatenbank lässt sich öffnen. Das System meldet allerdings "Alle SharePoint Tabellen haben keine Verbindung.

    Wenn ich die Verbindung für alle Tabellen wiederherstellen möchte: Button "Verbindungen für alle Tabellen

    wiederherstellen" funktioniert das nicht. Access meldet: "Microsoft Access kann für mindestens eine der Tabellen, die

    keine Verbindung haben, die Verbindung nicht wiederherstellen. Prüfen Sie die Netzwerkverbindung und die

    Serververfügbarkeit."

    Also prüfe ich Netzwerkverbindung und Serververfügbarkeit:

    - Netzwerkverbindung (in unserem Fall Verbindung zum Internet):Ist definitiv vorhanden.

    - Serververfügbarkeit: Die den Tabellen zugrundeliegenden SharePoint Listen sind auf dem Server im Office 365

    vorhanden. Ich kann sogar eine Verknüpfung (Externe Daten / Weitere / SharePoint-Liste) mit einer Tabelle auf dem

    Server von der selben Access-DB aus herstellen. Die verknüpfte Tabelle lässt sich dann auch öffnen und die Werte

    lassen sich bearbeiten.

    Wichtig zu wissen: Unsere DB arbeitet NICHT mit verknüpften Tabellen, sondern ist eine "echte" Webdatenbank.

    Mir ist etwas aufgefallen, dass evtl. zur Lösung des Problems beitragen könnte. Ich möchte dies am Beispiel der

    tblAnwesenheitszeiten, sowie den gezeigten Einstellungen in der DB erläutern:

    Access zeigt unter "Datei / Informationen / Informationen zur Datenbank" folgenden Verbindungspfad an:

    "h ttp://dave24.sharepoint.com/j" Das ist auch eigentlich so korrekt. Wenn ich diesen Link mit dem Internet-Explorer

    öffne, öffnet sich jedoch eine "h ttps://dave24.sharepoint.com/". Es wird also eine h ttps-Seite geöffnet.

    Den Speicherort der tblAnwesenheitszeiten benennt Access als

    h ttp://dave24.sharepoint.com/j/Lists/tblAnwesenheitszeiten/Allitemsg.aspx. Wenn ich zu dieser SharePoint-Liste

    manuell eine verknüpfte Tabelle erstellen möchte (Externe Daten / weitere / SharePoint-Liste), funktioniert es NICHT.

    Wenn ich dasselbe versuche mit h ttps://dave24.sharepoint.com/j/Lists/tblAnwesenheitszeiten/Allitemsg.aspx DANN

    FUNKTIONIERT es.

    Der nächste Schritt wäre es, Access mitzuteilen, dass sich die der DB zugrundeliegenden SharePoint-Listen NICHT auf

    "h ttp://dave24.sharepoint.com/j", sondern auf "h ttps://dave24.sharepoint.com/j" befinden. Dann könnte das System

    evtl. wieder funktionieren.

    Bisher habe ich jedoch keine Möglichkeit gefunden, diese Einstellung zu tätigen.

    Grüße,

    Jörg Hartgen

    Sonntag, 26. Mai 2013 07:01