none
Waveshare 7 inch display doesn't work on Windows 10 IoT Core

    Frage

  • I've bought following display for my Raspberry Pi http://www.waveshare.com/7inch-hdmi-lcd-b.htm. This display requires some drivers but I don't know where I can search this. On this screen touch doesn't work and exists problems with resolution. Where can I search drivers for this screen?
    Sonntag, 1. Mai 2016 15:23

Antworten

Alle Antworten

  • you need to ask the manufacturer if he plans to support your display on windows iot core

    i recommend you use a already supported display

    Sonntag, 1. Mai 2016 15:56
    Moderator
  • You can find driver from here.

    http://www.waveshare.com/wiki/7inch_HDMI_LCD_(B)#Software



    good luck!



    Sonntag, 1. Mai 2016 16:41
  • Hi Hubot.NET,

    Further to Cyberh0me's response, you can find the compatible Hardware list at https://developer.microsoft.com/en-us/windows/iot/win10/SupportedInterfaces.htm. 

    You will need to ask the OEM of your display if they have an IoTCore capable driver*.  The site at http://www.waveshare.com/wiki/7inch_HDMI_LCD_(B)#Software claims "Version 2.1 .... When work as a computer monitor, supports Windows 10/8.1/8/7, five-points touch, and driver free

    1. Are you connecting it the same way you would a display?
    2. Have you confirmed your display is ver 2.1?
    3. Have you followed the steps on the page to confirm?

    *NOTE: There is a previous thread that confirmed as of August last year they did not support IoT Core.  https://social.msdn.microsoft.com/Forums/en-US/e7f030e9-d22d-4972-9b2f-49bf4e090db9/waveshare-touch-problem?forum=WindowsIoT

    Sincerely.

    IoTGirl

    Montag, 2. Mai 2016 05:29
    Moderator
  • Hi Ashidacchi,

    Now that you have edited your response, can you please clarify which in that list is a Windows IoT Core driver? From what I read on the site, none of these drivers are for Windows (They are for Linux & Raspian).

    Sincerely,

    IoTGirl


    Montag, 2. Mai 2016 19:04
    Moderator
  • Hi IoTGirl and HUBOT.NET,

    I'm very sorry, I've mistaken *_windows_cap_usb_touch* for Windows driver. 

    Regards.
    Dienstag, 3. Mai 2016 00:36
  • Hi 

    I'm using Waveshare 7'' Capacitive LCD Touchscreen. It was working great with Iot Core on raspberry pi 2, but on Raspberry pi 3 the touch is not firing the click events on buttons. Only pointer entered, moved, exited and so on.

    Could You help me resolve this issue??

    BR Jacob

    • Zusammengeführt IoTGirlModerator Dienstag, 21. Juni 2016 20:15 Duplicate Question
    Dienstag, 21. Juni 2016 09:24
  • Hello

    which version of IOT are you using? There appears to be serious bugs in the latest version of Windows IOT on RPi3.  

    Dienstag, 21. Juni 2016 19:36
  • Hi BR Jacob,

    Please reach out to either the Manufacturer or Seller of your hardware to confirm their support of IoTCore.

    Sincerely,

    IoTGirl

    Dienstag, 21. Juni 2016 20:20
    Moderator
  • I'm using the latest OS Version:10.0.14366.0, but tried it on the older version as well, with no luck.

    Only works with the offical version for rpi2.

    Mittwoch, 22. Juni 2016 07:46
  • Hello IoTGirl

    On the offical site of the Manufacturer you can see it's supported. It works with rpi2 but not rpi3.

    See link below, supported mini pc

    http://www.waveshare.com/product/7inch-HDMI-LCD-C.htm

    Mittwoch, 22. Juni 2016 07:48
  • @Azmarel seems you have good cards if you contact the manufacturer with your issues
    Mittwoch, 22. Juni 2016 09:36
    Moderator
  • I've send a message to the manufacturer so I will let you know when I'll get an answer.

    Searching in some other threads, I found that there are some issues with other touchscreen's since the offical Windows IoT version. It might be an operating system problem.

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/a129d36c-5873-44a6-992f-acc2c45f02a1/rp3-hid-device-touch-usb-monitor-problem

    Mittwoch, 22. Juni 2016 13:02
  • Hi Azmarel,

    I can confirm that it is not an OS problem it is a driver problem.  If you choose a device from https://developer.microsoft.com/en-us/windows/iot/win10/SupportedInterfaces.htm it is expected to have a working driver. Both this thread and the thread you mention are using devices outside of this list so you will need to confirm with the OEM that their hardware works with IoT Core.

    Sincerely,

    IoTGirl

    Mittwoch, 22. Juni 2016 16:44
    Moderator
  • Hi IoTGirl,

    In the supported devices there is only one display, and it will not work with my project.

    I need this display, and it does work with the offical version. The manufacturer did not change the display driver. It was working fine until microsoft iot core update. So something changed in the preview version that disabled my touch screen from working properly.

    Donnerstag, 30. Juni 2016 06:53
  • even if your manufacturer changed or not changed his hardware he is responsible to provide drivers for his devices

    Donnerstag, 30. Juni 2016 08:38
    Moderator
  • Isn't weird that touchscreen works perfectly on Windows 10 PC without installing any additional drivers? It uses standard HID drivers. Especially that as people said it worked with official release of Win 10 IOT core, it must be something with insider preview version. We know that manufacturer should provide drivers, but what if they do not need custom drivers and they use stadard drivers? Who is reponsible for standard drivers?
    Samstag, 2. Juli 2016 09:09
  • The HID specification does include a 'custom' profile option. If that device uses a custom profile, it is possible to explain the current unsupported IoT situation if the following is the case: that device uses a custom profile that is 'compatible' with another device that is already built-in to Windows, and so an INF file with that VID/PID would be necessary to inform Windows to use that other devices VID/PID as its driver. It is also possible that the manufacturer of that device only supplied the INF file for use with Windows 8. In that case the INF file definition would be inherited by Windows 10 Desktop, but not inherited by Windows 10 IoT; because the hardware manufacturer has not authorized it.

    You could try to find the VID/PID of the device in question and find the INF/CAT/PNF files in Windows 10 Desktop folder C:\Windows\INF\ that refer to that device. You can try to copy those files into Windows 10 IoT and reboot. If you're very lucky, it may work.

    Mark

    Dienstag, 5. Juli 2016 06:05
  • Thanks for the idea, unfortunately it did not help :(

    It does use the standard HID protocoll.

    Info from producer website:

    - Standard HID protocol, easy to be integrated into your system
    - For the Raspberry Pi, supports Raspbian, Ubuntu, Windows 10 IoT, single touch, and driver free
    - When work as a computer monitor, supports Windows 10/8.1/8/7, five-points touch, and driver free

    But only works with Win 10 Iot offical version.

     
    Dienstag, 5. Juli 2016 09:46
  • I have a same problem, can you get some idea or solution for solve the problem?

    Thank in advance

    Mittwoch, 13. Juli 2016 17:37
  • Hi Clauz,

    Please reach out to the OEM or company that sold you this display for support. At this point we are fairly confident that the firmware in this screen is not following standard HID protocol.  Other screens that do, are working.  Please see the HCL for supported devices. https://developer.microsoft.com/en-us/windows/iot/win10/SupportedInterfaces.htm

    Sincerely,

    IoTGirl

    Mittwoch, 13. Juli 2016 19:02
    Moderator
  • from @grsw92

    "I got response from Waveshare. They said this is a common issue and they can upgrade firmware in your display but you have to pay shipping costs to China. It's really strange that we can't do it manually via USB."

    source:
    https://social.msdn.microsoft.com/Forums/en-US/e7f030e9-d22d-4972-9b2f-49bf4e090db9/waveshare-touch-problem?forum=WindowsIoT

    Montag, 18. Juli 2016 12:40
    Moderator
  • I use this: http://www.waveshare.com/product/mini-pc/raspberry-pi/7inch-hdmi-lcd-c.htm
    In the older version of Windows 10 IoT 2015. Everything worked perfectly.
    On the Windows 10 version of the IoT 10.0.14393.0 interface greatly retarding.
    Touch input does not work properly: scroll work, pressing the button works from 5-15 attempts. The behavior is very strange. Moreover, the button itself is clearly a response by pressing (falls, obscured), but that that should be fulfilled not when you press the button.
    Sonntag, 14. August 2016 10:50
  • I use this: http://www.waveshare.com/product/mini-pc/raspberry-pi/7inch-hdmi-lcd-c.htm
    In the older version of Windows 10 IoT 2015. Everything worked perfectly.
    On the Windows 10 version of the IoT 10.0.14393.0 interface greatly retarding.
    Touch input does not work properly: scroll work, pressing the button works from 5-15 attempts. The behavior is very strange. Moreover, the button itself is clearly a response by pressing (falls, obscured), but that that should be fulfilled not when you press the button.
    I'm in the exactly same situation, scroll works but touching cause no effects. Maybe the insider build works in a different way? Anyone has any tought to share?
    Freitag, 26. August 2016 15:27
  • It's the same for me around here. It there a way to get the behaviour of build 586 back?
    Donnerstag, 1. September 2016 07:07
  • This link gave me display manufacturer:

    "If you are using a Raspberry Pi 2, you can use the previous Windows 10 IoT image, download from: http://pan.baidu.com/s/1jHQVxdk, password: 9x9i
    Touch works on Raspberry Pi 2 with this image."

    Quite by accident I left:
    10586.0.151029-1700.TH2_Release_IOTCoreRPi_armFRE.ISO
    If necessary I can give.
    • Bearbeitet Seriga Samstag, 3. September 2016 22:06
    Samstag, 3. September 2016 22:03
  • I have two different touch lcd screens for my raspberry pi devices.

    one is 7" waveshare

    and the other is chalkboard 7" touch lcd.

    Touch quit working on both after anniversary update.

    Am the only one experiencing this?

    neither company is very strong with support.....or even responding to queries for that matter.

    Dienstag, 6. September 2016 14:31
  • hello

    that's a known issue, it seems like you need a firmware update from your display

    more information here https://social.msdn.microsoft.com/Forums/en-US/5a7d56df-cbc6-45e5-ad37-5ef97859b234/waveshare-7-inch-display-doesnt-work-on-windows-10-iot-core?forum=WindowsIoT

    Dienstag, 6. September 2016 14:33
    Moderator
  • Hello Folks,

    Based on the volume of this thread the team has ordered the -C, HDMI and USB-HID for touch waveshare 7" screen.  The original post mentions model B but I suspect that is no longer available and the one we order now will likely have the firmware upgrade.  Can anyone confirm that this model also shows the issue or can you please follow up with the ordering link for one that is failing?

    PS: The team would like to request that along long with your specific hardware & firmware details, we would also appreciate reproduction steps to clarify what exactly works in 10586 and how it fails in 14393.

    Sincere thanks,

    IoTGirl


    Dienstag, 6. September 2016 15:16
    Moderator
  • I wanted to update the firmware, but got the answer:

    Hello, 
    After our engineer's several tests,the 7inch LCD display HDMI (C) still cannot support  Windows 10 IoT 14393, still has bugs.
    Sorry for the trouble caused.

    Mittwoch, 7. September 2016 15:48
  • Thanks for the update Seriga.  I have passed these details on to the team.
    Mittwoch, 7. September 2016 18:05
    Moderator
  • I have de same problem... could you solve it?
    Freitag, 9. September 2016 20:23
  • Hi Everyone,

    We have the 7" touch display and a Microsoft developer has tried a few things with it but has not hit the exact issue.  Can you please tell us more about your setup and the steps we might use to see the failure?  For example, do you have anything plugged into the audio jack?

    It might help to start with our issue template.  Please copy and fill out the blue text below with as much detail as you can provide so that someone following your instructions can get the same result:

    ENVIRONMENT:

    What Computers, OS and devices are involved with this repro? How are they connected? What OS versions are they running?

    REPRO STEPS:

    What steps would someone else need to follow to see the issue?

    RESULTS:

    What did you Expect to happen?

    What did Actually happen?

    NOTES:

    Any other details/workarounds potentially related info

    If you fill out the template with as much detail as possible, it might give helpful folks a better understanding of your issue.

    Sincerely,

    IoTGirl

    Samstag, 10. September 2016 04:21
    Moderator
  • Hi,

    I have both a wave share and chalk electronics lcd with touch.

    Both displays touch quit working after anniversary update (windows 10 iot with raspberry pi 2).

    anybody else experiencing this and is there a fix?

    Montag, 12. September 2016 18:32
  • I see you merged my post about touch not working with this thread.

    Did you notice that I also had my chalkboard electronics displays touch stop working?

    Looks like this thread is about wave share (which stopped as well) with anniversary update.

    Montag, 12. September 2016 18:49
  • Hi MG1980,

    If your chalkboard is the model on the HCL, please follow the steps for that device here:  https://developer.microsoft.com/en-us/windows/iot/docs/hardwarecompatlist

    We have a few of the Waveshare screens in house now and are beginning to test them at 1280x800 resolution and have not seen any issues as yet so we have asked for complete steps on how to see the issue. 

    NOTE: There is a known issue with the RPi sharing an interrupt with the audio jack and touch. This will impact all touch based functionality if the audio jack is connected. Please ensure you do not have anything connected to the audio jack or touch will fail. See https://social.msdn.microsoft.com/Forums/en-US/9a97dd76-d069-472a-915f-9eccc3c6f431/using-a-mediaelement-freezes-the-touchscreen?forum=WindowsIoT

    Sincerely,

    IoTGirl


    Montag, 12. September 2016 18:58
    Moderator
  • this is what waveshare says to modify in config.txt for 7" touch lcd:

    max_usb_current=1
    hdmi_group=2
    hdmi_mode=1
    hdmi_mode=87
    hdmi_cvt 1024 600 60 6 0 0 0

    these were working fine until anniversary update with rpi2.

    on the wave share the symptom is that a button will change color and show pressed via touch, but nothings happens. You can scroll display. This behavior is on the initial boot screen (settings button  etc.) as well as in code.

    as far as the chalk electronic 7" display I've tried latest firmware from them with no luck. 2.3 is the oldest version they have on their website now. I'll try that and see if it helps. Not sure what version it had when I received it, but it did not work with touch either. It doesn't even acknowledge the touch like the wave share did.

    I've emailed them for support, but they are horrible as to returning emails or any other inquiries.

    Montag, 12. September 2016 19:43
  • Hi mg1980,

    Thank you for the details on how to see the issue on the Waveshare screen.  Is the experience the same on the chalk screen?

    Sincerely,

    IoTGirl

    Montag, 12. September 2016 20:46
    Moderator
  • nope the chalk elect. screen shows no acknowledgement of touch at all.

    I haven't mentioned it, but if you plug in a mouse it works fine.

    Montag, 12. September 2016 22:46
  • after reviewing some other post on the waveshare topic I noticed one person saying if the keep touching a button repeatedly it would actually respond.

    I booted up my pi with latest release on iot core and then began to continually press and release the gear icon.

    It took quite a few touches, but it did actually go to the setting screen. The get back I had to do the same thing to the back arrow. Don't know if this helps at all, just my input on this issue.

    I also send a query to waveshare about the firmware rev for my 7" display and was told that

    for my rev c boars 2.1 is the latest version (which is what I have)

    Dienstag, 13. September 2016 14:36
  • Hi Folks,

    I believe I have an answer and hopefully Waveshare can fix the issue as we have already had one OEM address the same problem.

    Essentially there are two main areas that cause issues with HID devices in this class.  HID definitions consist of Mandatory Entries and potentially Optional Entries.  Issues arise from:

    • Mandatory Entries are missing, invalid or malformed
    • Optional Entries are malformed or incomplete

    As you can guess, if either of these are in effect, they result in random behavior from the OS. This is not the only thread regarding Waveshare displays in this forum so I can make a pretty strong guess that they are not conforming to HID specification.  I can't confirm how they are not conforming but Waveshare should be able to run through HID compliance testing to discover where they require changes. 

    Some examples from other devices are Mandatory Entries filled with 0's instead of actual values or Optional Entries that do not match their definition. 

    Based on the number of random behaviors that were found as a result of such devices, Windows 10 Anniversary Edition ignores/rejects invalid HID communication across all target of the OS.  This means you should be getting the same rejection on the desktop as the IoT Core device.

    Sincerely,

    IoTGirl



    Dienstag, 13. September 2016 17:20
    Moderator
  • ok how do we get waveshare in the loop?

    also my chalk electronics board is not working either.....should I start a new thread for that?

    It's supposed to be certified right?


    it's the 7" SKU 00020
    • Bearbeitet mg1980 Dienstag, 13. September 2016 19:29
    Dienstag, 13. September 2016 19:19
  • Hi mg1980,

    I have already started a thread with the IoTCore team regarding both of these screens, however I have no contacts at either Waveshare or Chalkboard so we are in the same situation as you and can only work with the product as we purchased them.  I believe we have both in house so they will be able to try the reproduction steps you provided.

    Generally, it is up to each OEM to ensure they adhere to HID specifications so it will be up to Chalkboard and Waveshare respectively to address their firmware. 

    Sincerely,

    IoTGirl

    Mittwoch, 14. September 2016 04:33
    Moderator
  • Created a small application.
    In this button, when clicked, displays the event code.
    It may help to understand the problem.

    Failed to throw a photo here directly, so I give a link:
    http://transfiles.ru/qxy4j

    Mittwoch, 14. September 2016 13:58
  • here is the screen with chalk electric 7:  notice that is says it has hid touch screen connected. however no touch at all.

    Mittwoch, 14. September 2016 14:23
  • can you tell us which oem....or stated in another way.... can you tell us which  displays work properly with the latest w10iot?

    Mittwoch, 14. September 2016 19:18
  • Hi mq1980,

    The only answer I have at this point is that any HID compliant device should work. For example I am using an old touch monitor from HP myself but it has no special features so likely conforms to basic HID.  As for the Hardware Compatibility List, the team is going to retest the items on the list using Anniversary Edition so it should be updated soon as well.

    Sincerely,

    IoTGirl

    Mittwoch, 14. September 2016 21:07
    Moderator
  • anybody having any luck with chalk electronics touch display after anniversary update of windows 10 iot with rpi2?
    • Bearbeitet mgarner1980 Freitag, 16. September 2016 16:26
    • Zusammengeführt IoTGirlModerator Freitag, 16. September 2016 16:43 Same topic
    Freitag, 16. September 2016 16:26
  • Hi mgarner1980,

    As you can see from this existing thread the chalk display is already being discussed as submitted by "mg1980" with the Waveshare display so I have merged your question into the thread that has the full discussion. 

    We are attempting to reach out to OEMs as they will need to be HID compliant to work with all varieties of Windows 10 at this point.  

    A tool that was referred to in one of the discussions on examining HID messages is (http://www.usblyzer.com/) which can be used to watch the traffic from the screen on a touch message. I am told that these messages should then be validated against the HIDCLASS it originally declared.

    Sincerely,

    IoTGirl

    Freitag, 16. September 2016 16:57
    Moderator
  • my bad iot girl.

    I am mg1980. (another login) one for work one for home.

    It's driving me nuts to have the touch stop working and chalk electronics won't answer tech support requests. However they respond immediately for sales inquiries :)

    Freitag, 16. September 2016 19:35
  • No worries MG! Sadly, you are not alone! I have reached out from @Microsoft as well and have no response from either Waveshare or Chalk at this point.

    Sincerely,

    IoTGirl

    Samstag, 17. September 2016 00:18
    Moderator
  • [..] This means you should be getting the same rejection on the desktop as the IoT Core device.

    Hi IoTGirl,

    Do you mean insider preview desktop editions or official releases as well?

    On my PC I'm using official Win10 release (10586) and touch screen from Waveshare is working great, it even supports multitouch on PC! Unfortunately, I'm not able to try on Insider Preview desktop version.

    But on my RPi2 with Win 10 IOT release 14393 still does not work. Issue is that as people above described, when you try to click, button is blinking but OnClick event isn't fired.

    BR, grsw92

     

    Samstag, 17. September 2016 13:44
  • Hi grsw92,

    10586 is not Anniversary Edition, 14393, so does not have the strong HID validation.  When you deploy Anniversary Edition on your Desktop, you can expect similar HID rejections.

    Sincerely,

    IoTGirl



    Samstag, 17. September 2016 16:38
    Moderator
  • Hi Folks,

    We have gotten in direct contact with Chalk-Elec and their screen is passing all HID testing an has been validated against multiple platforms running 14393 so we are confident that screen does in fact work with IoT Core.

    Waveshare is failing validation and we are having more difficulty getting a technical contact from them.

    Sincerely,

    IoTGirl

    Mittwoch, 21. September 2016 22:22
    Moderator
  • Waveshare 7inch HDMI LCD (C)
    "Hello. Is there any information about firmware for Windows IoT 14393. When will it be possible to send the display?"

    "Sorry, now we haven't found out the reason yet."

    I have a feeling that this display and will not work on Windows IoT. The developers obviously are not in a hurry to do it, and do not seem to want to.

    Donnerstag, 22. September 2016 09:53
  • Maybe better solution would be to suggest them to implement some custom driver for Windows (no longer trying to fit in standard HID driver requirements). Then all users could automatically download new drivers for windows without need for sending screens back to Waveshare. I'm not familiar with how driver things work in Win 10 IoT. Is this possible from Win 10 IoT Core point of view?

    Donnerstag, 22. September 2016 10:19
  • So engineers at Microsoft have tested the display themselves?

    do you know which version of their (chalk elect) firmware is working.

    My 7" hdmi touch display doesn't have any touch.

    It did before update.

    Could be faulty I'll try it on a pc and see if touch works.

    Donnerstag, 22. September 2016 15:41
  • one other question,

    does config.txt have anything with chalk display touch working?

    Donnerstag, 22. September 2016 15:50
  • Hi MG,

    The display under test is 7” Chalkboard multi touch screen and we are in touch with Chalk-Elec and the poster of the information at that link.  The link on our Hardware Compatibility List should have all the details.

    As to Config.txt, rotation of the display and rotation of touch does not work on Raspberry Pi so I would recommend leaving the rotation values alone.  That is discussed in another thread.

    Sincerely,

    IoTGirl

    Donnerstag, 22. September 2016 15:56
    Moderator
  • that's the one I have and touch stopped after update.

    As I stated earlier I haven't tried it on another device.....that should at least let me know that the displays touch is functional.

    As always thanks for all the information.

    Donnerstag, 22. September 2016 16:19
  • Hi MG,

    How do you check and what is the firmware version on your display? I will have our team check theirs the same way and compare.

    Sincerely,

    IoTGirl


    Donnerstag, 22. September 2016 17:16
    Moderator
  • I don't think the bootloader program reads what the current version is.

    I've only used it to load new firmware.

    I should be able to tinker with it tonight, if I figure out how to check firmware revision I'll post it.

    Donnerstag, 22. September 2016 19:03
  • Excellent!
    Donnerstag, 22. September 2016 21:36
    Moderator
  • "Waveshare" has not solved the problem with the displays. Please, advise display that works in the new version “Windows 10 IoT”. Need 7 inch preferably with a resolution of 1024x600, compatible with “Raspberry Pi 2-3”.

    Have noticed that the display from "Waveshare" even in older versions of Windows 10 IoT (10586) still works with a slight delay. Ie responds to touch late. Delay, though not large, but still noticeable compared to modern touch screens. And on the “Raspbian” there are no delays.
    Sonntag, 9. Oktober 2016 10:18
  • Hi Seriga,

    It is my understanding that any screen that sends valid fully-filled HID messages will work with Windows 10.  The problem with some screens is that they leave some expected values NULL so Windows can't route them correctly.  Version 10586 "guessed" at these routings but it caused other issues so now 14393 discards all mal-formed HID messages.  All HID compliant screens should work or they are not truly HID compliant.

    Sincerely,

    IoTGirl

    Montag, 10. Oktober 2016 17:27
    Moderator
  • Hello IoTGirl,

    I'm watching this discussion since pretty much the beginning, and since the way Waveshare has been handling this issue wasn't very helpful, I decided to "have a closer look" at the hardware and ended up implementing my own firmware for the Waveshare Touchscreen.

    Long story short, with my firmware the touchscreen behaves perfectly well under Windows 10 (including Anniversary Update) on PC! But sadly on IoT Core, it exhibits some weird behaviour (which is different from the behaviour with the original firmware).

    I didn't find a proper way of getting more information out of IoT Core (the ETW tracer isn't showing me anything useful, but that might be me not using it as I should) so I was hoping for your help to get in touch with the right people to get that issue sorted out, so that people willing to fiddle around with a "custom" (I prefer "alternative") firmware could get the screen fully working.

    I published the firmware as open source, so if anyone here is feeling like contributing, just head over to my github page and contribute:

    https://github.com/pysco68/waveshare-hid


    • Bearbeitet IoTGirlModerator Freitag, 28. Oktober 2016 17:44 Made github link live
    Freitag, 28. Oktober 2016 13:24
  • Hi pysco68,

    Wow! that sounds like a great project. I'll see if I can get you some feedback at GITHUB.  Please take a look at https://github.com/pysco68/waveshare-hid/issues/1

    Sincerely,

    IoTGirl


    Freitag, 28. Oktober 2016 17:44
    Moderator
  • Thank you so much for the quick issue raising. I'd like to announce that the Waveshare 7 inch Capacitive Touchscreen is now fully functional even with Windows 10 IoT Core with my alternative firmware!

    All you need is a Linux box (or Cygwin with an ARM toolchain) an a STM32 / GD32 compatible flasher/debugger (STM32 Link v2, Black Magic Probe, an OpenOCD setup or one of the other half a zillion JTAG/SWDP probes for STM32).

    I'm writing up an article on my blog about that at the moment, I'll post the link here soon!

    Montag, 31. Oktober 2016 12:59
  • Hi again, I just wanted to notify you guys about the article I promised two days ago:

    http://k16c.eu/2016/11/02/open-firmware-for-waveshares-7-inch-touch-screen/

    I already got a bit of feedback from some nice guy from Poland who reported that (after fiddling around with the flashing process) the firmware works for him too. So rather good news all in all :) https://github.com/pysco68/waveshare-hid/issues/2

    Cheers!

    Mittwoch, 2. November 2016 14:47
  • Hi pysc068,

    Many thanks!  I have also pointed "Waveshare-Sales" to your GitHub so potentially they will also take your fix!

    Sincerely,

    IoTGirl

    Mittwoch, 2. November 2016 16:43
    Moderator
  • Thanks for the work!

    what do I need to re-program it in windows 10. I saw on GitHub another user had pulled it off.

    What exactly am I re-programming (IE what make/model of programmable device/chip) ?

    Thanks again,

    Mark

    Mittwoch, 16. November 2016 23:52
  • Hi mg1980,

    You should take a look at the blog at http://k16c.eu/2016/11/02/open-firmware-for-waveshares-7-inch-touch-screen/ and the associated GitHub repository for that detail.  there is no change required to Windows 10, this is a firmware issue with some HID devices.  If you are not familiar with flashing firmware, I suggest you work with the OEM of your touch display to ensure they are meeting HID specifications. You can also point them to the Blog & Repository.

    Sincerely,

    IoTGirl

    Mittwoch, 16. November 2016 23:57
    Moderator
  • Hello Mark,

    as IoTGirl pointed out, most of the details are explained in my blog post and the repository. Put simply, my firmware runs on the GD32F103 chip on the touch screen's PCB, and takes care of transmitting the touch reports in a HID specification compliant way (which wasn't the case with the original firmware).

    For flashing you'll need a ST-Link v2 compatible SWD probe (there are china-clones for a under five bucks around on EBay, Aliexpress and the like) and a Linux machine for the compiling.

    Once you have the binary you can flash the firmware using tools like OpenOCB, GDB (both primarily on Linux) or the "STM32 ST-Link Utility" (you'll find that on ST's website).

    As IoTGirl stated, you should be either familiar with embedded development or be a bit courageous ;) Anyhow, if you feel like trying this, please go over to my blog & Github read and try. If you need some help for specific step's I'll happily help you where possible.

    Donnerstag, 17. November 2016 07:48
  • thanks for the reply.

    What I was asking is if I had to use a linux box. I see programming tools for st32 that run on windows instead of Linux. I've programmed pic controllers and such via c. I assume I will have to compile to create an executable.  

    just wondering if I could perform all tasks with tools in windows as I do not have a Linux install available.

    I found dev  stuff on st's website that run in windows, just haven't used it before.

    Could the compiled binary be made available?

    Donnerstag, 17. November 2016 21:38
  • Hi MG,

    One of the Microsoft MVPs thought "you can burn this to the STM with VisualGDB on a PC, anxious to give it a try…" but has not come back with any success as yet.

    Sincerely,

    IoTGirl

    Donnerstag, 17. November 2016 21:43
    Moderator
  • Hi,

    Compiling all of this under windows shouldn't be a problem; you'll just have to fiddle around with the Makefile stuff. Could could eventually give the EM::Bitz IDE a try (https://www.emblocks.org/web/) or try to compile the sources using the ARM GCC package for windows. In the end there's probably at least a dozen ways of getting this thing compiled and burned.

    On the other hand you could get yourself running with an Ubuntu VM (on Hyper-V or Virtualbox or or or...) in about twenty minutes (once you have the ISO).

    Regarding your question about the binaries, sure I *could* just publish them. Honestly I fear to do so because it would lower the bar of understanding of *what you're actually doing* so much that anyone would just give it a try without thinking.


    • Bearbeitet pysco68 Samstag, 19. November 2016 11:25
    Samstag, 19. November 2016 11:24
  • thanks for the reply
    Montag, 21. November 2016 16:01
  • Short note for all customers of Chalkboard Electronics LCD panels - our panels work well with all versions (including the latest) of Windows 10 IoT. You just have to update LCD firmware to the latest multi-touch version (2.4 at the moment). Firmware and update instructions are available at the bottom of product page in our webstore.

    Freitag, 25. August 2017 10:38
  • @Chalkboard Electronics

    thank you for this valuable information, please could you check your entry on the Hardware compatibility list so we could update possible old information

    br
    Andre


    Freitag, 25. August 2017 12:30
    Moderator