none
Fehler bei Reportingserver - Aufruf Bericht RRS feed

  • Frage

  • Hallo,
    seit unserer Umstellung auf Windows Server 2008 R2 haben wir das Problem, dass keine Reporte mehr erstellt werden können und bei dem versuch, reports direkt über den Reportserver zu erstellen kommt folgender Fehler

    Serverfehler

    500 - Interner Serverfehler.

    Problem bei der gesuchten Ressource. Sie kann nicht angezeigt werden.

    Reporting Services-Fehler

    • Interner Fehler beim Berichtsserver. Weitere Informationen finden Sie im Fehlerprotokoll. (rsInternalError) Onlinehilfe
      • Um weitere Informationen zu diesem Fehler zu erhalten, navigieren Sie zum Berichtsserver auf dem lokalen Servercomputer, oder aktivieren Sie Remotefehler.

      SQL Server Reporting Services



    • Hat jemand vielleicht das selbige Problem oder kennt jemand eine Lösung?


    • Danke und Grüße Ronny
    Freitag, 30. Oktober 2009 09:02

Antworten

  • Hallo Ronny,

    das war bei dir das Problem der unterschiedlichen Sprachen, richtig?

    Viele Grüße,
    Jürgen

    Jürgen Beck

    Dipl. Kfm./Wirtschaftsinformatik
    MVP, MCSD.NET, MCITP DBA, MCDBA, MCSE
    Microsoft Certified Business Management Solutions Professional
    Microsoft Certified CRM Developer
    Microsoft Certified Trainer

    ComBeck IT Services & Business Solutions
    Microsoft Gold Certified Partner
    Microsoft Small Business Specialist

    Developing & Supporting Business Applications from small business to big enterprises covering scores of sectors

    http://www.combeck.de
    Mittwoch, 6. Januar 2010 22:47
    Moderator

Alle Antworten

  • Hallo Ronny,

    zuerst die gute Nachricht, bei uns läuft CRM und Reportserver auf 2008 R2.
    Um das Problem zu untersuchen brauchen wir ein paar Angaben.

    1. Wie seid Ihr auf R2 migriert. Neuinstallation / Upgrade
    2. Sind die Berichte wirklich auf dem Server?
    3. Kann man die Berichte ansurfen http://Reportservername/Reports
    4. Habt Ihr eigene Berichte erstellt und wenn ja hast Due die RDL Dateien noch. (Dann könnten mand ie Berichte einfach noch einmal aufspielen.
    5. Der Fehler 500 sollte einen  Stacktrace ins Eventlog geschrieben haben. Schick uns den mal ins Forum.

    Grüße
    Thomas
    Freitag, 30. Oktober 2009 09:29
  • Hallo Thomas,
    wir haben eine komplette Neuinstall des Servers gemacht.
    Wenn ich die Standartadresse, als in unserem Fall http://server3/reportserver, im Browser aufrufe erscheinen unsere CRM UE's, in der ich auch die Reports aufrufen kann.
    Sobald ich dann jedoch den Report im Browser öffnen möchte, kommt die o.g. Fehlermeldung.

    Die Berichte wurden im CRM erstellt und funktionierte vor der Umstellung auf 2008 R2 unter W2k3 und dem selben SQL Server 2005 aktuelles SP.

    Fehlermeldung aus dem Eventlog:

    Event code: 3008

    Event message: Es ist ein Konfigurationsfehler aufgetreten.

    Event time: 30.10.2009 10:35:37

    Event time (UTC): 30.10.2009 09:35:37

    Event ID: 15865a91e5704592b1070b10ff859ff8

    Event sequence: 525

    Event occurrence: 2

    Event detail code: 0

     

    Application information:

    Application domain: /LM/W3SVC/1/ROOT/ReportServer-1-129013659315455930

    Trust level: RosettaSrv

    Application Virtual Path: /ReportServer

    Application Path: e:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer\

    Machine name: SERVER3

     

    Process information:

    Process ID: 5168

    Process name: w3wp.exe

    Account name: NT-AUTORITÄT\NETZWERKDIENST

     

    Exception information:

    Exception type: InvalidConfigFileTypeException

    Exception message: Vom Typ 'Microsoft.Crm.Web.Reporting.CrmReportViewerMessages, Microsoft.Crm.Application.Pages, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' wird 'IReportViewerMessages' nicht implementiert, oder das Element wurde nicht gefunden.

     

    Request information:

    Request URL: http://server3/ReportServer/Pages/ReportViewer.aspx?Es ist ein Konfigurationsfehler aufgetreten.fBrauneCRM_MSCRMEs ist ein Konfigurationsfehler aufgetreten.f4.0Es ist ein Konfigurationsfehler aufgetreten.f2b1b6a82c3-30c5-de11-a078-0040d0ac25fb2d&rs:Command=Render

    Request path: /ReportServer/Pages/ReportViewer.aspx

    User host address: 192.168.2.134

    User: DOMAENE1\Ronny

    Is authenticated: True

    Authentication Type: Negotiate

    Thread account name: NT-AUTORITÄT\NETZWERKDIENST

     

    Thread information:

    Thread ID: 11

    Thread account name: NT-AUTORITÄT\NETZWERKDIENST

    Is impersonating: True

    Stack trace: bei Microsoft.Reporting.WebForms.ConfigFilePropertyInterface`1.EnsurePropertyLoaded()

    bei Microsoft.Reporting.WebForms.ConfigFilePropertyInterface`1.GetInstance()

    bei Microsoft.Reporting.WebForms.LocalizationHelper.Microsoft.Reporting.WebForms.IReportViewerMessages.get_ProgressText()

    bei Microsoft.Reporting.WebForms.WaitControl.CreateChildControls()

    bei System.Web.UI.Control.EnsureChildControls()

    bei System.Web.UI.Control.PreRenderRecursiveInternal()

    bei System.Web.UI.Control.PreRenderRecursiveInternal()

    bei System.Web.UI.Control.PreRenderRecursiveInternal()

    bei System.Web.UI.Control.PreRenderRecursiveInternal()

    bei System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    bei System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    bei System.Web.UI.Page.ProcessRequest()

    bei System.Web.UI.Page.ProcessRequest(HttpContext context)

    bei ASP.pages_reportviewer_aspx.ProcessRequest(HttpContext context)

    bei System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

    bei System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

     

     

    Custom event details:

    Freitag, 30. Oktober 2009 09:39
  • Hallo Ronny,

    ich verstehe Dich so. Der Datenbank Server mit dem Report Server ist noch der Gleiche. Nur der CRM Server wurde neu installiert.
    Der Auszug den Du geschickt hast ist vom CRM Servetr richtig? der schipft uns an weil er den Report nicht bekommen hat.
    Da aber die Berichte schon nicht anzusurfen sind sollte im Eventlog des ReportServers etwas zu sehen sein. Bitte auch mal posten.

    Dann prüfe an der CRM Datenbank (orgname_MSCRM) unter Sicherheit Benutzer, ob die 3 Gruppen für den reporting Zugriff i.O. sind (sind die Gruppen mit den GUIDs am Ende).
    Der ReportingServer und der CRM server müssen in diesen Gruppen Mitglied sein.

    Grüße
    Thomas
    Freitag, 30. Oktober 2009 11:34
  • Hallo,
    also bei uns ist der CRM Server, sowie der SQL Server die selbe Maschiene. Wir haben bei der Umstellung komplett Windows Server 2008 R2 und den SQL Server (2005) neu installiert und die Datenbank zurück gesichert.

    Soweit funktioniert halt alles, nur der Reporting Service nicht.

    Des Weiteren, finde ich leiden den Punkt "Reporting Service" im Ereignis-Log nicht. Entweder sehe ich wieder den Wald vor lauter Bäumen nicht oder ich bin einfach zu dumm, den Bereich, zu finden.

    Grüße Ronny
    Freitag, 30. Oktober 2009 13:00
  • Hallo Ronny,

    ok verstanden, Hast Du die Datenbanken erst wiederhergestellt und dann bei der CRM Installation gesagt "vorhandene Datenbank verwenden" oder so ähnlich? Oder die Installation von CRM erst komplett durchlaufen lassen und dann die Datenbanken wiederhergestellt?

    Grüße
    Thomas 
    Freitag, 30. Oktober 2009 13:17
  • Hallo,
    also ich habe bei der installation gesagt "vorhandene Datenbank verwenden"... hat auch funktioniert soweit und habe dies auch schon mehr fach bei anderen installationen gemacht. Ohne Probleme.

    Aber halt bei uns im Haus.... Wie immer halt *fg*

    Freitag, 30. Oktober 2009 14:34
  • Hallo Ronny,

    Ich meine mich zu erinnern, das beim Verwenden einer vorhandenen Datenbank die Reports nicht neu deployed werden.
    Hast du eine Enterprise Lizenz? Falls ja, dann lege mal eine zweite Organisation an. Und prüfe ob da die Standardberichte laufen.
    Falls ja, sollte der Rest ganz einfach sein.
    Die zweite Organisation zur Standardorgansation machen.
    Eure Organisation löschen.
    Auf dem ReportServer aus dem Unterordner für eure Organsiation die angepassten Berichte sichern und dann den Ordner löschen.
    Dann eure Organsation als neue Organisation über den Bereitstellungmanager importieren.
    Dabei werden alle Standardberichte neu deployed.
    Die angepassten Berichte dann über CRM wieder einspielen.

    Grüße
    Thomas

    Freitag, 30. Oktober 2009 20:33
  • Hallo Ronny,

    das war bei dir das Problem der unterschiedlichen Sprachen, richtig?

    Viele Grüße,
    Jürgen

    Jürgen Beck

    Dipl. Kfm./Wirtschaftsinformatik
    MVP, MCSD.NET, MCITP DBA, MCDBA, MCSE
    Microsoft Certified Business Management Solutions Professional
    Microsoft Certified CRM Developer
    Microsoft Certified Trainer

    ComBeck IT Services & Business Solutions
    Microsoft Gold Certified Partner
    Microsoft Small Business Specialist

    Developing & Supporting Business Applications from small business to big enterprises covering scores of sectors

    http://www.combeck.de
    Mittwoch, 6. Januar 2010 22:47
    Moderator