none
ankommende Email automatisieren RRS feed

  • Frage

  • Hallo 
    habe diese Frage schon in einem MS Newsgroup gestellt aber ich denke dieses Forum ist aktueller.
    Ich hoffe ihr verzeiht.
    folgendes Problem. Wir verwenden neben dem MS CRM 4.0 ein Warenwirtschaftssystem welches Angebote etc an Kunden via eMail versendet. Parallel dazu bekomme ich eine Blindkopie zugesendet. Wie ist es nun möglich dem CRM beizubringen das diese "Blindkopie" einem Kontakt zuzuordnen ist. Momentan bekomme ich diese email und muss sie im Outlook Client auf "In CRM Nachverfolgen " klicken. Das muss doch auch automatisiert gehen?! Ein weiterer schritt wäre diese email  mit einem Workflow zu versehen der dem Besitzer des Kontaktes eine Aufgabe etc generiert. Habt Ihr eine Idee. Vielen Dank Gruss Erol
    Sonntag, 13. Dezember 2009 10:39

Antworten

  • Hallo,

    hast du immer noch das Problem, hat dir die vorgeschlagende Lösung geholfen oder hast du mittlerweile eine eigene Lösung gefunden?

    Viele Grüße,
    Jürgen


    Jürgen Beck

    Dipl. Kfm./Wirtschaftsinformatik
    MVP, MCSD.NET, MCITP DBA, MCDBA, MCSE
    Microsoft Certified Business Management Solutions Professional
    Microsoft Certified CRM Developer
    Microsoft Certified Trainer

    ComBeck IT Services & Business Solutions
    Microsoft Gold Certified Partner
    Microsoft Small Business Specialist

    Developing & Supporting Business Applications from small business to big enterprises covering scores of sectors

    http://www.combeck.de
    Mittwoch, 12. Mai 2010 13:22
    Moderator

Alle Antworten

  • Hallo Erol,

    richte im CRM eine Warteschlange ein. Dieser Warteschlange ordnest Du ein spezielle eMail-Addr. zu, an welcher Du aus Deinem MaWi-System die Blindkopie sendest. Damit wird die eMail automatisch im CRM hochgestuft.

    Schöne Grüße aus Bayern Heiko Heinrich-Nestler XING: http://www.xing.com/profile/Heiko_HeinrichNestler
    Sonntag, 13. Dezember 2009 12:21
  • Guten Morgen Heiko,

    danke für die rasche Antwort.

    1. ich lege diese email addresse im Active directory an

    2.ich definiere die Warteschlange

    richtig?

    wie definiere ich am besten den zugriffstyp ( e-Mailrounter / Weiterleitungspostfach / Keine) für diese eine emailadresse?
    normalerweise läuft bei uns alles über exchange.
    Verstehe ich das richtig das wenn der Popconnector die emails abruft diese spezielle dann in das CRM "umleiten bzw weiterleiten" würde.

    Gruss Erol

    Montag, 14. Dezember 2009 08:50
  • Hallo Erol,

    Richtig! Du musst im Active Directory ein Benutzer mit der entsprechenden eMail-Addr. anlegen. Anschließend legst Du im CRM die Warteschlange an und ordnest dieser die enstprechende eMail-Addr. zu.

    Anschließend musst Du noch dem eMail-Connector konfiguriert werden. Zu diesem Thema kann ich allerdings nicht viel sagen. Hier solltest Du Dir mal den Thread  http://social.msdn.microsoft.com/Forums/de-DE/crmgerman/thread/f11f0526-0d84-4a89-ad72-e77b9061c9e2  ansehen.


    Schöne Grüße aus Bayern Heiko Heinrich-Nestler XING: http://www.xing.com/profile/Heiko_HeinrichNestler
    Montag, 14. Dezember 2009 10:58
  • Hallo Heiko,

    habe sowiet alles angelegt.

    Nur leider bekomme ich es nicht hin das die Warteschlange die ich angelegt habe mit dem Email Router bzw mit dem Weiterleitungspostfach kommuniziert.
    Ich habe mir die Videos alle angesehen 

    Ich habe im Active Directory einem User eine weitere SMTP emailadresse  angelegt. z.b.: wawi@test.de / Dieser User ist auch  CRM User.(sprich meiner einer)
    Frage dazu, muss der angelegte user auch CRM User sein? wäre doch eigtentlich nicht sinnig wenn dies so wäre.

    Gruss Erol








    Montag, 14. Dezember 2009 14:14
  • Hallo Erol,

    der AD-Benutzer, der für die Warteschlange angelegt wurde, muss nicht CRm-Benutzer sein. Wenn die eMails aus dem Exchange-Postfach nicht an das CRM weitergeleitet werden, dann ist der eMail-Router nicht richtig konfiguriert.

    Wie ich bereits sagte, ich bin leider nicht der Spezialist zum Thema "eMail Router". Hier müssen Die andere helfen. Ich könnte Dir evtl. noch diesen Link anbieten.
    http://groups.google.de/group/microsoft.public.de.crm/browse_thread/thread/5d05f83546865a70/0a4f627ee5a01743?lnk=gst&q=eMail-router#0a4f627ee5a01743

    Schöne Grüße aus Bayern Heiko Heinrich-Nestler XING: http://www.xing.com/profile/Heiko_HeinrichNestler
    Montag, 14. Dezember 2009 15:11
  • Hallo Erol,

    damit eine Warteschlange die EMails automatisch erstellt, musst du folgende Schritte durchführen:
    - anlegen der Warteschlange mit der EMail Adresse, z.B: info@crm.local. Als Zugriffstyp für eingehende EMails legst du den EMail Router fest
    - Einrichten des EMail Routers, damit dieser die EMails für diese Adresse aus eurem Mailserver abholt. Dies wird in dem Video http://video.mikelu.org/emailrouterexchange/emailrouterexchange.html sehr gut erklärt.

    Das war es dann auch schon.
    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    Montag, 14. Dezember 2009 16:08
  • Guten Morgen Michael,

    also jetzt stehe ich total auf dem Schlauch...

    1.
    SMTP Emailadresse im Active sync angelegt. sprich : User1 bekommt zusätzliche SMTP email -> info@test.de
    wieso jetzt crm.local? bzw.local? in der Warteschlange?
    mmhh lege ich die emailadressen etwa falsch an?

    sprich in der Warteschlange lege ich auch info@test.de an. oder etwa nicht?


    2. welchen User nehme ich am besten für die allgemeinen Emails wie z.b: Info Mails?


    3.
    Videos habe ich mir schon alle drei 2 mal angesehen und so durchgespielt...
    Emailrouter via POP konnte ich nicht testen, da unser Emailprovider keine emailadressen zum abrufen der Popkonten verwendet sondern den POPAccount namen zb. kontop1



    Gruß Erol
    Mittwoch, 16. Dezember 2009 09:02
  • Hallo Erol,

    zu 1: Ja, du legst natürlich eure E-Mail Adresse in der Warteschlange an, also info@test.de

    zu 3: Was meinst du mit eurem E-Mail Provider? Habt ihr keinen eigenen E-Mail Server und verwendet einen POP3 Server eines Providers? Wenn ja, must du auf diesem Server eure E-Mail Adresse info@test.de anlegen und die Mails aus diesem Account dann mit dem E-Mail Router abholen.

    Eines der Vides beschreibt dann genau eure Konstellation ich glaube am Beispiel von googlemail.

    zu 2: Wenn meine Annahme vom Pnkt 3 stimmt, benötigt ihr keinen Account im AD, ansonsten würde ich einen eigenen User dafür erstellen.

    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    Donnerstag, 17. Dezember 2009 07:15
  • Hallo Michael,

    der Fehler muss bei uns woanders liegen.
    Ob es mit irgendeiner Einstellung der Benutzerguppen oder Sicherheitsrichtlinien zu tun hat?!

    Also die einzigen Emails die in die Warteschlange reinkommen sind momentan bei uns die allgemeinen(info@firma.de).
    Diese sind bei uns in der sog. Distribution Groups angelegt. Aber selbst wenn ich noch dort eine Email Adresse hinzufüge bekommen wir die Verlinkung nicht hin.


    Noch eine Idee?
    Gruß Erol

    Donnerstag, 17. Dezember 2009 12:11
  • Hallo,

    habe mal in der Ereignisanzeige gestöbert;

    >#35241 - Die Empfänger für die E-Mail-Nachricht mit dem Betreff 'testemail in Postfach service@contoso.com stimmten mit keinem bekannten Datensatz überein.
    >
    Kann es sein das ich die ganz Zeit einen Denkfehler mache?

    Also die emails werden von einer Software per BCC(Blindcopy) an das Exchange Postfach gesendet. Kann es sein das der Router nun nicht weiss ob diese email für Ihn bestimmt ist oder nicht Schliesslich ist die email ja an eine unbekannte Adresse sprich Kunde@msn.com gegangen.

    Ich habe gedacht ich kann den Router so verwenden das er quasi ALLE emails empfängt, also auch solche die eigentich nicht für Ihn bestimmt waren sprich auch BCC?

    Was mache ich falsch?

    Gruss Erol
    Mittwoch, 23. Dezember 2009 16:19
  • Es liegt an BCC: Würdest Du die E-Mail direkt an die neue Adresse senden, würde der E-Mail-Router diese E-mail garantiert in CRM hochstufen. Dies würde ich als 1. auch mal ausprobieren, um auszuschließen, dass Du den E-Mail Router doch nicht korrekt konfiguriert haben solltest. Und wenn es dann funktioniert und Du zurück zu BCC willlst, dann hilft Dir dieser Thread hier https://community.dynamics.com/forums/p/20411/33440.aspx#33440 weiter.


    Stichwort: Exchange Transport-Regel erstellen


    Gruß Carsten Groth http://carstengroth.spaces.live.com
    Mittwoch, 23. Dezember 2009 19:10
  • Bei mir scheitern alle Versuche mit den Warteschlangen und E-Mail Router.

    Wenn ich im E-Mail Router auf "Daten laden" klicke, erhalte ich immer den Http-Status 401: Unauthorized (hatte ich hier in einem andern Beitrag schon mal gepostet). Konfiguriert habe ich den Router nach Handbuch und Video.

    Warteschlagen erhalten auch nur mails, wenn ich eine mail Adresse eines CRM-Users eintrage (mit email Zugriff eingehend: Microsoft Dynamics CRM für Outlook).

    Gruss
    Guido

    Sonntag, 27. Dezember 2009 08:34
  • Hallo Carsten,

    stimmt es liegt an BCC, die emails kommen auf jeden fall in der Warteschlange an. Problem ist jetzt nur das diese Weitergeleitet wurden und WG:im Titel steht was nicht ideal ist. ( zuviele Klicksum überhaupt herauszufinden an wenn die email eigentlich gegangen ist + manuelle Zuordnung.)

    So sieht es dann aus:

    von Email: service@contoso.com

    An Email: Warteschlangennamen


    es soll aber so aussehen:

    von email: service@contoso.com

    an Email: CRM Kontakt(wenn vorhanden wenn nicht rot unterlegt)


    das muss doch gehen?

    Mit dem Link komme ich nicht wirklich klar. Ich denke ich bin nah dran aber es fehlt noch der letzte Haken im system frage ist nur wo?!


    Gruss Erol

    Montag, 28. Dezember 2009 11:16
  • Hast Du die Warteschlange so eingestellt, dass wirklich "Alle Emails" hochgestuft werden. Hier gibt es eine Auswahlliste mit 3 Optionen. Hier muss die 1. Option eingestellt sein.
    Gruß Carsten Groth http://carstengroth.spaces.live.com
    Montag, 28. Dezember 2009 14:50
  • Hallo Cartsen

    ja ist alles korrekt eingestellt jedoch wie gesagt wird "nur" weitergeleitet mt WG im Betreff...

    gruss Erol
    Montag, 28. Dezember 2009 17:42
  • Arbeitet Deine CRM Warteschlange mit einem eigenen Postfach oder hast Du ein Weiterleitungspostfach mit der Warteschlange verknüpft?
    Gruß Carsten Groth http://carstengroth.spaces.live.com
    Dienstag, 29. Dezember 2009 09:16
  • Hallo Carsten,

    haben ein eigenes Postfach im AD angelegt.

    den fehler WG bzw FW im Betreff bin ich auf die Schiche gekommen.

    Ich habe im Regelbereitstellungsmanager die Regel entfernen müssen dannach funktionierte es!

    Soweit so gut.

    Wir gesagt die Email die ich direkt an service@contoso.com sende kommt nun in der Warteschlange an. Jedoch habe ich nachwievor das Problem wie oben beschrieben:


    aktueller Zustand:

    von Email: service@contoso.com

    An Email: Warteschlangennamen


    es soll aber so aussehen:

    von email: service@contoso.com

    an Email: CRM Kontakt(wenn vorhanden, wenn nicht rot unterlegt)



    Mittwoch, 30. Dezember 2009 10:24
  • Es ist doch so, dass nach wie vor Dein WaWi System die E-Mail an den Kontakt versendet, richtig? Geschieht dies direkt aus dem System heraus oder wird die E-Mail durch den jeweiligen WaWi User via seinem Outlook versendet? Wenn letzteres der Fall, benötigst Du nur noch eine Bereitstellungsregel in den jeweiligen User-Postfächern, welche diese E-Mails z.B. anhand der Betreff-Zeile identifiziert und dann an Dein Warteschlangen-Postfach weiterleitet.

    Wenn das WaWi System direkt via Exchange versendet, hast Du ggfs. die Chance über eine direkte Tranport-Regel für E-mail Nachrichten diese Nachrichten zu identifizieren und dann an Deine Warteschlange zu senden.


    Gruß Carsten Groth http://carstengroth.spaces.live.com
    Mittwoch, 30. Dezember 2009 10:47
  • system ist extern sprich SAAS system bei dem ich halt die Möglichkeit habe BCC eine emailadresse zu versenden.

    habe ich zum beispiel die BCC an User1@contoso gesendet kann ich diese im Outlook ohne problem im CRM hochstufen,( er findet den Kontakt wenn vorhanden etc etc ) daher war der Grundgedanke dies automatisiert in eine Warteschlange zu bringen und später dieses noch mit Workflows zu versehen.

    sollte doch eigentlich wenn ich einen Benutzer angelegt habe genauso gehen aber anscheinend kommt Outlook irgendwie besser mit in BCC versendeten emails klar.




    Mittwoch, 30. Dezember 2009 11:14
  • Richtig, der E-Mail Router kann mit BCC nicht wirklich arbeiten - nur mit ein paar Transport-Regel-Tricks im Exchange, aber das ist nicht die Art, wie man den E-Mail-Router nutzen sollte.

    Aber hast Du denn mal versucht, die E-Mails, die Du via BCC an User1@contoso sendest über eine Regel-Bereitstellung an die Warteschlange weiterzuleiten - sprich die Regel im jeweiligen User-Postfach hinterlegen?

    Der E-Mail-Router schaut ja nur "stupide" ins Postfach und prüft, ob Nachrichten zu verarbeiten sind. Übrigens am besten zu überwachen mit CrmDiagTool
    Gruß Carsten Groth http://carstengroth.spaces.live.com
    Mittwoch, 30. Dezember 2009 11:49
  • Regel Bereitstellung an die Warteschlange weiterleiten habe ich versucht via Outlook.
    Wenn ich in dem Outlook Regel Assistenten-> Adressbuch-> bin und die Warteschlage also Person/Verteilerliste auswählen möchte nimmt er diese nicht an. Sie ist zwar da aber Outlook bekommt Sie nicht verlinkt bzw findet Sie nicht. Muss ich dies irgendwo separat freischalten?

    Mittwoch, 30. Dezember 2009 17:11
  • Ich nutze für die Regel-Bereitstellung zunächst den Assistenten, der mit dem CRM E-Mail Router mitgeliefert wird, erstelle hierüber die Default-Regel und gehe anschließend via Outlook in den Regel-Bereitstellungsassistenten und passe die Default-Regel entsprechend meinen Anforderungen hin an.
    Das ist der sicherste Weg...

    Gruß Carsten Groth http://carstengroth.spaces.live.com
    Donnerstag, 31. Dezember 2009 10:06
  • das ist eine gute Idee. Hab ich gerade ausprobiert und funktioniert auch soweit.
    Aber wie bekomme ich es hin das ich die Warteschlange auch in dem Outlook Assistenten auswählen kann?
    Momentan findet er meine Warteschlange nicht bzw zeigt Sie nicht an.

    Idee war um das Bcc problem zu lösen:

    Regel Assistent:

    1. die meinen Namen im Feld "An" NICHT enthält

    2.  diese Umleiten an eine Person/Verteilerliste  hier taucht das Problem auf: Regel Adressen -> Adressbuch -> MS CRM Adressen -> CRM Warteschlangen

    dort sind die Warteschlangen nicht aufgeführt. Die Firmen, Kontakte etc jedoch auch nicht.

    Wie kann ich also die CRM Adressen in den Outlook Regel Adressen anzeigen und auswählen?

    Donnerstag, 31. Dezember 2009 11:08
  • Geh mal in Deine CRM Optionen und stelle dort bei Adressbuch auf Alle / Alle um und synchronisiere noch mal mit CRM. Manchmal sind die Adressbuch-Einträge nicht sauber zwischen CRM und Outlook synchronisiert. Da hilft es kurz die Optionen umzustellen und neu zu synchronisieren.

    So wie hier http://blog.customereffective.com/blog/2008/02/crm-address-boo.html beschrieben


    Gruß Carsten Groth http://carstengroth.spaces.live.com
    Donnerstag, 31. Dezember 2009 11:22

  • Regel erstellt Meldung im Outlook "Möglicherweise sind einige der Parameter nicht unterstützt oder es ist nicht genügend Speicherplatz zum Speichern aller Ihrer Regeln."
    Also am Speicherplatz kann es nicht liegen!


    Donnerstag, 31. Dezember 2009 13:05
  • Doch, kann es. Im Exchange gibt es eine Grenze von 32k für die Speicherung von Regeln. Manchmal bin ich in meinen Projekten bei einigen Clients schon auf die Grenze gestoßen und musste einige Regeln entsprechend konsolidieren, um unter 16k für die Regel-Datei zu kommen. Siehe http://support.microsoft.com/kb/886616
    Gruß Carsten Groth http://carstengroth.spaces.live.com
    Freitag, 1. Januar 2010 10:18
  • Hallo Carsten,

    also ich habe die kompletten Regeln einmal gelöscht aber trotzdem ist die Meldung erschienen.
    Montag, 4. Januar 2010 16:01
  • Hast Du das hier http://support.microsoft.com/kb/910875/en-us erwähnte Häkchen möglicherweise gesetzt?
    Gruß Carsten Groth http://carstengroth.spaces.live.com
    Montag, 4. Januar 2010 19:02
  • habe alles überprüft und sogar neue Konten, Outlook etc angelegt funktioniert so nicht. Meldung bleibt...
    scheint so als wenn CRM BCC irgendwie nicht mag.

    Dienstag, 5. Januar 2010 17:41
  • Hallo,

    hast du immer noch das Problem, hat dir die vorgeschlagende Lösung geholfen oder hast du mittlerweile eine eigene Lösung gefunden?

    Viele Grüße,
    Jürgen


    Jürgen Beck

    Dipl. Kfm./Wirtschaftsinformatik
    MVP, MCSD.NET, MCITP DBA, MCDBA, MCSE
    Microsoft Certified Business Management Solutions Professional
    Microsoft Certified CRM Developer
    Microsoft Certified Trainer

    ComBeck IT Services & Business Solutions
    Microsoft Gold Certified Partner
    Microsoft Small Business Specialist

    Developing & Supporting Business Applications from small business to big enterprises covering scores of sectors

    http://www.combeck.de
    Mittwoch, 12. Mai 2010 13:22
    Moderator