none
bei der 2. Instanz von Access funktioniert der Startparameter /x nicht mehr

    Frage

  • Hallo zusammen,

    ich habe eine kleine Access-Anwendung, eine Hauptanwendung und einen von uns so genannten Viewer. Beide sind mit einer separaten und zentralen Datenbankdatei im Netzwerk verbunden. In der Hauptanwendung befindet sich die Administration, der Viewer ist abgespeckt und für den normalen User gedacht. In der Hauptanwendung soll ein automatisierter Import laufen, der über ein Makro und dann mit dem Aufruf AccessAnwendungsname /x Makroname gestartet wird. Der Aufruf erfolgt dann über den Taskmanager (Aufgabenplaner, den Job erstelle ich per Script). Bis dahin ist alles gut und funktioniert auch.

    Ein Problem gibt es dann, wenn in der Sitzung des Benutzers Access bereits gestartet ist! Dann startet zwar die Hauptanwendung als 2. Instanz, aber der Startparameter "/X" scheint nicht mehr zu funktionieren.

    Wie kann ich das umgehen, oder geht das überhaupt wie geplant?
    Ich hoffe, das ich mich einigermaßen verständlich ausgedrückt habe :)

    Gruß
    Michael Pleick

    Dienstag, 23. Dezember 2014 11:23

Antworten

  • Hallo,

    ich habe eine Weg gefunden.  Wenn nicht die Batchprogrammierung sondern VBS verwendet wird, dann funktioniert es. Allerdings wird dann nicht der Parameter /x verwendet, sondern die Prozedur kann direkt über rum gestartet werden.

    Gruß
    Michael Pleick

    • Als Antwort markiert Michael Pleick Dienstag, 23. Dezember 2014 22:40
    Dienstag, 23. Dezember 2014 22:40