Installing CCR and DSS Runtime fails - Microsoft Robotics Developer Studio 4


  • I want to install the Microsoft Robotics Developer Studio 4 and downloaded it directly from When I run the .exe file a window pops up with the requirements that will be installed before installing the RDS:
    - MS CCR and DSS Runtime
    - NVIDIA Physx System Software

    When I hit the Install Button the status of CCR/DSS Runtime switches from Pending to Installing and after 10 seceonds of loading or something an error message appears:

    "The files for installation requirement Microsoft CCR and DSS Runtime could not be found. The installation will now stop. This is probably due to a failed, or canceled download"

    I'm quite sure that the file is not broken (multiple times downloaded, filessize matches) and I fullfill all software requirements listed here:

    I would appreciate any help to fix this error.


    Freitag, 16. März 2012 08:35


  • Sorry about the trouble please let us know if you are able to norrow down the problem any more.
    Also send us that verbose install log if you can.

    Donnerstag, 26. April 2012 15:28

Alle Antworten

  • This is the first report of this I have heard of.

    Do you have any previous installs of RDS4?
    Are you running as the system administrator during the install?
    Also try running the installer "As Administrator".


    Freitag, 16. März 2012 23:24
  • I've never use RDS so far, so no old installs (looked it up). I've even tried to install RDS3 with the same result.
    I am running as admin and tried to run "as Admin".

    I downloaded the CCR/DSS Toolkit over Dreamspark to install it seperated from rds, but the same error appears while trying to install the
    ".Net Compact FW 3.5" as a requirement of this package.


    Samstag, 17. März 2012 08:55
  • I appears there is a CCR/DSS requirement that is not installed by CCR/DSS installer.
    I would start by installing the complete ".NET 3.5" runtime. 

    Just to confirm...  you are using Windows7?

    Montag, 19. März 2012 18:05
  • Hi

    I got the same error on a pc running Win 7 and with latest visual studio pro when i should install MS Robotics 4 beta

    Have none older versions of DSS  CCR or robotics, and have net 4 runtime

    i tried with RDS3 and RDS4 beta- but get the same error.

    It installs  the other requiremenst like XNA, but DSS &CCR

    any clue?

    best regards


    Mittwoch, 28. März 2012 05:06
  • I am struggling to figure out what is different about your system since we have done many installs of CCR and DSS to very basic Win7 installations.

    Can you confirm from the control panel that you have the complete .NET Framework 3.5 SP1 installed?

    Can you create a verbose install log?  This page might be helpful in doing that:

    Freitag, 30. März 2012 02:09
  • Hi

    I have not .NET Framework 3.5 SP1 installed

    I have

        .Net framework 4 client profile framework 4 multi Targeting pack

        .net framework 4 extended

        .net framework 4 Multi-Targeting Pack

    See list below

    best regards


    Dienstag, 3. April 2012 14:14
  • Could you install .Net 3.5 SP1 from here and see if it fixes the problem?

    Freitag, 6. April 2012 21:13
  • Hi

    I tried

    but i still get the same error message

    I skip that installation, will use  another PC where it intalled OK....

    Thanks & best regards


    Donnerstag, 12. April 2012 10:28
  • Sorry about the trouble please let us know if you are able to norrow down the problem any more.
    Also send us that verbose install log if you can.

    Donnerstag, 26. April 2012 15:28
  • Do we have some official documentation re:Microsoft.Ccr library and it's prerequisites?

    A computer once beat me at chess, but it was no match for me at kick boxing. - Emo Philips

    Mittwoch, 15. August 2012 15:54
  • Hello,

    i know that questions are old, but now i'm having the same problems! how do you solve that problems?

    Please, i need to install MRDS 4 , and i can't!!! i'm totally crazy! i don't know what can i do! because:

    - I installed NVIDIA PhysX System but the computer ignore it! it tells me that is not installed.

    - I don't have CCR and DSS Runtime anywhere in the computer....

    Please, help me!!


    Mittwoch, 17. Oktober 2012 22:42
  • Hello,

    I do have the same problem. My windows 7 laptop cannot install robotics due failed or canceled install but I never installed it before. I did install some other MS programs though. Also the beta version is not able to install:  Is there an answer available due to error reading initialization file. Is the solution known?

    thanks in advance,


    Montag, 22. Oktober 2012 19:34
  • There have been issues in the past with installing RDS under paths that contain non English characters.  What is path you are installing to?

    Dienstag, 23. Oktober 2012 21:24
  • I tried that one to. After a clean windows install it installed fine. I have no idea about the problem or what initiated the failed install.

    thanks all


    Dienstag, 6. November 2012 20:22