none
Abrufen mit "TF.EXE /GET" klappt nicht, wenn Batch als Aufgabe nachts gestartet wird

    Frage

  • Hallo zusammen,

    ich verwende eine Batchdatei, um alle unsere Solutions auf dem TFS abzurufen und anschließend zu kompilieren.

    Die Batchdatei beginnt dabei mit dem Aufruf von "TF.EXE" und dem Parameter "/get" um zunächst den aktuellen Stand der Dinge abzurufen. Dieser Aufruf klappt auch hervorragend, wenn ich die Batchdatei starte, während ich angemeldet bin. Jetzt wollte ich die Batchdatei aber nachts automatisch laufen lassen und haben sie via "Aufgabenverwaltung" eingebunden. Jede Nacht 2:00 Uhr startet die Aufgabe. Sowohl bei der Aufgabe als auch beim Aufruf von "TF.EXE" sind meine Anmeldeinformationen hinterlegt (Parameter "/Login").

    Alles läuft auch durch, aber es wird einfach nichts abgerufen. Woran kann das denn liegen? Kann ich mir vielleicht irgendwas mitprotokollieren?

    Danke, Karsten.

    Mittwoch, 3. Mai 2017 07:02

Antworten

Alle Antworten

  • Hi Karsten,
    unter welchem Konto läuft die Batch-Datei? Hat dieses Konto auch alle Rechte für den Vorgang, z.B. Schreibrechte im Dateiverzeichnis? Was steht dazu im Ereignisprotokoll des Rechners, auf dem die Batch-Datei ausgeführt wird? 

    --
    Viele Grüsse
    Peter Fleischer (ehem. MVP)
    Meine Homepage mit Tipps und Tricks

    Donnerstag, 4. Mai 2017 04:42
  • Hallo Peter,

    also im Anwendungsprotokoll des Rechners steht exakt um 02:00 Uhr lediglich die folgende Information:

    • TF200027: Von Team Foundation Server wurde die Gruppensynchronisierung mit der folgenden Gruppe gestartet: "Sync Tree".

      Anwendungsdomäne: TfsJobAgent.exe

      Diensthost:       3f576940-787d-45df-9bbd-acd17872914a (TEAM FOUNDATION)

     

    Der Task läuft unter meinem Konto, mit dem ich auch tagsüber arbeite, d.h. beim Anlegen der Aufgabe habe ich meine Benutzerinfo hinterlegt. Es muss auch definitiv was mit meiner Anmeldung zu tun haben, denn heute Nacht lief der Task erfolgreich durch, allerdings habe ich meine Sitzung offen gelassen. Das läuft ja alles auf einem Terminalserver.

    Beim Aufruf von /get habe ich auch per Parameter /login nochmal meine Anmeldeinfo hinterlegt.

    Kann man das /get irgendwie selber nochmal protokollieren? Wenn ich den Befehl in der DOS-Box ausführe, werden ja die abgerufenen Dateien angezeigt. Vielleicht kann man diese Anzeige ja in eine Datei umleiten?

    Viele Grüße, Karsten.

    Donnerstag, 4. Mai 2017 07:06
  • Also ich habe jetzt noch den Tipp gefunden, vor dem "get" Befehl den "workspaces" Befehl abzusetzen. Das werde ich jetzt mal ausprobieren und kann dann Feedback geben.

    Quelle: Klick

    Freitag, 5. Mai 2017 07:22
  • So, wunderbar, der zusätzliche Befehl "workspaces" hat tatsächlich das Problem gelöst.
    • Als Antwort markiert Atlan Gonozal Mittwoch, 17. Mai 2017 14:09
    Donnerstag, 11. Mai 2017 11:55