none
Visual C++ 2005 Kompatibilität RRS feed

  • Frage

  • Hallo,

    ich möchte ein Plugin für eine Software erstellen. Das SDK fordert aber den Visual C++ 2005 compiler. Gibt es eine Art "compatibility mode" in Visual Studio 2010 oder kann ich auf eine andere Art und Weise die neue Version benutzten?

    Vielen Dank für die Hilfe.

    Mittwoch, 2. Juni 2010 09:05

Antworten

  • Welches SDK verlangt VC-2005?
     
    Es gibt keine Möglichkeit reine statische Libs, die mit anderem
    Compilern als dem eigenen erzeugt wurden zu nutzen.
    Handelt es sich nur um Import-Bibliotheken zu DLLs, die PODs und keine
    komplexeren Strukturen/Klassen übergeben, dann spielt der Compiler
    meistens gar keine Rolle.
     
    Du kannst aber VC-2005 parallel installieren und dem VS-2010 Projekt
    IMHO sagen, dass es Comiler/Linker/Libs von VS-2005 nutzen soll.
     

    Martin Richter -- MVP for VC++ [Germany] -- http://blog.m-ri.de
    Mittwoch, 2. Juni 2010 09:33

Alle Antworten

  • Welches SDK verlangt VC-2005?
     
    Es gibt keine Möglichkeit reine statische Libs, die mit anderem
    Compilern als dem eigenen erzeugt wurden zu nutzen.
    Handelt es sich nur um Import-Bibliotheken zu DLLs, die PODs und keine
    komplexeren Strukturen/Klassen übergeben, dann spielt der Compiler
    meistens gar keine Rolle.
     
    Du kannst aber VC-2005 parallel installieren und dem VS-2010 Projekt
    IMHO sagen, dass es Comiler/Linker/Libs von VS-2005 nutzen soll.
     

    Martin Richter -- MVP for VC++ [Germany] -- http://blog.m-ri.de
    Mittwoch, 2. Juni 2010 09:33
  • Alles klar. Vielen Dank,

     

    Ich werde das mal ausprobieren.

    Mittwoch, 2. Juni 2010 16:03