none
MsgBox schweigt stille RRS feed

  • Frage

  • Hallo!

    Google liefert ja genug Treffer auf die Frage wie man eine MsgBox ohne Ton auslösen können mag. Bei mir ist plötzlich das Gegenteil der Fall.

    Der Code ist der selbe und die Windows-Sounds sind ebenfalls noch da (und selbstverständlich sind die Lautsprecher in Betrieb). Auch, aber das sollte hier eigentlich nicht hergehören, die OfficeSounds funktionieren einwandfrei.

    An was kann das liegen, dass sowohl in Word wie in Excel (mehr habe ich erst gar nicht getestet) die Message-Box völlig tonlos daherkommt? Eine Registryeintragug?

    Eric March


    Eric March »Ein Unterschied der keinen Unterschied bewirkt ist kein Unterschied.«
    • Bearbeitet Eric March II Sonntag, 23. Oktober 2011 17:17 Etwas vergessen
    Sonntag, 23. Oktober 2011 17:13

Antworten

  • Hallo Bogdan,

    ich weiß nicht was die Ursache war. Wie auch immer, ich holte ein Systemimage hervor das ein paar Tage alt ist und damit funktionierte es wieder. Die Einstellungen sind vom Augenschein her die selben…

    Pro forma:

    1. Unter welcher Office Version passiert das Problem? 2003 / 2007 /2010

    O2k. Aber das muss irrelevant sein. Denn mir ist nicht aufgefallen, dass ich wohl die Sounds in der Systemsteuerung abspielen kann, dass aber auch WIN selbst (XP, SP3) just dieses Alarmtöne nicht ausgelöst hat, andere (recht willkürlich) funktionierten nämlich noch.

    In der Tat; würde man da eben jene Alarmtöne stillsetzen tut sich auch bei MessageBoxen nichts. Ironischerweise stand da alles da was da normal stehen muss. Und es muss tiefer liegen, ich habe den relevanten Registryteil einem 2. XP eingeimpft und mehr dann dass die etwas anderen Sounds alle da waren ist nicht passiert.

    2. SP Level?

    Drei.

    3. Hast Du auch Office Communicator (MS Lync) drauf?

    Nein.

     

    Grüße,

    Eric March


    Eric March »Ein Unterschied der keinen Unterschied bewirkt ist kein Unterschied.«
    Dienstag, 25. Oktober 2011 17:34

Alle Antworten

  • Hallo Eric,
    Office verwendet eigentlich die Windows Sound-Einstellungen. Man soll bloß der Buttons Parameter (der zweite) des MsgBox angeben:
    Sub MsgBoxes()
        
        'ohne Sound
        MsgBox "Ohne 'Buttons' Parameter"
        'mit Sound
        MsgBox "Mit Exclamation Parameter", vbExclamation
        MsgBox "Mit Question Parameter", vbQuestion
        MsgBox "Mit Critical Parameter", vbCritical
        MsgBox "Mit Information Parameter", vbInformation
    
    End Sub
    

     
    Viele Grüße,
    Bogdan

    Ich bin gerne bei den Foren. Es kommt von Herzen. Es wird aber keine implizite oder sonstige Garantie für die geposteten Antworte / Informationen gewährt. Hier auch die Forenregeln.
    Montag, 24. Oktober 2011 14:12
  • Hallo Bogdan,

    das weiß ich ja alles. Es ging alles wie es sollte - und plötzlich werden die Systemsounds von Office (VBA) nicht ausgelöst (die Office-Sounds dagegen gehen…) Wie gesagt stimmen der Code und die Sounds sind vorhanden und aktiv.

    Wenn wir eine Lösung finden - und da tippe ich insofern auf die Registry -  müsste man den falschen Zustand glatt als Lösungsmittel für Messageboxen ohen Sound verkaufen :)

    Eric March

     

    PS: Dass die Syntax so, ohne Umklammerung, auch funktioniert war mir neu.


    Eric March »Ein Unterschied der keinen Unterschied bewirkt ist kein Unterschied.«
    Montag, 24. Oktober 2011 18:11
  • Hallo Eric,

    alles klar.

    1. Unter welcher Office Version passiert das Problem? 2003 / 2007 /2010

    2. SP Level?

    Danke und v.Gruesse,
    Bogdan


    Ich bin gerne bei den Foren. Es kommt von Herzen. Es wird aber keine implizite oder sonstige Garantie für die geposteten Antworte / Informationen gewährt. Hier auch die Forenregeln.
    Dienstag, 25. Oktober 2011 08:04
  • 3. Hast Du auch Office Communicator (MS Lync) drauf?
    Ich bin gerne bei den Foren. Es kommt von Herzen. Es wird aber keine implizite oder sonstige Garantie für die geposteten Antworte / Informationen gewährt. Hier auch die Forenregeln.
    Dienstag, 25. Oktober 2011 08:06
  • Hallo Eric,

    Ich konnte Dein Problem bei mir nachstellen. Ich habe einfach die aktuellen Windows Sounds für Exclamation z.B. auf None gesetzt und habe ich dann in VBA kein Sound mehr gekriegt.

     

    Also prüfe einfach die Windows-Sound  Einstellungen nach.

    Grüße,

    Bogdan


    Ich bin gerne bei den Foren. Es kommt von Herzen. Es wird aber keine implizite oder sonstige Garantie für die geposteten Antworte / Informationen gewährt. Hier auch die Forenregeln.
    Dienstag, 25. Oktober 2011 08:48
  • Hallo Bogdan,

    ich weiß nicht was die Ursache war. Wie auch immer, ich holte ein Systemimage hervor das ein paar Tage alt ist und damit funktionierte es wieder. Die Einstellungen sind vom Augenschein her die selben…

    Pro forma:

    1. Unter welcher Office Version passiert das Problem? 2003 / 2007 /2010

    O2k. Aber das muss irrelevant sein. Denn mir ist nicht aufgefallen, dass ich wohl die Sounds in der Systemsteuerung abspielen kann, dass aber auch WIN selbst (XP, SP3) just dieses Alarmtöne nicht ausgelöst hat, andere (recht willkürlich) funktionierten nämlich noch.

    In der Tat; würde man da eben jene Alarmtöne stillsetzen tut sich auch bei MessageBoxen nichts. Ironischerweise stand da alles da was da normal stehen muss. Und es muss tiefer liegen, ich habe den relevanten Registryteil einem 2. XP eingeimpft und mehr dann dass die etwas anderen Sounds alle da waren ist nicht passiert.

    2. SP Level?

    Drei.

    3. Hast Du auch Office Communicator (MS Lync) drauf?

    Nein.

     

    Grüße,

    Eric March


    Eric March »Ein Unterschied der keinen Unterschied bewirkt ist kein Unterschied.«
    Dienstag, 25. Oktober 2011 17:34
  • Hi Eric,

    Super, dass es geklappt hat. Irgendeine Benutzerprofil Einstellung wurde koruppt...Vielen Dank.

    VG/Bogdan


    Ich bin gerne bei den Foren. Es kommt von Herzen. Es wird aber keine implizite oder sonstige Garantie für die geposteten Antworte / Informationen gewährt. Hier auch die Forenregeln.
    Mittwoch, 26. Oktober 2011 07:35