none
Access startet nicht + Fehlermeldung: failed to initialize c2rdll

    Frage

  • Access startet nicht + Fehlermeldung: failed to initialize c2rdll

    Wir haben Access 2013 (die normale, nicht Office 365) auf einer Workstation in einem kleinen Firmennetzwerk lokal installiert.

    Wenn man als Administrator angemeldet ist, dann funktioniert Access einwandfrei.

    Als normaler Domain-User erscheint Access aber nicht!

    Unter Computer\<computername>\Benutzer\<benutzername>\AppData\Local\Temp haben wir dann zwei Textdateien gefunden, welche offensichtlich bei jedem Fehlstart angelegt werden:

    - MSACCESS.EXE_c2rdll(<18-stellige Datums- Zeit- und Hex- angaben hier>) und
    - msoiaexe_c2rdll(<18-stellige Datums- Zeit- und Hex- angaben hier>) ,

    welche beide die folgende identische Fehlermeldung enthalten:
    <Datum- Zeit und Process-ID hier> failed to initialize c2rdll: OExeption caught: failed to create registry key: 5 error code: 5 Last error: 0

    Wir haben dann versucht, Access per Rechtsklick als Administrator auszuführen, was leider auch nicht funktioniert.

    Zudem haben wir den User temporär zum Admin erhoben und das Programm ausgeführt, was problemlos funktioniert hat - in der Hoffnung, dass allenfalls fehlende Registry-Einträge so eingetragen würden - aber auch das hat leider nicht funktioniert, mit wieder normalen User-Rechten erscheint Access nach wie vor nicht, sondern legt die oben erwähnten Fehlermeldungen an...

    Das ganze läuft unter Win 7 Pro, es hat auf der Workstation auch noch Office 2010 (ohne Access) installiert.

    Hätte uns da jemand einen Tipp, oder gar die Lösung? :-)

    Vielen Dank und freundliche Grüsse aus der Schweiz :-)

    Freitag, 26. Juli 2013 09:07

Alle Antworten

  • Wir haben Access 2013 (die normale, nicht Office 365) auf einer Workstation in einem kleinen Firmennetzwerk lokal installiert.


    Wenn man als Administrator angemeldet ist, dann funktioniert Access einwandfrei.

    Als normaler Domain-User erscheint Access aber nicht!

    Habt ihr Office als angemeldeter Admin oder als User mit "Ausführen als Administrator" installiert? Ich würde die neues Version vollständig entfernen, benutze auch den vorhandenen FixIt zum vollständigen bereinigen. http://it-blogger.net/post/Office-2013-vollstaendig-entfernen-und-erneut-installieren.aspx Muß unbedingt Access 2010 auch noch installiert sein? Ich würde immer nur mit einer Version arbeiten, deshalb auch immer nur eine Version gleichzeitig installiert haben. http://it-blogger.net/post/Office-2010-vollstaendig-entfernen-und-erneut-installieren.aspx Wenn Du Office vollständig deinstalliert hast, starte den Rechner neu, melde dich als Admin an, und starte die Installation mit "Ausführen als Administrator". Wenn die Installation abgeschlossen ist, unbedingt alle Office Anwendungen per Rechtsklick > Ausführen als Administrator einmal vollständig starten und konfigurieren lassen. Jetzt wieder neu starten und als Benutzer anmelden. Funktioniert jetzt Access 2013?

    Servus
    Winfried
    Freitag, 2. August 2013 13:53