none
SQL Reportserver Email RRS feed

  • Frage

  • Hallo zusammen,

    mal wieder habe ich eine Frage, weil ich nicht weiterkomme. Ich habe schon vieles versucht, aber nichts hat gefunkt.

    Wir haben bei einem Dienstleister eine SQL Server und auch Reportingserver. Ich möchte jetzt über unseren Mailserver im Unternehmen mit dem Berichtsserver bei dem Hoster eine Email versenden. Ich habs auch versucht mit dem IIS als SMTP Server und unserem Mailserver (z.B. http://mntechblog.de/windows-smtp-server-e-mails-ueber-externen-smarthost-versenden/)

    Null geht. Reporting sagt nur immer: Fehler beim Senden von E-Mail: Konfigurationsfehler beim Berichtsserver: .E-Mails werden nicht erneut gesendet

    Ich weiß nicht mehr weiter. Irgendeine Idee?

    Gruß Daniel

    Donnerstag, 25. Februar 2016 11:50

Antworten

  • Hallo zusammen,

    sorry für die späte Antwort. Es läuft jetzt.

    Was haben wir gemacht?
    Wir haben das Konto für den ReportUser auf einen Window AD User umgestellt. Das alleine hat jedoch nicht ausgereicht. Wir haben dann das Konto vom SQL Agent auf das gleiche Konto umstellen müssen.

    Jetzt läuft alles.

    Danke an die Tippgeber :-)

    Gruß Daniel

    • Als Antwort markiert DanWe1 Montag, 9. Mai 2016 12:54
    Montag, 9. Mai 2016 12:54

Alle Antworten

  • Hallo Daniel,

    hast Du schon versucht mit einem SMTP Client eine E-Mail von dem Server zu versenden, um zu sehen, das Versand funktioniert?

    Hast Du mal über SQL Server Database Mail eine E-Mail zu versenden?


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Donnerstag, 25. Februar 2016 12:52
  • Hallo Olaf,

    ja Datenbank Mail funktioniert. 

    Wie kann ich ich das Testen eine Email zu verschicken?

    Gruß Daniel

    Donnerstag, 25. Februar 2016 12:57
  • Database Mail kannst Du einfach testen durch Rechte-Maus => Send Test Mail und in dem Folgedialog gibst Du Deine E-Mail Adresse als Empfänger an.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Donnerstag, 25. Februar 2016 13:50
  • Sorry für die späte Antwort. Ja das Testmail vom Datenbankserver ist angekommen
    Donnerstag, 10. März 2016 12:04
  • Hast Du in der Reportserver Configuration auch eine gültige Absenderadresse hinterlegt und den SMTP-Server (der vom Hoster aus erreichbar sein muss)?

    Einen schönen Tag noch, Christoph -- Data Platform MVP - http://www.insidesql.org/blogs/cmu

    Donnerstag, 10. März 2016 12:32
  • jup - alles hinterlegt. Aber wir sind jetzt mittlerweile einen Schritt weiter. Wenn ich mich Remote auf den Server einlogge und dann mit dem lokalen Adminkonto ein Abo erstelle, dann funktioniert alles wie gewünscht. Mache ich das jedoch über unsere Dömäne mit meinem Namen unter der anderen Domain geht's nicht. Sieht dann irgendwie nach Berechtigung aus?

    Allerdings weiß ich nicht, wie man das lösen kann. Wir haben beim Hoster eine einseitige Vertrauensstellung. unser AD wird da gespiegelt, läuft halt unter der Domäne .B. Firma.res und die normale Dömäne wo es funktioniert - daher sollte es doch funktionieren?

    Freitag, 11. März 2016 06:19
  • Und im Reportserver Log steht nicht mehr als Info?

    Unter welchem Konto läuft der Reportserver?


    Einen schönen Tag noch, Christoph -- Data Platform MVP - http://www.insidesql.org/blogs/cmu

    Freitag, 11. März 2016 08:24
  • Hallo zusammen,

    sorry für die späte Antwort. Es läuft jetzt.

    Was haben wir gemacht?
    Wir haben das Konto für den ReportUser auf einen Window AD User umgestellt. Das alleine hat jedoch nicht ausgereicht. Wir haben dann das Konto vom SQL Agent auf das gleiche Konto umstellen müssen.

    Jetzt läuft alles.

    Danke an die Tippgeber :-)

    Gruß Daniel

    • Als Antwort markiert DanWe1 Montag, 9. Mai 2016 12:54
    Montag, 9. Mai 2016 12:54