none
Abfrage liefert auf chinesischen Rechner anderes Ergebnis

    Frage

  • Hallo zusammen,

    ich habe eine MS Access "Anwendung" welche auf zwei accdb's aufgeteilt ist (Frontend mit Formularen/Abfragen und Backend mit den Haupttabellen)

    Führe ich nun auf einen chinesischem PC (mit englischen Windows OS) ein Formular aus, welches als Datenbasis eine Abfrage nutzt, bekomme ich im Formular ganz andere Ergebisse angezeigt als auf einem deutschem PC, obwohl die gleiche Datenbank als Backend genutzt wird.

    An was kann das liegen? Regioneneinstellungen? Zeichensatz?

    Vielen Dank :)

    Mittwoch, 18. März 2015 07:17

Alle Antworten

  • Was heisst "ganz andere Ergebnisse"? Sehen die Inhalte von Textfeldern anders aus? Dann versuche es mit einer Schrift wie Arial Unicode MS.

    Matthias Kläy, Kläy Computing AG

    Mittwoch, 18. März 2015 09:13
  • Mit ganz anderes Ergebnis meine ich, dass die zugrunde liegende Abfrage, welche die Datensätze für das Formular liefert, nach bestimmten Parametern gefiltert wird (z.B. Where Name = *abc*) und ich dann als Ergebis auf den chinesischen PCs ganz andere Datensätze angezeigt bekomme, als auf den deutschen PCs und diese Datensätze eigtl. gar nichts mit dem eingegebnen Filter zu tun haben.
    Mittwoch, 18. März 2015 12:02
  • Es sind also keine fixen Abfragen, sondern abhängig von Benutzereingaben? Da wäre mein erster Verdächtiger Datumsfelder und der Benutzer z.B. in den Regionaleinstellungen en-GB eingestellt hat, also DD/MM/YYYY, MS Access in SQL Abfragen aber immer MM/DD/YYYY erwartet.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Mittwoch, 18. März 2015 12:14
  • Das hat höchstwahrscheinlich schon mit der Problematik der Zeichensätze (ANSI/Unicode) zu tun. Aber um dein Problem zu verstehen, solltest du den Code angeben, wie du den Filter setzt.

    Matthias Kläy, Kläy Computing AG

    Mittwoch, 18. März 2015 12:14
  • Hallo!

    Um das Rätselraten etwas abzukürzen könntest Du mal den konkreten SQL-String einer der Abfragen hier posten.

    CU


    Thomas@Team-Moeller.de
    Blog: Blog.Team-Moeller.de
    Homepage: www.Team-Moeller.de


    Samstag, 21. März 2015 09:14
  • Hat das Frontend die gleiche Collation wie das Backend? (File - Options - General - New database sort order)

    Falls nicht, stell sie mal ein, wie sie sein soll. Danach komprimieren und nochmal probieren.

    Gruss - Peter


    Freitag, 3. April 2015 18:21
    Moderator