none
Visual Studio Enterprise 2015- Installation bricht ab

    Frage

  • I habe erst VS Studio 2013 Ultimate deinstalliert auf  Windows 7 professional. Nun will ich Visual Studio Enterprise 2015 installieren. I installiere in verschiedenen Versuchen wahlweise mit

    de_visual_studio_enterprise_2015_with_update_1_x86_x64_web_installer_8234344

    oder aber dem ISO-Image 

    de_visual_studio_enterprise_2015_with_update_1_x86_x64_dvd_8234338,iso.

    Beides geladen von Dreamspark.

    In allen Versuchen bricht die Installation ab mit Fehlermeldung.

    Hier die Fehlermeldungen aus zwei Fehlerlogs.  Gelistet ist jeweils der erste Fehler, der zum Abbruch und zum Rollback der Installation geführt hat: 

    [0E90:186C][2016-10-09T16:04:05]i338: Acquiring package: vs_communitycoreres, payload: cab99BE860BD8B3416F4ABD18F406FCF4BD, download from: http://go.microsoft.com/fwlink/?prd=12514&pver=Dev14&sbp=d14u1ss&plcid=0x409&clcid=0x409&ar=24720.41&sar=S80_RCPrep&o1=1B5C3A245C8D6CB41CABD7D231DC51567547F23B
    [13C8:1ABC][2016-10-09T16:04:12]e000: Error 0x80070643: Process returned error: 0x643
    [13C8:1ABC][2016-10-09T16:04:12]e000: Error 0x80070643: Failed to execute EXE package.
    [0E90:0E64][2016-10-09T16:04:12]e000: Error 0x80070643: Failed to configure per-machine EXE package

    [1B6C:1628][2016-10-07T22:51:39]i338: Acquiring package: vs_enterprisecore, payload: cabB365924A88347F6A54E88D83A631AA9C, download from: http://go.microsoft.com/fwlink/?prd=12514&pver=Dev14&sbp=d14u1ss&plcid=0x409&clcid=0x409&ar=24720.41&sar=S80_RCPrep&o1=48886D7EDADC7DD2CE748DF7DD808178C7B0688B


    [1B6C:1628][2016-10-07T22:51:39]i338: Acquiring package: vs_enterprisecore, payload: cabB365924A88347F6A54E88D83A631AA9C, download from: http://go.microsoft.com/fwlink/?prd=12514&pver=Dev14&sbp=d14u1ss&plcid=0x409&clcid=0x409&ar=24720.41&sar=S80_RCPrep&o1=48886D7EDADC7DD2CE748DF7DD808178C7B0688B

    [164C:1588][2016-10-07T22:51:40]e000: Error 0x80070643: Process returned error: 0x643
    [164C:1588][2016-10-07T22:51:40]e000: Error 0x80070643: Failed to execute EXE package.
    [1B6C:0928][2016-10-07T22:51:40]e000: Error 0x80070643: Failed to configure per-machine EXE package.

    Wenn ich die Links aus den obigen Meldungen in einen Webbrowser eingebe werden jeweils eine Dateien cab1.cab, bzw. cab8.cab runtergeladen. Zumindest die Dateien scheinen zugreifbar. 

    Was geht da schief? Wie muss ich weiter vorgehen? Wie kriege ich Visual Studio Enterprise 2015 installiert?







    Sonntag, 9. Oktober 2016 19:02

Alle Antworten

  • Hi,
    nimm mal die aktuelle Version als ISO-Datei:

    en_visual_studio_professional_2015_with_update_3_x86_x64_dvd_8923272.iso
    SHA1: 2126C6EBE83DC3065A1C499D8D0C7F253D275BF1

    Außerdem ist wegen Suchen zu Problemen die englische Version die bessere Alternative.

    Wenn das aus unterschiedlichen Gründen nicht möglich ist, dann prüfe bei Deiner heruntergeladenen ISO-Datei den Hashcode. Vermutlich liegt da ein Fehler vor.

    Dateiname: de_visual_studio_enterprise_2015_with_update_1_x86_x64_dvd_8234338.iso
    SHA1: 50DB28CFE3FAECE6F9F9780BAA922B7B06840B15

    Ein Installieren mit dem Web-Installer kann zum obigen Fehler führen, wenn die Internet-Verbindung nicht stabil oder zeitweilig langsam ist. Deshalb ist es besser, das ISO-Image herunterzuladen, zu prüfen und dann dieses für eine Installation zu nutzen (ohne Internet-Verbindung beim Installieren).


    --
    Viele Grüsse
    Peter Fleischer (MVP Reconnect, Partner)
    Meine Homepage mit Tipps und Tricks

    Montag, 10. Oktober 2016 04:46
  • Hallo,

    wie Peter schon schreibt, überprüfe zuerst die SHA Prüfsumme und verwende die aktuellste Version (derzeit Update 3). Unter den Downloads findet man auch Visual Studio 2015 Enterprise Edition mit Update 3

    Gruß Elmar

    Montag, 10. Oktober 2016 06:15
  • Hallo Peter und ELmar, 

    danke für die Hinweise und die Unterstützung. 

    fciv -sha1 de_visual_studio_enterprise_2015_with_update_1_x86_x64_dvd_8234338.iso

    liefert mir  50db28cfe3faece6f9f9780baa922b7b06840b15 der Hashcode stimmt also. Wegen Bequemlichkeit und Umweltschutz mounte ich das ISO mit VirtualCloneDrive (VCD) statt eine DVD zu brennen. Weiterer Grund für VCD: Das ISO ist auch 6.2 GB gross und mein Brenner schafft glaub nur 4.7 GB. Das Vorgehen mit VCD meine ich müsste passen. Mache das auch mit anderen Softwareinstallationen so, da gab es bisher nie Probleme. 

    Ich habe den Dreamspark-Licencsekey für für dieses ISO. Denke dass der Key an die DE-Version und dieses ISO gebunden ist. 

    Habe auch mal die Hoffnung auf ENTERPRISE versuchsweise in den Wind geschrieben und wollte COMMUNITY zu installieren. Ich vermute das der VS-2015 Installer kein Freund ist von meiner Windows-7 Installation. Die läuft nun schon zu lange und die Registry ist wohl etwas madig geworden. Schade das gerade die MS-Entwicklungsplattform Mühe hat auf meinem durchwirkten Windows-7 Fuss zu fassen. Andere Programme hatten da bisher keine Mühe beim Installieren.

    Mein Plan: Windows-7 neuinstallieren. Dazu muss ich aber erst eine Oracle-DB(DEV) auf einen anderen Rechner migirieren und ein Softwareinventar erstellen. Das wird also einige Tage dauern bis ich soweit bin. Wenn möglich möchte ich diesen Aufwand natürlich auch vermeiden. Ein stabiles Betriebssystem sollte ja auch nicht ständig aus irgendwelchen Sachzwängen heraus neu installiert werden ;-)

    Gibt etwas das ich noch tun kann, womit ich eine Neuinstallation auf einem frischen OS vermeiden kann?

    Freundliche Grüsse 

    Othmar


    • Bearbeitet LPNO Mittwoch, 12. Oktober 2016 12:07
    Dienstag, 11. Oktober 2016 22:15
  • Ich musste dann doch das ganze Windows-7 installieren. Danach hat dann auch VS2015 richtig installiert. Danke für die Tips. Offenbar ist die Installation von VS2015 doch etwas zickig, wenn die OS-Installation und ihre Registry schon eine längere Vorgeschichte aufweisen.
    • Bearbeitet LPNO Mittwoch, 7. Dezember 2016 18:54
    Mittwoch, 7. Dezember 2016 18:52