none
.net framework 3.5 Installation schlägt fehl RRS feed

  • Frage

  • Hallo,


    kurz vor Weg - mein System:
    Vista 32 bit


    ich habe .net framework 3.5 von folgender Seite gedownloadet :

    http://www.microsoft.com/downloads/details.aspx?familyid=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=de

    Während der Installation bekam ich jedoch eine Windows Fehlermeldung.
    Hier der Inhalt des Fehlerprotokolls:


    [03/12/10,11:09:31] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,09:56:14] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,18:20:43] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,18:20:59] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/13/10,18:44:18] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,22:23:46] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,22:24:01] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/13/10,22:38:03] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,22:38:20] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/13/10,22:46:03] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/14/10,15:13:40] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/14/10,15:13:55] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/14/10,15:56:54] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/14/10,15:57:13] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/14/10,18:12:00] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/14/10,18:12:20] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/14/10,20:02:37] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/14/10,20:02:56] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/15/10,19:26:23] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/15/10,21:23:48] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/15/10,21:24:01] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.





    Ich habe bereits folgenden Lösungsvorschlag getestet, jedoch ohne Erfolg:


    ** Start -> Ausführen -> "msconfig"

    ** [Dienste] -> [Alle deaktivieren]

    >> danach bitte folgende Dienste reaktivieren:

    - Fehlerberichterstattung
    - Ereignisprotokoll
    - Intelligenter Hintergrundübertragungsdienst
    - Plug & Play
    - Windows Installer
    - Systemwiederherstellung

    ** Dann [OK] drücken, die möglicherweise folgende Fehlermeldung wegklicken und den Neustart veranlassen.

    ** Nach dem Neustart kommt eine Meldung, dass dies eben kein normaler Start war, da [OK] drücken, worauf "msconfig" startet, [Abbrechen] drücken und den Neustart ablehnen.

    =>> In diesem Modus lassen sich alle .NET Framework Versionen widerstandslos installieren.

    Nach der Installation "msconfig" noch einmal starten und alle Dienste wieder aktivieren.



    Ich habe ebenfalls den folgenden KB Eintrag verwendet, ohne Erfolg:


    http://support.microsoft.com/kb/923100/


    Unter "Programme und Funktionen" wird keine .net framework Version angezeigt, also kann ich auch keine deinstallieren. Allerdings existiert unter C:\Windows\Microsoft.NET ein Ordner der v1.0, v2.0 und v3.0 beinhaltet.

    Unter "zu installierende Updates" wird folgendes Update als wichtig eingestuft, lässt sich aber ebenfalls nicht installieren. Vielleicht weil es ein Update für .net framework ist?

    Ich besitze leider sehr wenig Erfahrung was solche Programme bzw. Probleme angeht und wäre über jeden (hilfreichen) Tip dankbar. Falls noch mehr Informationen benötigt werden,  schreibt mir dies bitte.

    MfG
    Mittwoch, 17. März 2010 14:24

Antworten

  • Hallo,

    was das CMD Fenster angeht: Vereinzelt nutzen Installationsprogramme Aufrufe
    über die Kommandozeile, die solche Fenster erzeugen. Die Regel ist das aber nicht.

    Was das Protokoll angeht: Dort hat sich bereits über die Tage einiges angesammelt.
    Nur das eigentliche Problem läßt sich daran nicht ablesen, dazu brauchte man
    die detaillierten Protokolle.

    In den englischen Foren findest Du eine detaillierte Anleitung von YiChun Chen
    unter   Installing .NET Framework 3.5 SP1 fails on Vista 32-bit
    Versuche die Schritte dort, klappt es weiterhin nicht,
    stelle die Protokolle wie dort angegeben zum Download bereit.

    Auf der anderen Seite:
    Wenn das System so hartnäckig streikt und Du bereits zwei Wochen
    daran verschwendet hat, wird es Zeit darüber nachzudenken,
    den Rechner neu zu installieren.

    Gruß Elmar
    Donnerstag, 18. März 2010 08:50
    Beantworter

Alle Antworten

  • Hallo,

    installiere bitte gleich Microsoft .NET Framework 3.5 Service Pack 1 ,
    da aktueller und einige Probleme damit behoben sind.
    Für Vista sollte das Service Pack 2 bereits installiert sein.

    Tritt der Fehler wieder auf, kannst Du probieren ob hilft:
    Automated cleanup tool to remove the .NET Framework 1.0, 1.1, 2.0, 3.0 and 3.5
    (wird im KB Artikel 923100 auch genannt)

    Zum "Lösungsvorschlag":
    Die häufigsten Probleme bereiten Virenscanner,
    die Du während der Installation ausschalten solltest.

    Vista wird bereits mit .NET Framework 3.0 (enthält 2.0) ausgeliefert,
    so dass die Existenz der Ordner normal ist.

    Was das wichtige Update angeht, fehlt leider die Beschreibung bzw. KB Nummer.

    Gruß Elmar
    Mittwoch, 17. März 2010 16:09
    Beantworter
  • Hallo,

    danke für die schnelle Antwort
    Hab versucht  das von dir gepostete .net framework zu installieren. Das Resultat is immer noch der gleiche Fehler.
    Was ich vielleicht noch vergessen hab zu erwähnen, während der Installation öffnet sich mehrmals ein Fenster wie bei der cmd. exe, aber nur für einen Bruchteil einer Sekunde, danach verschwindet es wieder ohne das ein Inhalt zu erkennen ist.

    Beschreibung:
      Beim Setup von Microsoft .NET Framework 3.5 SP1 ist ein Problem aufgetreten. Setup konnte nicht abgeschlossen werden. Vielleicht hilft dir / euch der folgende Auszug aus der Windows Fehlermeldung:


    Dateien, die bei der Beschreibung des Problems hilfreich sind:
      C:\Users\Jan\AppData\Local\Temp\WLF6013.tmp
      C:\Users\Jan\AppData\Local\Temp\SDB638E.tmp
      C:\Users\Jan\AppData\Local\Temp\VSW10\VSSWMSISummary.txt
      C:\Users\Jan\AppData\Local\Temp\VSW10\VSSWMSIInstallTime.txt
      C:\Users\Jan\AppData\Local\Temp\VSW10\VSSWMSIFailInfo.txt
      C:\Users\Jan\AppData\Local\Temp\dd_dotnetfx35install.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI0086.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI0185.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI0270.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI0358.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI10F8.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI11E3.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI1200.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI12EB.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI1313.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI13D3.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI1401.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI14EC.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI1738.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI1820.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI1907.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI19E9.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI1CCB.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI1DB3.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI1EA2.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI1F6E.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI1FD8.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI207D.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI2178.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI2263.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI24A4.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI25AF.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI2857.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI2963.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI303A.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI3149.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI3824.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI3926.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI3A1B.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI3B03.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI3F5B.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI4087.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI417D.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI42AD.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI5747.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI5812.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI58B8.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI5910.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI59FF.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI5AED.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI6385.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI64AE.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI65A3.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI6627.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI669B.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI671F.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI6BEB.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI6CF0.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI74A7.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI7585.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI7653.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI7727.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI7AFC.txt
      C:\Users\Jan\AppData\Local\Temp\dd_NET_Framework35_MSI7BFA.txt

    Lesen Sie unsere Datenschutzrichtlinie:
      http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0407

    Bei dem Cleanup Programm stehen bei mir .net framework 1.0, 1.1 und 3.5 zur Auswahl.

    Hier ein paar Informationen zum Update:


    Update für die Microsoft .NET Framework 3.5 Service Pack 1- und .NET Framework 3.5-Produktfamilie (KB951847) x86

    Downloadgröße: 41,7 MB

    Sie müssen ggf. den Computer neu starten, damit die Änderungen wirksam werden.

    Updatetyp: Wichtig

    Dies ist ein Update für Windows Vista Service Pack 2 and Windows Server 2008 Service Pack 2. Microsoft .NET Framework 3.5 Service Pack 1 ist ein vollständig kumulatives Update, das viele neue Features enthält, die inkrementell auf .NET Framework 2.0, 3.0 und 3.5 aufbauen. Es enthält ferner kumulative Wartungsupdates für die Unterkomponenten .NET Framework 2.0 und .NET Framework 3.0. Das Update für die .NET Framework 3.5-Produktfamilie enthält wichtige Updates zur Anwendungskompatibilität. Dieses Update wird unter den Lizenzbedingungen für Windows Vista und für Windows Server 2008 zur Verfügung gestellt.

    Weitere Informationen:
    http://go.microsoft.com/fwlink/?LinkId=133335

    Hilfe und Support:
    http://support.microsoft.com

    Mittwoch, 17. März 2010 16:27
  • Hallo,

    aufgrund des angezeigten Updates scheint Dein Vista der Meinung zu sein,
    dass das .NET Framework 3.5 bereits installiert ist.
    Denn das Update ist dazu gedacht um eine vorhandene NET 3.5 Installation
    auf Service Pack 1 zu aktualisieren.

    Vermutlich ist Deine Installation so unglücklich fehlgeschlagen,
    dass der Zustand aufgetreten ist.

    Du solltest über das Cleanup Programm .NET 3.5 deinstallieren.
    Danach einen erneuten Versuch mit 3.5 inkl. Service Pack 1 starten.

    Schlägt das immer noch fehl, deinstalliere 1.1 und 1.0
    und noch ein Versuch.

    Löschen bitte vor der Installation alle Dateien aus dem TEMP Ordner,
    der oben angezeigt wird.

    Gruß Elmar
    Mittwoch, 17. März 2010 17:39
    Beantworter
  • Ich benutz einfach mal die Option "cleanup all versions". Ist es normal das bei erneutem Starten des Cleanup Tools die Versionen 1.0, 1.1 und 3.5 immer noch angezeigt werden? Laut dem Tool wurden diese jedenfalls erfolgreich entfernt. Ein Neustart ist nach dem Entfernen mit dem Cleanup tool nicht nötig, oder ?

    Würde es helfen, dass Update zu entfernen, falls möglich, angeblich ist es bereits herunter geladen und muss nur noch installiert werden.
    Hier noch mal ein kleiner Auszug aus dem Log des Cleanup Tools:

    [03/14/10,16:06:39] Detected operating system: Windows Vista (x86)
    [03/14/10,16:06:39] Install state for .NET Framework 1.0: not installed.
    [03/14/10,16:06:39] Install state for .NET Framework 1.1: not installed.
    [03/14/10,16:06:39] Install state for .NET Framework 2.0: installed with service pack 2.
    [03/14/10,16:06:39] Install state for .NET Framework 3.0: installed with service pack 2.
    [03/14/10,16:06:39] Install state for .NET Framework 3.5: not installed.
    [03/14/10,16:06:39] Install state for .NET Framework 4 Client: not installed.
    [03/14/10,16:06:39] Install state for .NET Framework 4 Full: not installed.
    [03/14/10,16:06:39] Not adding product '.NET Framework - All Versions' because the OS condition does not match
    [03/14/10,16:06:39] Not adding product '.NET Framework - All Versions (Tablet PC and Media Center)' because the OS condition does not match
    [03/14/10,16:06:39] Not adding product '.NET Framework - All Versions (Windows Server 2003)' because the OS condition does not match
    [03/14/10,16:06:39] Not adding product '.NET Framework - All Versions (Windows 7)' because the OS condition does not match
    [03/14/10,16:06:39] Not adding product '.NET Framework 2.0' because the OS condition does not match
    [03/14/10,16:06:39] Not adding product '.NET Framework 3.0' because the OS condition does not match


    Gruß Schrödi
    Mittwoch, 17. März 2010 17:49
  • Hallo Schrödi,

    sicherheitshalber nach solchen Aktionen immer neustarten.

    Das Update ignoriere für den Moment, das sollte nach einer erfolgreichen
    Installation erkennen, dass es nicht mehr benötigt wird.
    Und vorher wird es vermutlich immer wieder auf Fehler laufen.

    Die Liste sieht danach aus, dass für Vista .NET Standard installiert ist,
    was wie schon geschrieben inkl. NET 3.0 kommt.

    Gruß Elmar

    Mittwoch, 17. März 2010 18:13
    Beantworter
  • Hallo Elmar,

    nach dem Neustart zeigt das Cleanup Tool immer noch v1.0, 1.1 und 3.5 an.
    Während der Installation taucht leider immer noch der gleiche Fehler auf.
    Weiß nicht ob das irgendwas zu bedeuten hat, aber bei dem Versuch .net framework mit dem Client zu installieren (dies hab ich probiert als ich alle anderen irrelevanten Dienste deaktiviert hatte) blieb das Setup bei 46% hängen.
    Mittwoch, 17. März 2010 18:19
  • Hallo,

    Zur Anzeige von V1.0...: Das "not installed" heißt, das es nicht installiert ist.

    je nach Geschwindigkeit Deines Rechners kann die Installation einige Zeit dauern.
    Da die Prozentangaben nicht immer zuverlässig sind, sollte man einige Zeit
    warten, auch wenn sich da anscheinend nichts mehr rührt.

    Verwende ggf. den dsa vollständige Paket , das Du auf der Downloadseite
    unten findest, denn dabei wird nicht permanent übers Internet nachgeladen.

    Und bitte lasse die Konfiguration der Microsoft-Dienste, so wie sie voreingestellt ist
    und ändere sie nur aus gutem Grund (niemals aber aus Verdacht).
    Denn da hängt vieles zusammen, was man ohne die Hintergründe
    zu kennen, nicht ändern sollte. Einen Link dazu:
    http://www.drwindows.de/windows-anleitungen-und-faq/306-vista-dienste-ubersicht.html

    Gruß Elmar
    Mittwoch, 17. März 2010 19:31
    Beantworter
  • Hallo,

    Mit der Aussage, dass Cleanup Tool zeige die Version 1.0 1.1 und 3.5 immer noch an, meinte ich, dass es immer noch als löschbar angezeigt wird bzw in der Auswahlliste zu verfügung steht.
    Die Dienste habe ich bereits alle wieder aktiviert.
    Dein vollständiges Paket hat leider auch nichts geändert, ich bekomme immer noch den gleichen Fehler.
    Das Fehlerprotokoll beinhaltet folgendes:




    [03/12/10,11:09:31] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,09:56:14] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,18:20:43] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,18:20:59] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/13/10,18:44:18] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,22:23:46] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,22:24:01] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/13/10,22:38:03] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/13/10,22:38:20] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/13/10,22:46:03] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/14/10,15:13:40] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/14/10,15:13:55] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/14/10,15:56:54] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/14/10,15:57:13] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/14/10,18:12:00] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/14/10,18:12:20] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/14/10,20:02:37] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/14/10,20:02:56] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/15/10,19:26:23] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/15/10,21:23:48] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/15/10,21:24:01] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/15/10,21:35:37] Microsoft .NET Framework 3.5 'package': [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/15/10,21:35:37] Microsoft .NET Framework 3.5 'package': [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/15/10,21:35:38] Microsoft .NET Framework 3.5 'package': [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/15/10,21:35:38] Microsoft .NET Framework 3.5 'package': [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/15/10,21:35:38] Microsoft .NET Framework 3.5 'package': [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/15/10,21:35:39] Microsoft .NET Framework 3.5 'package': [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/15/10,21:35:39] Microsoft .NET Framework 3.5 'package': [2] dlmgr: dlmgr::JobBase::Retry:  all retries failed
    [03/15/10,21:35:40] Microsoft .NET Framework 3.5 'package': [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [03/15/10,21:35:40] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [03/15/10,21:35:40] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [03/15/10,21:35:40] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [03/15/10,21:35:40] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [03/15/10,21:35:41] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [03/15/10,21:35:41] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [03/15/10,21:35:41] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [03/15/10,21:35:41] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/15/10,21:35:41] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5LP - DEU was not attempted to be installed.
    [03/15/10,21:45:21] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/15/10,21:45:35] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/16/10,16:16:06] Microsoft .NET Framework 3.5LP - DEU: [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/16/10,16:16:07] Microsoft .NET Framework 3.5LP - DEU: [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/16/10,16:16:07] Microsoft .NET Framework 3.5LP - DEU: [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/16/10,16:16:07] Microsoft .NET Framework 3.5LP - DEU: [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/16/10,16:16:08] Microsoft .NET Framework 3.5LP - DEU: [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/16/10,16:16:08] Microsoft .NET Framework 3.5LP - DEU: [2] dlmgr: dlmgr::CDownloadJobURLMonImpl::Failed:  URLMonError: Download failure (0x800c0005)
    [03/16/10,16:16:08] Microsoft .NET Framework 3.5LP - DEU: [2] dlmgr: dlmgr::JobBase::Retry:  all retries failed
    [03/16/10,16:17:36] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/16/10,17:54:36] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/17/10,15:02:52] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/17/10,17:22:11] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/17/10,17:22:32] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/17/10,17:32:00] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/17/10,17:32:18] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/17/10,18:51:44] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/17/10,18:52:00] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/17/10,19:21:06] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/17/10,19:21:24] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [03/17/10,19:24:46] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/17/10,21:06:45] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [03/17/10,21:07:00] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.


    Könnte es sein, dass irgendwas mit meinem Windows Installer nicht stimmt? Dieses cmd.exe Fenster taucht auch bei anderen Installationen auf.

    Hoffe du kannst mir irgendwie weiter helfen, bin schon seit fast 2 Wochen am Verzweifeln

    Gruß
    Mittwoch, 17. März 2010 20:06
  • Hallo,

    was das CMD Fenster angeht: Vereinzelt nutzen Installationsprogramme Aufrufe
    über die Kommandozeile, die solche Fenster erzeugen. Die Regel ist das aber nicht.

    Was das Protokoll angeht: Dort hat sich bereits über die Tage einiges angesammelt.
    Nur das eigentliche Problem läßt sich daran nicht ablesen, dazu brauchte man
    die detaillierten Protokolle.

    In den englischen Foren findest Du eine detaillierte Anleitung von YiChun Chen
    unter   Installing .NET Framework 3.5 SP1 fails on Vista 32-bit
    Versuche die Schritte dort, klappt es weiterhin nicht,
    stelle die Protokolle wie dort angegeben zum Download bereit.

    Auf der anderen Seite:
    Wenn das System so hartnäckig streikt und Du bereits zwei Wochen
    daran verschwendet hat, wird es Zeit darüber nachzudenken,
    den Rechner neu zu installieren.

    Gruß Elmar
    Donnerstag, 18. März 2010 08:50
    Beantworter
  • Ich hätte Vista ja bereits neu installiert wenn ich denn die notwendige DvD hätte. Den Key hab ich zwar nur die DvD nicht ;)

    Bei deinem Link finde ich leider keinen Beitrag von "YiChun Chen". Sicher das es der richtige ist? Oder hast du sonst noch einen Tip für mich ?

    Freitag, 23. April 2010 17:51
  • Hallo,

    ich habe oben den Link zum Beitag geändert - irgendwie seltsam,
    auch wenn es möglich ist, das ich den falschen Link erwischt hatte.

    Wenn man Dir einen Rechner ohne DVD "angedreht" hat,
    schau nach, ob sich die Installationsmedien auf der Platte befinden.
    Bei Billig-über-den-Tisch-Ware wird schon mal auf die DVD verzichtet
    und man muß sie sich selbst brennen (wenn denn ein Brenner dabei ist).

    Gruß Elmar

     

    Samstag, 24. April 2010 18:03
    Beantworter
  • Die Situation ist etwas anders, ein Bekannter arbeitet bei der Telekom und hat mir den Rechner zusammen gebastelt & Vista installiert. Jedoch hat er mir die DvD nicht überlassen und ist mittlerweile weggezogen und ich habe keinen Kontakt mehr zu ihm. Wo würde ich diese Installationsmedien denn finden?

    Gruß

    Samstag, 24. April 2010 22:04
  • Hallo,

    die Aussage bezog sich auf Kauf-Rechner (Supermärkte, Versandhandel und Co.).
    Dein Bekannter wird wohl eine "invidiuellere" Methode gewählt haben,
    und wenn Du nicht irgendwo durch Glück ein Verzeichnis findest...

    Aber bei einer Neuinstallation solltest Du heute eher überlegen
    Windows 7 als Systembuilder Version zu kaufen und zu installieren.

    Gruß Elmar

    Sonntag, 25. April 2010 07:32
    Beantworter