none
Fehler beim Starten von Apps im Debugger

    Frage

  • Ich kann seit kurzem keine Apps mehr im Debugger starten. Meine letzten Aktionen waren das Erstellen eines App-Packages und die Installation der App auf meinem Rechner. Ich habe auch noch einmal einige Farben von Menüs geändert und ein neues Package erstellt und nach Deinstallation erneut erfolgreich installiert und gestartet. Das Projekt selbst scheint mir daher ok zu sein. Ich erhalte folgende Meldungen:

    Darüber hinaus findet sich nach erfolglosem Start im Ausgabefenster folgendes:

    "XXX.exe" (CoreCLR: DefaultDomain): "C:\Program Files\WindowsApps\Microsoft.NET.CoreRuntime.1.0_1.0.23819.0_x86__8wekyb3d8bbwe\mscorlib.ni.dll" geladen. PDB-Datei wurde nicht gefunden oder konnte nicht geöffnet werden.
    Ausnahme ausgelöst: "System.Exception" in mscorlib.ni.dll
    Die Aktivierung der Windows Store-App "49994XXXXX.yyyyyyBeta_y6p5rjkrrpfyg!App" ist mit Fehler "Die App wurde nicht gestartet" fehlgeschlagen.
    Das Programm "[448] XXX.exe" wurde mit Code -532462766 (0xe0434352) beendet.

    Für den Fall, dass es die fehlende PDB-Datei ist, wie bekomme ich die nachinstalliert, bzw. wenn ich die irgendwo finde, wo muss die hin?

    Auch alte Projektstände oder neu erstellte Projekte lassen sich nicht im Debugger starten. Was habe ich mir da zerschossen bzw. kaputt parametriert?
    Beim Installieren mit Shell musste ich außerdem irgendetwas mit Zertifikaten bestätigen. Hat es vielleicht etwas damit zu tun?

    Danke schon mal vorab

    ------------------------------------------------------------------------------

    Edit: Folgendes habe ich erfolglos ausprobiert.

    • Visual Studio über das Setup repariert
    • Projekt bereinigt => hier
    • In Visual Studio neu am Microsoft Konto angemeldet und die Entwicklerlizenz aktualisiert

    • Bearbeitet Mail0 Sonntag, 1. Mai 2016 11:04 Update
    Samstag, 30. April 2016 21:51

Alle Antworten

  • Hallo!

    Hatte das Problem letztens auch! Ich hatte im Verdacht das es die neue Insider Preview von Windows war!

    Bei mir hat es nur nach einer komplette Neuinstallation von VS funktioniert! Reparaturversuche sind zwecklos bei mir gewesen!

    Habe immer Probleme wenn Ich eine neue Insider Preview Build von Windows installiere! Habe mir das deinstallieren von VS schon deswegen angewöhnt!

    Gruß

    Sonntag, 1. Mai 2016 14:18
  • Ich bin jetzt soweit, dass ich sogar mein Windows 10 zurück gesetzt habe. Allerdings kann ich immer noch keine UWP-Apps debuggen. Normale Anwendungen lassen sich auch über Visual Studio problemlos starten. Im Ereignissprotokoll habe ich folgende Meldungen gefunden:

    • [ID:5990]Fehler bei der Aktivierung über das Vertragshilfsprogramm: App b604f730-866a-4b8f-92ac-7c7c8d7d0422_y6p5rjkrrpfyg!App für den Windows.Launch-Vertrag: Starten des Servers fehlgeschlagen.
    • [ID:5961]Fehler bei der Aktivierung der App „b604f730-866a-4b8f-92ac-7c7c8d7d0422_y6p5rjkrrpfyg!App“ für den Vertrag „Windows.Launch“: Die App wurde nicht gestartet.
    • [ID:5985]ActivateApplicationForContractByAppIdAsUserWithHost-Fehler bei der App b604f730-866a-4b8f-92ac-7c7c8d7d0422_y6p5rjkrrpfyg!App für den Windows.Launch-Vertrag: Die App wurde nicht gestartet..

    Bei Ereignisskategorie ist jedes mal 5961 eingetragen.

    Für mich interessant zu lesen,... aber wirklich anfangen kann ich damit nix.

    Montag, 2. Mai 2016 20:21
  • Ist Windows 10 im Entwicklermodus?

    Einstellungen >> Update und Sicherheit >> Für Entwickler

    Welches Windows 10 Build ist es?

    Dienstag, 3. Mai 2016 09:47
  • Windows 10 ist im Entwicklermodus und jetzt mit allen Konsequenzen nochmals neu aufgesetzt (hilflos). Aber es geht immer noch nix. So langsam verzweifle ich. Ja, Windows ist im Entwicklermodus.

    Der Windwos Build ist 10586.281.  Zielversion der Apps wenn ich sie erstelle ist von 10240 bis 10586.

    An den Fehlermeldungen hat sich nichts geändert. In der App war nur eine Textbox,... nur um da alles auszuschließen. Auf dem Rechner befinden sich derzeit nur Browser und Visual Studio. Ich habe es beim letzten mal mit Anmeldung an mein Entwicklerkonto getestet, jetzt ohne. Wird da vielleicht etwas mit meinem Microsoft Konto abgeglichen, dass ich mir jedes mal nach Anmeldung übers Internet die gleiche Scheiße auf den Rechner hole? :(

    Dienstag, 3. Mai 2016 16:45
  • VS mal als Administrator gestartet?

    Benutzerrechte der Verzeichnisse

    C:\Program Files (x86)\Microsoft Visual Studio 14.0

    und

    C:\Program Files\Microsoft Visual Studio 14.0

    kontrolliert?

    Dienstag, 3. Mai 2016 17:27
  • Als Admin habe ich das gleiche Problem.

    C:\Program Files\Microsoft Visual Studio 14.0 => Hab ich nicht

    C:\Program Files (x86)\Microsoft Visual Studio 14.0  => zumindest der Admin hat alles außer Special permitions

    Aber ändern kann ich da irgendwie nichts.

    Ich hab auch folgendes gefunden:

    takeown /R /F *.*

    icacls "c:\windows" /q /c /t /grant "ALL APPLICATION PACKAGES":F

    Auch wenn ich nicht wirklich weiß was es macht, habe ich es in meiner Verzweiflung trotzdem ausprobiert.Hat allerdings leider auch nicht geholfen. Der zweite Befehl läuft außerdem auf meinem Rechner nicht => Invalid parameter "ALL APPLICATION PACKAGES"

    • Bearbeitet Mail0 Dienstag, 3. Mai 2016 19:21
    Dienstag, 3. Mai 2016 19:16
  • Im eventviewer finde ich außerdem folgendes:

    • [ID 10010] The server App did not register with DCOM within the required timeout

    DCOM kannte ich eigentlich bisher nur von OPC,... aber es scheint auch was mit den UWP apps zu tun haben.

    Dienstag, 3. Mai 2016 19:28
  • So,

    alles erneut installiert (explizit als Admin) und beim Windows 10 SDK ausschließlich das neueste angewählt.
    Jetzt kann ich wieder Apps erstellen und dann sogar starten. Bei der Windows Installation habe ich ebenfalls alles auf Standard gelassen. Jetzt bin ich zwar nicht mehr mit den Einstellungen zufrieden, allerdings kann ich wieder weiter arbeiten.

    Danke noch mal für die Unterstützung!!! :)

    !!! EDIT !!!

    Es liegt am Projektpfad, bzw. dessen freigaben. Hab jetzt noch mal das eigentliche Projekt geöffnet und auch ein neues am entsprechenden Ort erstellt und wieder geht nix. Dann noch mal Im Ordner Dokumente auf "C" und dort ging's dann. Leider ist auf C absolut kein Platz. Aber jetzt weiß ich wonach ich suchen muss.
    PS: @dombar => Ich glaube jetzt zu wissen, das es das war, worauf du mich hinweisen wolltest. Danke noch mal!!!

    • Bearbeitet Mail0 Mittwoch, 4. Mai 2016 13:12
    Mittwoch, 4. Mai 2016 12:55