none
Visual Studio Online: Benutzer zu Teamprojekten hinzufügen RRS feed

  • Frage

  • Hi,

    wir verwenden unter anderem Visual Studio Online. Kürzlich haben wir einen neuen Kollegen bekommen. Diesen konnte ich, nachdem er im Azure AD hinzugefügt wurde, auch auf Server-Ebene als Benutzer hinzufügen.

    Ich bin jedoch nicht in der Lage, ihn als Benutzer zu einem Teamprojekt hinzuzufügen. Weder über die "Manage" Funktion auf Teamprojekt-Ebene, noch über den umständlichen Weg der Gruppen. Interessanterweise kann ich auch keinen anderen Benutzer zu irgendeinem Teamprojekt hinzufügen. An meinen Berechtigungen sollte es nicht liegen, da ich Owner und entsprechend auch sämtliche Admin Rechte habe.

    Wenn ich versuche einen Benutzer zu einem Teamprojekt hinzuzufügen und auf Save Changes klicke schließt sich das Pop Up und es passiert nichts. Gelegentlich zeigt es mir einen Fehler "Could not load identities".

    Ich habe es jetzt schon mit verschiedenen Browsern auf verschiedenen Rechnern mit unterschiedlichen Betriebssystem versucht - erfolglos.

    Kennt jemand dieses Problem, oder besser noch eine Lösung? Handelt es sich ggf. um einen Bug?

    Montag, 12. Oktober 2015 07:43

Alle Antworten

  • Hi,
    ich habe das schon öfter gemacht, ohne im Azure-AD hinzuzufügen. Es reichte, den live-Account hinzuzufügen und schon bekam der Betreffende die Einladung und konnte mitarbeiten.

    --
    Viele Grüsse
    Peter Fleischer (MVP, Partner)
    Meine Homepage mit Tipps und Tricks
    Kommas richtig setzen!
    Schüler sagen, Lehrer haben es gut.
    Schüler, sagen Lehrer, haben es gut

    Montag, 12. Oktober 2015 08:09
  • Hi,

    ja, das hängt davon ab. Bei uns liegt als Benutzerverwaltung das Azure AD zu Grunde. Wird der Benutzer dort nicht hinzugefügt, kann ich ihn zwar im TFS hinzufügen, bei der Anmeldung bekommt er aber 403 - Unauthorized.

    Wie gesagt, ich konnte ihn ja grundsätzlich auf Collection Ebene anlegen, was nicht funktioniert ist eben die Berechtigung auf ein Teamprojekt. Die Seite "flackert" kurz, hinzugefügt wird der Benutzer aber nicht. An meiner Unfähigkeit sollte es - eigentlich - nicht liegen, da ich das schon etliche Male vorher getan habe.

    Montag, 12. Oktober 2015 09:36