none
Schema und Mapping nicht mehr auswählbar

    Frage

  • Hallo. Folgendes Problem trat heute auf. Ich habe eine Orchestrierung, welche Nachrichten von einem WebService empfängt. Hierfür habe ich den WebService per WebVerweis in das Projekt eingebunden. Um eine Anfrage an den WebService zu erstellen, habe ich ein Schema erzeugt und die Werte der Inputdatei durch ein Mapping auf das Request des WebServices gemapped. Anschließend konnte ich das Projekt ohne Porbleme kompilieren und deployen. Nun das Problem. Nach dem Neustart des Visual Sudio 2008 ist die Orchestrierung auf ein Mal nicht mehr in der Lage auf das „lokale“ Schema und das Mapping zuzugreifen. Die Messages melden einen Fehler, dass das Schema nicht gefunden werden kann. Auch die Transformation-Nodes sind nicht mehr in der Lage die Mappings anzusprechen. Beide sind jedoch im Projektmappen-Explorer des VS sichtbar. Ich bin in der Lage nur mit den Schemata des WebServices zu arbeiten. Woran kann das liegen???
    • Bearbeitet -I_P- Mittwoch, 7. Dezember 2011 15:34
    Mittwoch, 7. Dezember 2011 15:32

Antworten

  • Da keine auf diese Frage eine Antwort hatte, habe ich das Problem anders lösen müssen:

    Ich habe die Schemata von der Logik komplett getrennt. Dazu wurde ein Projekt erstellt, in welchem die Schemata (lokale als auch WebDienst-bezogene) und das Mapping definiert wurden.

    In einem separaten wurde die Orchestrierung definiert und auf das erste per Referenz verwiesen.
    (Nun geht nichts mehr verloren)

    • Als Antwort markiert -I_P- Freitag, 16. Dezember 2011 16:28
    Freitag, 16. Dezember 2011 16:27

Alle Antworten

  • Da keine auf diese Frage eine Antwort hatte, habe ich das Problem anders lösen müssen:

    Ich habe die Schemata von der Logik komplett getrennt. Dazu wurde ein Projekt erstellt, in welchem die Schemata (lokale als auch WebDienst-bezogene) und das Mapping definiert wurden.

    In einem separaten wurde die Orchestrierung definiert und auf das erste per Referenz verwiesen.
    (Nun geht nichts mehr verloren)

    • Als Antwort markiert -I_P- Freitag, 16. Dezember 2011 16:28
    Freitag, 16. Dezember 2011 16:27
  • Hallo zusammen,
     
    Funktioniert ein Rebuild des Projektes? Ggf. die Schema DLLs compilieren und lokal in den GAC deployen.
     
    Grüße
     
    Jörg Fischer
     
     
     
    "microsoft_pfeifer" schrieb im Newsbeitrag news:1f7439b5-f197-45b3-a7dd-70978e80c2e1...
    Hallo. Folgendes Problem trat heute auf. Ich habe eine Orchestrierung, welche Nachrichten von einem WebService empfängt. Hierfür habe ich den WebService per WebVerweis in das Projekt eingebunden. Um eine Anfrage an den WebService zu erstellen, habe ich ein Schema erzeugt und die Werte der Inputdatei durch ein Mapping auf das Request des WebServices gemapped. Anschließend konnte ich das Projekt ohne Porbleme kompilieren und deployen. Nun das Problem. Nach dem Neustart des Visual Sudio 2008 ist die Orchestrierung auf ein Mal nicht mehr in der Lage auf das „lokale“ Schema und das Mapping zuzugreifen. Die Messages melden einen Fehler, dass das Schema nicht gefunden werden kann. Auch die Transformation-Nodes sind nicht mehr in der Lage die Mappings anzusprechen. Beide sind jedoch im Projektmappen-Explorer des VS sichtbar. Ich bin in der Lage nur mit den Schemata des WebServices zu arbeiten. Woran kann das liegen???

    Jörg Fischer
    Dienstag, 31. Januar 2012 15:30
    Moderator