none
Bereitstellungsprozess endet nicht

    Frage

  • Ich habe eine VHD mit Server 2012 nach ausgeführtem sysprep per AzCopy in einen anderen Account kopiert, was problemlos funktioniert hat. Der Server ist auch gestartet und läuft soweit tadellos und ist via VPN und extern erreichbar. Im Azure Dashboard wird jedoch stets "Der Bereitstellungsprozess wird ausgeführt. Sie können die Konfigurationseinstellungen ändern, nachdem die Bereitstellung abgeschlossen ist." angezeigt und eben dieser Prozess endet nicht. Auch Neustart, bzw. herunterfahren  nütz nichts.

    Ersuche um Ideen...

    Vielen Dank

    mfg
    Kurt

    Samstag, 28. Juni 2014 03:15

Alle Antworten

  • Nachtrag

    Nach mehreren Stunden:

    Rosarotes Rufzeichen mit "Wird ausgeführt (Timeout bei der Bereitstellung)"

    Grüße

    Kurt

    Samstag, 28. Juni 2014 03:51
  • Hallo Kurt,

    hast du denn die VHD zuvor mit SYSPREP generalisiert?

    Azure IaaS versucht den Administratornamen und das Passwort beim Setup/ersten Start der VM einzupflegen. Wenn der Server nicht generalisiert wurde, läuft das Minisetup nicht los und Azure wartet (vergebens).

    Kannst du dich denn auf der Maschine mit RDP einloggen und verbinden?

    Welchen Weg hast du gewählt, um aus deinem VHD eine VM zu machen?

    Florian


    The views and opinions expressed in my postings do NOT necessarily correlate with the ones of my friends, family or my employer. If anyone should be allowed to mark a response as an "answer", it should be the thread creator. No one else.

    Montag, 30. Juni 2014 09:11
  • Hallo Florian,

    danke für deine Antwort!

    Ja, ich hatte sysprep gemacht, allerdings ohne Generalisierung, auf der Server konnte ich eingentlich fehlerfrei per RDP exten und via VPN zugreifen, nur der Bereitstellungsprozess hat nicht geendet.

    Ich habe den Vorgang einfach wiederholt -diesmal mit Generalisierung- und siehe da der (mein) Fehler war weg und der Server läuft wie gewünscht.

    Ich hatte beim ersten Mal die Generalisierung werggelassen, da es sich um einen DC handelt, war wohl ein Denkfehler.

    Grüße

    Kurt

    Montag, 30. Juni 2014 09:20
  • Hallo Kurt,

    Generalisierung und DC beißt sich ein wenig.

    Wenn du die VM hochladen willst ohne SYSPREP/Generalisierung, kannst du das auch tun. Dann darfst du allerdings beim Deployment das VHD-Image nicht aus der Gallery auswählen sondern musst aus dem VHD eine VM-Disk erstellen, die du dann beim VM-Erstellen auswählst.

    Anderer Vorgang, aber auch funktionell. Generalisieren und Gallery sind eben dafür da, dass du ein generisches Image erstellst und davon dann 1..n gleiche VMs erstellst.

    Florian


    The views and opinions expressed in my postings do NOT necessarily correlate with the ones of my friends, family or my employer. If anyone should be allowed to mark a response as an "answer", it should be the thread creator. No one else.

    Montag, 30. Juni 2014 10:55
  • Hallo Florian,

    ja, langsam habe ich -nach weiteren Versuchen- da auch durchgeblickt, es ist auch in Anleitungen für AzCopy, das ja das Herunter- und wieder Hochladen erspart und wirklich ganze Server in Sekunden von einem Account in einen anderen kopiert, so beschrieben. Bei einer bestehenden Domäne (z. B. ein Sever lokal per VPN mit Azure verbunden) muss man es -so wie du beschreibst- ohne Generalisierung machen, da man sonst die SID verliert.

    Danke für deine Tips

    Kurt

    Montag, 30. Juni 2014 11:22