none
Umwandlung von ACCDB 2010 in ACCDE verläuft fehlerhaft

    Frage

  • Hallo,

    derzeit versuche ich eine ACCDB 2010 in eine ACCDE zu wandeln. Die Erstellung der ACCDE verläuft fehlerfrei. Beim Start der ACCDE wird das Startformular geöffnet und dann ist Schluss. Öffne ich ein anderes Formular ist der gleiche Effekt. Es wird also der VB-Code nicht abgearbeitet.

    Vor der Erstellung habe ich die ACCDB kompiliert und alle Haltepunkte herausgenommen. Der Speicherort ist als vertrauenswürdiger Speicherort eingetragen.

    Es sind derzeit die Sicherheitseisntellungen auf minimalst eingestellt, Makros und AktivX darf tun was möchte. Das nehme ich nach der Fehlerfindung wieder heraus.

    Wie bekomme ich die ACCDE lauffähig?

    Arbeitsumgebung

    Windows 7 Ultimate SP1 64 Bit

    MS Office Prof Plus 2010

    Access Version 14.0.6112.5000 (32-Bit)

    Vielen Dank im Voraus für die Hilfe

    Bjoern

    Dienstag, 15. Mai 2012 14:49

Antworten

  • Hallo,
     
    Bjoern Kulig wrote:
     
    > derzeit versuche ich eine ACCDB 2010 in eine ACCDE zu wandeln. Die
    > Erstellung der ACCDE verläuft fehlerfrei. Beim Start der ACCDE wird das
    > Startformular geöffnet und dann ist Schluss. Öffne ich ein anderes
    > Formular ist der gleiche Effekt. Es wird also der VB-Code nicht
    > abgearbeitet.
    > [...]
     
    Versuch mal folgendes:
     
    - /decompile der ACCDB, siehe http://www.donkarl.com?FAQ1.23
    - Reparieren/Komprimieren
    - Kompilieren
    - ACCDE erzeugen
     
    HTH - Peter
     
    --
     
    • Als Antwort markiert Bjoern Kulig Mittwoch, 16. Mai 2012 10:49
    Dienstag, 15. Mai 2012 21:21
    Moderator
  • Bjoern Kulig wrote:
    > ...
    > LEHRE: Immer Compile vor dem Erzeugen einer ACCDE machen!
    >
    > Eigentlich hatte ich noch weitere Fragen, deren Lösungsansatz ich
    > aber bei DonKarls-Access-Seiten gefunden habe.
    > ...
     
    Noch als Hinweis für Leute mit ähnlichen Problemen:
     
    Dort gibt es auch eine FAQ zu
     
    MDE-Erstellung scheitert
     
    in der als 1. Lösung zum Kompilieren geraten wird.
    Werde jetzt mal den Titel um "ACCDE" ergänzen. ;-)
     
    --
    Servus
    Karl
    *********
     
     
     
    • Als Antwort markiert Bjoern Kulig Mittwoch, 16. Mai 2012 14:15
    • Tag als Antwort aufgehoben Bjoern Kulig Mittwoch, 16. Mai 2012 14:17
    • Als Antwort markiert Bjoern Kulig Mittwoch, 16. Mai 2012 14:25
    Mittwoch, 16. Mai 2012 13:22

Alle Antworten

  • Hallo,
     
    Bjoern Kulig wrote:
     
    > derzeit versuche ich eine ACCDB 2010 in eine ACCDE zu wandeln. Die
    > Erstellung der ACCDE verläuft fehlerfrei. Beim Start der ACCDE wird das
    > Startformular geöffnet und dann ist Schluss. Öffne ich ein anderes
    > Formular ist der gleiche Effekt. Es wird also der VB-Code nicht
    > abgearbeitet.
    > [...]
     
    Versuch mal folgendes:
     
    - /decompile der ACCDB, siehe http://www.donkarl.com?FAQ1.23
    - Reparieren/Komprimieren
    - Kompilieren
    - ACCDE erzeugen
     
    HTH - Peter
     
    --
     
    • Als Antwort markiert Bjoern Kulig Mittwoch, 16. Mai 2012 10:49
    Dienstag, 15. Mai 2012 21:21
    Moderator
  • Hallo,

    Danke für die Antwort.

    Eigentlich hätte ich auch selbst darauf kommen können. Ich habe nur von Gunter die Anregung der Abschaltung der Symbolleisten eingefügt. Dabei etwas falsch verstanden und etwas Fehlerverursachendes eingefügt. Danach leider anscheinend kein Compile mehr gemacht. Die fehlerverurachenden Statements sind jetzt auskommentiert und es geht.

    LEHRE: Immer Compile vor dem Erzeugen einer ACCDE machen!

    Eigentlich hatte ich noch weitere Fragen, deren Lösungsansatz ich aber bei DonKarls-Access-Seiten gefunden habe.

    Noch einmal Danke

    Bjoern

    Mittwoch, 16. Mai 2012 11:28
  • Bjoern Kulig wrote:
    > ...
    > LEHRE: Immer Compile vor dem Erzeugen einer ACCDE machen!
    >
    > Eigentlich hatte ich noch weitere Fragen, deren Lösungsansatz ich
    > aber bei DonKarls-Access-Seiten gefunden habe.
    > ...
     
    Noch als Hinweis für Leute mit ähnlichen Problemen:
     
    Dort gibt es auch eine FAQ zu
     
    MDE-Erstellung scheitert
     
    in der als 1. Lösung zum Kompilieren geraten wird.
    Werde jetzt mal den Titel um "ACCDE" ergänzen. ;-)
     
    --
    Servus
    Karl
    *********
     
     
     
    • Als Antwort markiert Bjoern Kulig Mittwoch, 16. Mai 2012 14:15
    • Tag als Antwort aufgehoben Bjoern Kulig Mittwoch, 16. Mai 2012 14:17
    • Als Antwort markiert Bjoern Kulig Mittwoch, 16. Mai 2012 14:25
    Mittwoch, 16. Mai 2012 13:22
  • Mein Irrtum lag darin begründet, dass ich der Meinung war Kompile gemacht zu haben.

    Den Ratschlag von Peter habe ich stur abgearbeitet, weil es mir als letzte Möglichkeit erschien. Danach habe ich mir stundenlang an die Stirn geklopft. Zukünftig werde ich lieber einmal mehr als zuwenig Kompile machen.

    Die Ergänzung des Titels ist sicher trotzdem hilfreich.

    Mittwoch, 16. Mai 2012 14:34