none
Access DB kann nicht mit Runtime Version geöffnet werden - Fehlermeldung

    Frage

  • Hallo

    Ich habe eine DB mit MS Access 16 erstellt. Alles läuft prima.

    Ich habe eine accde-Version erstellt damit der Endbenutzer die DB mit Access Runtime benutzen kann.

    Der Benutzer hat die Runtime Version installiert und die DB damit eröffnet.

    Fehlermeldung:

    "Datenbank kann die in "tbl_Artikel" erhaltene Daten nicht lesen.

    Zur lesen der Daten ist mindestens Version 16.0.7124.1000 erforderlich"

    Doch ein Version Problem passiert obwohl die MS Access 2016 auf die neuste Version aktualisiert ist und der Endbenutzer die aktuelle Runtime Version vom MS Download Center installiert hat.

    Wo liegt das Problem, bzw. was müssen wir unternehmen damit man die DB mit Runtime benutzen kann?

    Danke im Voraus für eure Hilfe

    Dienstag, 6. November 2018 14:22

Alle Antworten

  • Hi,

    probier es mal mit der englischen Fehlermeldung:

      The minimum required version to read the data is 16.0.7124.1000

    Bei einigen hat wohl das komprimieren und reparieren der Datenbank geholfen. Bei anderen das erneute Einfügen der betroffenen Tabellen.


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET (2001-2018)
    https://www.asp-solutions.de/ - IT Beratung, Softwareentwicklung, Remotesupport

    Dienstag, 6. November 2018 14:35
    Moderator
  • Zur lesen der Daten ist mindestens Version 16.0.7124.1000 erforderlich


    Dann hast du wahrscheinlich neue Funktionen verwendet, z.B. BigInt (Grosse Zahl) als Datentyp in tbl_Artikel. Das ist erst seit besagter Version möglich und die aktuell verfügbaren Runtime-Versionen stammen aus dem Jahr 2015. 

    Dir bleibt also nicht als den Tabellenentwurf anzupassen.

    Gruss - Peter

    Mittwoch, 7. November 2018 11:02
    Moderator