none
SQL Server Management Studio - Edit Modus Tabelle funktioniert nicht

    Frage

  • Hallo zusammen,

    ich fand keine bessere Rubrik, hoffe daher, dass das Problem hier thematisiert werden kann.

    Ich habe ein riesen Problem mit dem Edit-Modus des SSMS. Ich kann mich problemlos mit der Datenbank verbinden. Folgendes geht unproblematisch: Rechtsklick auf Tabelle innerhalb der DB -> Kontextmenu -> "Oberste 1000 Zeilen auswählen" -> Im Hauptfenster erscheinen die Daten im Grid (readonly).

    Bei folgendem verfällt SSMS in den Inaktiv-Modus (im Taskmanager dennoch CPU-Belastung mit 31%) -> Rechtsklick auf Tabelle innerhalb der DB -> Kontextmenu -> "Oberste 200 Zeilen bearbeiten". Im Hauptfenster wird begonnen, das Eigenschaftenfenster aufzurufen, aber nicht vollständig gerendert. Ich habe mehrere unterschiedliche Versionen (2017, 2016) versucht, aber immer das gleiche Ergebnis. Das Problem existiert aber auch noch nicht lange, weiß aber nicht, wann und warum dies nun nicht mehr funktioniert. Ich hoffe auf Tipps, da ich keine Lust habe, das OS (Win 10) inkl. sämtl. Programme neu zu installieren.

    Ein Screenshot habe ich erstellt: https://ibb.co/j6a3Kb

    Im Ereignisprotokoll finde ich folgendes (nachdem ich das inaktive, auf Rückmeldung wartende Studio schloss):

    Programm Ssms.exe, Version 2015.130.16106.4 kann nicht mehr unter Windows ausgeführt werden und wurde beendet. Überprüfen Sie den Problemverlauf in der Systemsteuerung "Sicherheit und Wartung", um nach weiteren Informationen zum Problem zu suchen.
     Prozess-ID: 1930
     Startzeit: 01d36dbffbe1a47b
     Beendigungszeit: 0
     Anwendungspfad: C:\Program Files (x86)\Microsoft SQL Server\130\Tools\Binn\ManagementStudio\Ssms.exe
     Berichts-ID: aa2c7619-b8a6-4686-b975-b2c6a5134037
     Vollständiger Name des fehlerhaften Pakets:
     Auf das fehlerhafte Paket bezogene Anwendungs-ID:

    Unter "Sicherheit und Wartung" findet sich nichts.

    Hat jemand Tipps zum Bereinigen des Problems, ohne das OS neu installieren zu müssen?

    Gruß
    Ronald


    • Bearbeitet Ronald Siegel Dienstag, 5. Dezember 2017 12:48 Präzisierung des Problems
    Dienstag, 5. Dezember 2017 12:38

Alle Antworten

  • Ergänzung: Auch wenn ich eine Tabelle "entwerfen" möchte, funktioniert es nicht. Anscheinend sobald ein editierbares Grid geöffnet wird, verweigert SSMS seinen Dienst.
    Dienstag, 5. Dezember 2017 15:52
  • Hallo Ronald,

    SSMS 2016 ist leider so ziemlich die unbrauchbarste Version, die ich beim SSMS je gesehen habe.

    Installier bitte die aktuellste Version des SSMS 2017 (derzeit 17.3, v14.0.17199.0) und schau, ob das Problem damit auch auftritt.

    Du schreibst zwar, Du hast es mit verschiedensten Versionen probiert aber nicht, mit welchen Builds genau.

    Falls das Problem auch mit SSMS 17.3 auftritt, meld dich bitte nochmal hier.

    Falls Du aus irgendeinem Grund SSMS 2016 zwingend brauchst, aktualisier bitte auf 16.5.3. Die Fehlermeldung besagt, dass Du die veraltete Version 16.3 verwendet hast.

    Dann bitte jegliche Plugins, die evtl. installiert sind (kommen manchmal auch parallel zu Visual Studio Plugins) deaktivieren bzw. deinstallieren.

    Virenscanner bitte testweise vollständig abschalten.

    Falls Du Visual Studio installiert hast, aktualisiere diese Installation bitte und falls das nicht hilft, reparier die Installation nochmal.

    Ansonsten poste bitte noch die exakte Version der SQL Server Instanz, mit der Du dich verbinden willst und schreib dazu, ob das ein lokaler SQL Server (also auf der gleichen Maschine wie das SSMS) oder ein Remote Server ist.

    Willst Du eigentlich eine Tabelle oder eine View auf die o.g. Art bearbeiten?

     


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community






    Dienstag, 5. Dezember 2017 19:55
  • Hallo,

    danke. Wie ich schon schrieb, hatte ich zuvor die Version 17.3. im Betrieb gehabt mit dem gleichen Resultat. Ich habe nun Visual Studio komplett entfernt und neu installiert. Nun klappt es wieder. Zum Glück muss ich nicht das System neu aufsetzen.

    Ergänzung: Ich konnte weder Tabelle noch View damit bearbeiten. Auch neue Tabellen erstellen ging damit nicht.

    Gruß
    Rinakd

    Donnerstag, 7. Dezember 2017 16:16
  • ... einen Tag später und schon wieder treten die Probleme auf. Aber ich sehe, ich bin nicht der einzige: https://stackoverflow.com/questions/43039964/sql-server-management-studio-crash-on-edit-rows

    Samstag, 9. Dezember 2017 17:20
  • Hallo Ronald,

    solange Du die anderen Fragen nicht beantwortest, kann ich dir leider auch nicht helfen (Ok, kann sein, dass ich auch mit den Antworten nicht helfen kann ohne diese aber definitiv nicht)


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    Samstag, 9. Dezember 2017 19:37
  • Hallo,

    der Zugriff folgte auf folgende SQL-Server (1. extern, 2. lokal installiert)

    1. Microsoft SQL Server 2014 (SP2-CU7) (KB4032541) - 12.0.5556.0 (X64)   Aug 17 2017 12:07:38   Copyright (c) Microsoft Corporation  Express Edition (64-bit) on Windows NT 6.3 <X64> (Build 9600: ) (Hypervisor)
    2. Microsoft SQL Server 2017 (RTM) - 14.0.1000.169 (X64)   Aug 22 2017 17:04:49   Copyright (C) 2017 Microsoft Corporation  Developer Edition (64-bit) on Windows 10 Pro 10.0 <X64> (Build 16299: ) (Hypervisor)

    Visual Studio Community Edition 2017 Version 15.5.1

    Microsoft SQL Server Management Studio      14.0.17199.0
    Microsoft Analysis Services-Clienttools      14.0.1008.227
    Microsoft Data Access Components (MDAC)      10.0.16299.15
    Microsoft MSXML      3.0 5.0 6.0
    Microsoft Internet Explorer      9.11.16299.0
    Microsoft .NET Framework      4.0.30319.42000
    Betriebssystem      6.3.16299

    Heute deinstallierte ich Visual Studio, nachdem das Problem erneut auftrat, aber dieses Mal brachte es keine Änderung. 

    Antiviren-Suite (Norton) habe ich selbstverständlich auch zeitweise deaktiviert. Das brachte keine Änderung.

    Plugins? Ich hatte Visual Studio komplett deinstalliert. Aber keine Besserung. Danach installierte ich VS erneut - ohne Plugins - aber leider keine Änderung.

    Danke und Gruß
    Ronald

    Samstag, 9. Dezember 2017 21:45
  • Hallo Ronald,

    mit Ausnahme von Windows 10 habe ich mir jetzt mal ein identisches System aufgebaut. (in meinem Fall Windows 8.1, die Windows 10 VMs sind grade belegt).

    Diese Frage nach lokal oder remote hab ich gestellt, da es seit SSMS 2016 erhebliche Unterschiede bei entsprechenden Zugriffen gibt. Teils gab es eben auch Abstürze bei bestimmten Aktionen auf Remoteservern.

    Ich kann das Problem hier leider nicht nachstellen, weder auf einem lokalen, noch auf einem Remoteserver.

    Daher kann ich im Moment leider nur zwei Sachen empfehlen:

    • Mit dem SysInternal Process Monitor schauen, ob Du feststellen kannst, was genau da just in dem Moment des "Absturz" passiert.

    • Einen Connect Eintrag erstellen wobei ich befürchte, dass das Problem nicht ohne weiteres bei den MS Entwicklern zu reproduzieren ist.

    Da das Problem auch mit mehreren SSMS Versionen auftritt, würde ich aber annehmen, dass es eine Konstellation auf deinem PC ist, die zu diesem Absturz führt. Sowas ist natürlich nur sehr schwer zu debuggen, da niemand exakt dein System hat.

    Frage dazu wäre allerdings: Seit wann tritt das Problem auf? Evtl. erst seit dem letzten (oder einem der letzten) Windows 10 Updates?


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community


    Samstag, 9. Dezember 2017 23:43
  • Hallo,

    danke für die Rückmeldung. Seit wann es auftritt, kann ich nicht sagen. Erstaunlich ist aber, dass die komplette Neuinstallation von VS und SSMS am Donnerstag dazu führte, dass es funktionierte! VS wurde seitdem auch nicht neu installiert. Einen Tag später dann schon wieder nicht mehr. Woran ich mich erinnere ist, dass ich .Net 4.7 und 4.7.1 nachträglich installierte. So danach alles deinstalliert (inkl. VS und .net 4.7.1) und gestern erneute Neu-Installation. Aber dieses mal funktionierte es von Anfang an nicht. Naja, ich hoffe, nachdem das Problem auf stackoverflow doch einige Mal in letzter Vergangenheit diskutiert wurde, dass es vielleicht mit einem update von VS geklärt wird. Bis dahin nutze ich HeidiSQL (allerdings ist das eben leider nicht mein Favorit).

    Deine Empfehlungen werde ich testen.

    Danke nochmals.

    Gruß
    Ronald

    P.S. Ein direkter Absturz ist es nicht. SSMS hängt bei 20% - 30% CPU-Auslastung (Keine Rückmeldung...)


    Sonntag, 10. Dezember 2017 10:00
  • Hallo Ronald,

    hattest Du evtl. mal eine Beta oder eine RC von SSMS und/oder Visual Studio installiert? Beide Programme sind teils eng miteinander verzahnt und VS spielt (wie man ja auch gesehen hat) schon eine größere Rolle beim SSMS als man evtl. denkt. Da kann eine vor der Installation der RTM installierte Beta oder RC Version schon vielerlei Probleme verursachen.


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

    Sonntag, 10. Dezember 2017 11:33
  • Hallo Stefan,

    nein, derartiges hatte ich nicht installiert. Der Process Monitor bringt mich auch nicht weiter, da SSMS ja nicht wirklich abstürzt, sondern weiter, weiter und weiter "arbeitet"... 

    Na mal schauen, vielleicht gibt sich das Problem mit einem nächsten update.

    Gruß
    Ronald


    PS. Das SSMS-Update auf 17.4 brachte keinen Erfolg. 
    Sonntag, 10. Dezember 2017 22:55