locked
Update VS 2010 (Compact Framework 4 !!) RRS feed

  • Frage

  • Hallo,

    ich wollte einmal nachfragen, ob es jetzt eigentlich einmal das angekündigte Update für Visual Studio 2010 geben wird, um WindowsMobile (Net Compact Framework) entwickeln zu können. Ich bekomme demnächst ein neues Notebook und möchte mir ersparen wieder das VS2008 installieren zu müssen.

    Ich steige ganz bestimmt nicht auf WP7 um, bevor da nicht was vernüftiges kommt.

    Grüße Dennis

    Donnerstag, 11. November 2010 19:52

Antworten

  • Hallo Dennis,

    wo wurde denn ein Update für Visual Studio 2010 angekündigt? Mir ist in dieser Hinsicht außer Gerüchten bislang nichts begegnet. Dagegen gibt es in der MSDN-Library zahlreiche Stellen, an denen eindeutig steht, dass .NET-Compact-Framework-Entwicklung in Visual Studio 2010 nicht unterstützt wird, zum Beispiel hier oder auch hier. Ein Compact Framework 4 ist ebenfalls nicht angekündigt. Windows Phone 7 basiert auf einem .NET Compact Framework 3.7, welches allerdings nicht einzeln veröffentlicht wird und in seinen Möglichkeiten doch sehr eingeschränkt ist.

    Bei Microsoft Connect läuft derzeit eine Petition zu diesem Thema. Diese kannst Du ja unterstützen. Vielleicht merkt man dann bei Microsoft, dass die Entscheidung zahlreiche Entwickler unzufrieden gemacht hat. Wenn Du bis zu einer Entscheidung nicht warten kannst, wirst Du aber wohl oder übel Visual Studio 2008 auf Deinem Notebook installieren müssen, um Software für mobile Geräte entwickeln zu können.

    Marc

    • Als Antwort markiert Dennis Nusser Freitag, 19. November 2010 19:10
    Freitag, 12. November 2010 12:35

Alle Antworten

  • Hallo Dennis,

    wo wurde denn ein Update für Visual Studio 2010 angekündigt? Mir ist in dieser Hinsicht außer Gerüchten bislang nichts begegnet. Dagegen gibt es in der MSDN-Library zahlreiche Stellen, an denen eindeutig steht, dass .NET-Compact-Framework-Entwicklung in Visual Studio 2010 nicht unterstützt wird, zum Beispiel hier oder auch hier. Ein Compact Framework 4 ist ebenfalls nicht angekündigt. Windows Phone 7 basiert auf einem .NET Compact Framework 3.7, welches allerdings nicht einzeln veröffentlicht wird und in seinen Möglichkeiten doch sehr eingeschränkt ist.

    Bei Microsoft Connect läuft derzeit eine Petition zu diesem Thema. Diese kannst Du ja unterstützen. Vielleicht merkt man dann bei Microsoft, dass die Entscheidung zahlreiche Entwickler unzufrieden gemacht hat. Wenn Du bis zu einer Entscheidung nicht warten kannst, wirst Du aber wohl oder übel Visual Studio 2008 auf Deinem Notebook installieren müssen, um Software für mobile Geräte entwickeln zu können.

    Marc

    • Als Antwort markiert Dennis Nusser Freitag, 19. November 2010 19:10
    Freitag, 12. November 2010 12:35
  • Hallo Marc,

    Danke die 'Gerüchte' habe ich gemeint. Ich habe schon einmal bei Frank Prengel meinen Unmut ausgedrück. Der kann aber auch nichts dafür.

    Hier: http://blogs.msdn.com/b/windowsphone/archive/2010/05/04/device-entwicklung-vs2008-vs-vs2010.aspx?wa=wsignin1.0

    Verstehen kann ich das nicht. Und die Argumentation ist auch dürftig. Ich denke der Weg geht in eine andere Richtung. Irgendwer hat gemerkt, dass mit mobilen Geräten Geld zu verdienen ist. Daran ist ja grundsätzlich nichts auszurichten. Machen wir ja auch. Nur; dass ich plötzlich alle vor den Kopf stosse und ein Produkt von einem Tag auf den anderen nicht mehr pflege ist, gelinde ausgedrückt, Schwachsinnig.

    Künftig werden wir alle unsere Entwicklungen nur mehr über einen App, Hub, oder wie auch immer die Dinger heissen werden, verkaufen können. Wir entwickeln aber keine 'Spass' Anwendungen. Sondern ein System das im Sicherheitsbereich eingesetzt wird. Funktionen, die für uns eminent wichtig sind, werden Schlicht und Einfach von WP7 nicht angeboten oder unterstützt. Also müssten wir, entweder noch länger auf WM6.5 bleiben, oder uns eine andere alternative überlegen.

    Auch WP7, benutzt das NET Framework. Vor allem, kann es ja nicht wirklich ein Problem sein, VS2010 zum NETCF3.5 kompatibel zu machen. Also wirklich.

    OK; Petition ist wichtig und wird unterstützt.

     

    Freitag, 19. November 2010 19:09
  • Hallo Dennis

    Einiges wird in folgendem Video der TechEd USA 2010 genannt:
    http://www.msteched.com/2010/NorthAmerica/WEM307

    ab 20:00-22:00, Gründe:
    + VS2010 was not ready yet when they started on Compact 7.
    + Plugin-model has so dramatically changed for VS2010.
    + They did not have the resources to switch.
    + Talking with customers if VS2010 support is important.

    Donnerstag, 2. Dezember 2010 23:52