none
Ältere Version von Blend SDK RRS feed

  • Frage

  • Hallo 

    Nach einer Neuinstallation meines Rechners (+VS) erhalte ich beim Öffnen eines Projektes die Fehlermeldung, dass die Version (m)einer eingebundenen DLL veraltet ist:

    Der Typ "MinWidthSplitterBehavior" aus Assembly "ar_WPF" 
    wurde mit einer älteren Version von Blend SDK erstellt und wird in einem Windows Presentation Framework 4-Projekt nicht unterstützt.	
    

    Die (meine) eingebundene DLL habe ich daraufhin noch einmal mit der gleichen VS-Version (VS 2019 Prof.), ohne Fehlermeldungen, kompiliert. Trotzdem bleibt die Fehlermeldung im Hauptprojekt bestehen.

    Bind, in der akt. Version (2019), ist auf dem PC auch installiert.

    Was kann/muss ich verändern?

    Mittwoch, 31. März 2021 10:02

Antworten

  • Hallo!

    Folgendes beseitigte bei mir den "Fehler".

        1. Expresion Blend SDK (Nuget-Package) installieren
             PM> Install-Package Expression.Blend.Sdk 

    2. Aus dem Blend-SDK die System.Windows.Interactivity.dll im GAC registrieren

    - Eingabeaufforderung als Administrator öffnen.

    - In das Tool-Verzeichnis des DotNet Framworks wechseln.
      CD C:\Program Files (x86)\Microsoft SDKs\Windows\v10.0A\bin\NETFX 4.8 Tools
      (Beispiel für installiertes 4.8 Framework)

    - Die Interactivity.dll registrieren:
      gacutil -i "C:\Program Files (x86)\Microsoft SDKs\Expression\Blend\.NETFramework\v4.5\Libraries\System.Windows.Interactivity.dll"

    Angepasste Lösung von: https://stackoverflow.com/questions/32024034/the-type-from-assembly-is-built-with-an-older-version-of-blend-sdk-and-is-not-su


    • Als Antwort markiert perlfred Mittwoch, 31. März 2021 14:19
    • Bearbeitet perlfred Mittwoch, 31. März 2021 14:22 Formatierung
    Mittwoch, 31. März 2021 14:14