none
IE11 setzt automatisch "www." vor die Domain

    Frage

  • Hallo,

    ich habe folgendes Problem: Ich möchte auf z.B. "https://test.blatt.com". Der IE (und auch jeder andere Browser) hängt aber immer ein "www." davor, sodass ich auf "https://www.test.blatt.com" lande.

    Wo kann ich das abstellen / umstellen? Es ist mir wichtig, dass es unter dem IE läuft.

    Vorab danke für die Hilfestellung!

    Tim

    Montag, 19. September 2016 09:21

Antworten

Alle Antworten

  • Hallo Tim,

    die Browser ändern maximal dann die Adresse, wenn Du nur test.blatt.com eingibst. Sobald ein Protokoll voransteht, ändert sich da nichts mehr. Ich hab das jetzt mit allen mir zur Verfügung stehenden Browsern probiert, überall das gleiche.

    Aber selbst nur bei Eingabe von test.blatt.com konnte ich es bei keinem Browser nachvollziehen, dass www. vorangestellt wird.

    Die einzige Option, die zudem browserübergreifend so agieren würde, wäre eine serverseitige Einstellung, bspw. per UrlRewrite Regeln in einem IIS (Apache hat ähnliche Funktionen), so dass bei fehlendem www. dieses immer vorangestellt wird. Das ist aber eine Sache der Webanwendung, nicht des Browsers.

    Zudem frage ich mich, wo und wie Du die Adresse überhaupt aufrufst. Da Du in einem Forum für Softwareentwickler fragst, nehme ich an, dass Du eine Anwendung entwickelst, die den IE automatisieren soll?


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community


    • Bearbeitet Stefan Falz Montag, 19. September 2016 09:29
    Montag, 19. September 2016 09:28
  • Hm nein das scheint es nicht zu sein.

    Dann liegt's wohl an meinem Client, trotzdem danke für die schnelle Antwort!

    Montag, 19. September 2016 09:35
  • Immer? Bezweifle ich. Und wenn nicht immer, ist das eine Funktion der Seite, die das gerne so hätte. Daran ist dann nichts auszusetzen.

    Wenn du das Thema weiterverfolgen willst, bitte auf http://answers.microsoft.com/de-de/ie/forum?tab=Threads&auth=1 Hier bist du als Endanwender mit Browserfragen falsch.


    IEFAQ: http://iefaq.info

    Montag, 19. September 2016 11:43
    Beantworter