none
The New Team Project Wizard Could Not retrieve the wizard page in VS 2013 RRS feed

  • Frage

  • Hallo,

    ich habe einen Team Foundation Server 2013 auf einem Server installiert, auf dem ebenfalls ein Visual Studio 2013 Update 5 läuft.

    Nachdem ich eine projektspezifische Collection angelegt habe, versuchte ich, ein neues Team Projekt zu erstellen, woran ich nun scheitere. Ich erhalte beim Process Template die Fehlermeldung: 

    TF30323: The New Team Project Wizard Could Not retrieve the wizard page from the plug-in Microsoft.ProjectCreationWizard.VersionControl.

    Ich habe hiernach bereits gesucht, aber keine Lösung gefunden. Den Cache vom TSF habe ich bereits geleert, was jedoch zu keiner Lösung führte.  Die Meldung erhalte ich auch für die anderen beiden Process Templates.

    Hat hier jemand eine Idee?

    Was mir im Nachhinein noch aufgefallen ist: Ich habe, damit es funktioniert, eines der drei vorgebenen Templates abgeändert, womit es dann funktioniert hat (von true nach false):

    <plugin name="Microsoft.ProjectCreationWizard.VersionControl" wizardPage="false" />
    und 
    <plugin name="Microsoft.ProjectCreationWizard.Portal" wizardPage="false" />
    Das Problem ist ja aber logischerweise, dass nun keine Möglichkeit besteht, Git oder TVCF auszuwählen, was für mich aber relevant ist. Als zusätzliche Information: VS ist auf dem gleichen Server installiert, wie TFS (und ist momentan auch nicht änderbar).

    Donnerstag, 14. Januar 2016 08:07

Alle Antworten

  • Hi Lorenz,
    was verstehst Du unter "projektspezifischer Collection"? TFS 2013 hat auch SP5?

    Der Einfachkeit halber würde ich mal den TFS neu konfigurieren:

    1. alte Konfiguarion abhängen

    2. alte Konfiguration löschen, wenn sich nicht mehr gebraucht wird.

    3. Neue Konfiguration anlegen, ggf. unter neuem Namen, wenn die alte Konfiguration nicht gelöscht wurde.


    --
    Viele Grüsse
    Peter Fleischer (MVP, Partner)
    Meine Homepage mit Tipps und Tricks
    Kommas richtig setzen!
    Schüler sagen, Lehrer haben es gut.
    Schüler, sagen Lehrer, haben es gut

    Donnerstag, 14. Januar 2016 10:02
  • Hallo Peter,

    danke für deinen Beitrag!

    Damit meinte ich lediglich, eine neue Collection angelegt zu haben und nicht die DefaultCollection genutzt zu haben. 

    Das TFS hat auch das SP5, aber ich hatte die Collection bereits vor dem Upgrade angelegt. Aber nach dem Upgrade lief ja auch ein Upgrade über die Datenbank, sodass es dadurch nicht zu Probleme führen sollte, oder?

    Ich habe die Konfiguration bereits neu angelegt, aber leider löste das das Problem auch nicht.

    Donnerstag, 14. Januar 2016 12:08
  • Hi Lorenz,
    wenn das so ist, wie Du das geschildert hast, dann würde ich mir die 15 Minuten Zeit nehmen und den TFS deinstallieren und erneut installieren, da vermutlich irgendein Teil der Installation zerstört ist.

    --
    Viele Grüsse
    Peter Fleischer (MVP, Partner)
    Meine Homepage mit Tipps und Tricks
    Kommas richtig setzen!
    Schüler sagen, Lehrer haben es gut.
    Schüler, sagen Lehrer, haben es gut

    Donnerstag, 14. Januar 2016 20:59