none
RDP-Client von Windows7 - englische Tastatur

    Frage

  • Hallo zusammen,
    ich habe eine Problem mit dem RDP-Client von Windows7 - der verbindet sich auf alle Server mit einem englischen Tastaturlayout. Geht schon, ist halt ein bißchen nervig bei Passwörtern mit Sonderzeichen - ist das bekannt? Gibt es da eine Lösung?
    Ich habe im Internet rumgesucht, ich habe aber nur einen Patch zum gleichen Problem von 2007 für Windows2000 Server gefunden, aber das kann es ja nicht sein ...

    Gruß, Tom
    Freitag, 31. Juli 2009 07:27

Antworten

  • Hi Zusammen,

    für alle die eine dauerhafte Lösung suchen.
    Ich habe dasselbe Prolem gehabt. Jedesmal wenn ich mit meinem Win7 Enterprise-Rechner per RDP mich auf einem Rechner anmelden wollte, erhielt ich die Anmeldebox mit der englischen Tastatur.

    Diese Lösung ist nicht von mir. Ich weiss auch nicht mehr genau wo ich das her ab. Ist halt aus dem Netz.

    Lösung:

    Auf dem Remote-Rechner in der Registry einen Schlüssel vom REG_DWORD "IgnoreRemoteKeyboardLayout=1" erzeugen.

    Das Ganze unter [HKEY_LOCAL_MACHINE][SYSTEM][CurrentControlSet][Control][Keyboard Layout]

    Abmelden...Neu anmelden...Anmeldebildschirm hat nun deutsches Tastaturlayout, bzw. das Layout das lokal auf dem Remote-Rechner eingestellt ist.

    Nachteil des Ganzen: Muss auf jedem Remote-Rechner eingestellt werden.
    Vielleicht kennt ja jemand einen Registry-Eintrag, bei dem der eigene Rechner mit deutschem Tatstatur-Layout sich zu verbinden versucht. Verursacher ist eigentlich das eigene Windows 7. Zumindestens die Enterprise-Edition von Windows 7 meldet sich mit englischer Tastatur an.

    Wie auch immer. Ich hoffe das Ganze hilft einigen Leuten.

    .... Grüsse Memet
    Mittwoch, 3. Februar 2010 10:18
  • Hallo zusammen,
    ich habe eine Problem mit dem RDP-Client von Windows7 - der verbindet sich auf alle Server mit einem englischen Tastaturlayout. Geht schon, ist halt ein bißchen nervig bei Passwörtern mit Sonderzeichen - ist das bekannt? Gibt es da eine Lösung?
    Ich habe im Internet rumgesucht, ich habe aber nur einen Patch zum gleichen Problem von 2007 für Windows2000 Server gefunden, aber das kann es ja nicht sein ...

    Gruß, Tom

    Hallo allerseits,

    ich hatte das gleiche Problem und vielleicht eine Lösung: Es gibt in der Taskleiste bei mir ein Symbol für die Tastatur. Das steht normal auf "Deutsch (Apple)" und wenn ich das nach dem Start des RDP-Client auf "Deutsch" umschalte, dann funktioniert auch die Tastaturbelegung. Ich vermute, dass die Standardeinstellung "Deutsch (Apple)" vom RDP nicht richtig interpretiert wird.
    Hoffe, damit helfen zu können.
    VG Ingo
    Mittwoch, 17. März 2010 14:14
  • Gut,
    dann liegt es vielleicht an BootCamp. Windows7 läuft bei mir auf einem MacBook mit BootCamp-Unterstützung.

    Gruß, Tom
    Freitag, 31. Juli 2009 13:17
  • Hi auch, wie ich sehe bin ich nicht der einzige mit diesem Problem. Man kann das Tastaturlayout mit der Standard Tasten-Kombination "Linke Alt + Umschalt" ändern, allerdings ist das in meine Augen keine dauerhafte Lösung, schließlich ist es ein unnötiger Schritt und so oft wie ich am Tag RDP Verbindungen aufbauen muss eine Qual. Also falls noch jemand eine andere Lösung kennt, wäre ich sehr dankbar... Gruß
    Mittwoch, 20. Januar 2010 11:05

Alle Antworten

  • Wenn Du ich den Anmeldebildschirm in meinem RemoteDesktop Client vor mir habe, dann kann ich links unten sehen welches Tastatur-Layout (DE/EN) gewählt ist und umschalten. Das kann ich bei Server 2008, Vista und müsste bei Windows 7 auch gehen.

    Ansonsten fragt mich doch RemoteDesktop sofort nach dem Kennwort wenn ich mich anmelde, insofern verstehe ich Dein Problem nicht ganz.
    Martin Richter -- MVP for VC++ [Germany] -- http://blog.m-ri.de
    Freitag, 31. Juli 2009 09:41
  • Servus Martin,
    ja, ich sehe blau eingerahmt, dass ich die EN für englische Tastatur benutze, wenn ich mich mit dem RDP auf einen Server verbinde. Aber ich kann dort nichts auswählen und auch nicht umschalten auf DE, kein Dropdown-Menü oder ähnliches. Es sind Windows2003 R2 Server.
    Und nervig meine ich deswegen, weil wir Sonderzeichen in den Paßwörtern haben, z.B. das "@"-Zeichen oder "_" und die liegen auf der englischen Tastatur eben ganz woanders.

    Problem ist eben - aus meiner Sicht - dass der RDP von Windows7 RC standardmäßig vermeldet, er wäre englischen Ursprungs, obwohl ich hier die deutsche RC installiert habe. Ich habe deutsche Server, also hätte ich gern auch per RDP eine deutsche Tastatur.

    Oder liegt das jetzt nur an meiner Windows7 Installation?

    Gruß, Tom
    Freitag, 31. Juli 2009 11:02
  • Kann ich nicht bestätigen. Mein Anmeldedialog meines Servers (auch 2003) zeigt bei mir DE an wenn ich mit Remote Desktop aus meinem Win7-RC darauf zugreife.
    Martin Richter -- MVP for VC++ [Germany] -- http://blog.m-ri.de
    Freitag, 31. Juli 2009 12:31
  • Gut,
    dann liegt es vielleicht an BootCamp. Windows7 läuft bei mir auf einem MacBook mit BootCamp-Unterstützung.

    Gruß, Tom
    Freitag, 31. Juli 2009 13:17
  • hallo tom,

    hab das gleiche "feature" - bist du damit weitergekommen ?

    thx für infos

    gruß adrian
    Freitag, 2. Oktober 2009 18:36
  • Hi auch, wie ich sehe bin ich nicht der einzige mit diesem Problem. Man kann das Tastaturlayout mit der Standard Tasten-Kombination "Linke Alt + Umschalt" ändern, allerdings ist das in meine Augen keine dauerhafte Lösung, schließlich ist es ein unnötiger Schritt und so oft wie ich am Tag RDP Verbindungen aufbauen muss eine Qual. Also falls noch jemand eine andere Lösung kennt, wäre ich sehr dankbar... Gruß
    Mittwoch, 20. Januar 2010 11:05
  • Hi Zusammen,

    für alle die eine dauerhafte Lösung suchen.
    Ich habe dasselbe Prolem gehabt. Jedesmal wenn ich mit meinem Win7 Enterprise-Rechner per RDP mich auf einem Rechner anmelden wollte, erhielt ich die Anmeldebox mit der englischen Tastatur.

    Diese Lösung ist nicht von mir. Ich weiss auch nicht mehr genau wo ich das her ab. Ist halt aus dem Netz.

    Lösung:

    Auf dem Remote-Rechner in der Registry einen Schlüssel vom REG_DWORD "IgnoreRemoteKeyboardLayout=1" erzeugen.

    Das Ganze unter [HKEY_LOCAL_MACHINE][SYSTEM][CurrentControlSet][Control][Keyboard Layout]

    Abmelden...Neu anmelden...Anmeldebildschirm hat nun deutsches Tastaturlayout, bzw. das Layout das lokal auf dem Remote-Rechner eingestellt ist.

    Nachteil des Ganzen: Muss auf jedem Remote-Rechner eingestellt werden.
    Vielleicht kennt ja jemand einen Registry-Eintrag, bei dem der eigene Rechner mit deutschem Tatstatur-Layout sich zu verbinden versucht. Verursacher ist eigentlich das eigene Windows 7. Zumindestens die Enterprise-Edition von Windows 7 meldet sich mit englischer Tastatur an.

    Wie auch immer. Ich hoffe das Ganze hilft einigen Leuten.

    .... Grüsse Memet
    Mittwoch, 3. Februar 2010 10:18
  • Hallo zusammen,
    ich habe eine Problem mit dem RDP-Client von Windows7 - der verbindet sich auf alle Server mit einem englischen Tastaturlayout. Geht schon, ist halt ein bißchen nervig bei Passwörtern mit Sonderzeichen - ist das bekannt? Gibt es da eine Lösung?
    Ich habe im Internet rumgesucht, ich habe aber nur einen Patch zum gleichen Problem von 2007 für Windows2000 Server gefunden, aber das kann es ja nicht sein ...

    Gruß, Tom

    Hallo allerseits,

    ich hatte das gleiche Problem und vielleicht eine Lösung: Es gibt in der Taskleiste bei mir ein Symbol für die Tastatur. Das steht normal auf "Deutsch (Apple)" und wenn ich das nach dem Start des RDP-Client auf "Deutsch" umschalte, dann funktioniert auch die Tastaturbelegung. Ich vermute, dass die Standardeinstellung "Deutsch (Apple)" vom RDP nicht richtig interpretiert wird.
    Hoffe, damit helfen zu können.
    VG Ingo
    Mittwoch, 17. März 2010 14:14
  • Hi,

     

    Ja genau das ist es, einfach Deutsch Deutschland in der Systemsteuerung Region und Sprache dazu geben und als Standard nehmen, ich habe zusätzlich noch Deutsch Apple gelöscht, weiss aber nicht ob ich das für was andere brauche, auf jeden Fall sind meine RDP Sessions jetzt immer deutsch.

     

    DANKE!!

     

    Werner

    Dienstag, 25. Mai 2010 19:14
  • Hallo, Memet,

    mehr als ein Jahr nach Deinem Beitrag folgt hier mein ganz herzlicher Dank an Dich!

    Ich habe mich jetzt mehrere Wochen mit dem Problem herumgeschlagen, ohne eine Lösung zu finden, aber jetzt, endlich, habe ich sie!

    Noch mal ganz herzlichen Dank :)

    Viele Grüße,

    Hartmut

    Sonntag, 10. April 2011 12:25
  • Hallo zusammen,
    ich habe eine Problem mit dem RDP-Client von Windows7 - der verbindet sich auf alle Server mit einem englischen Tastaturlayout. Geht schon, ist halt ein bißchen nervig bei Passwörtern mit Sonderzeichen - ist das bekannt? Gibt es da eine Lösung?
    Ich habe im Internet rumgesucht, ich habe aber nur einen Patch zum gleichen Problem von 2007 für Windows2000 Server gefunden, aber das kann es ja nicht sein ...

    Gruß, Tom


    Hallo allerseits,

    ich hatte das gleiche Problem und vielleicht eine Lösung: Es gibt in der Taskleiste bei mir ein Symbol für die Tastatur. Das steht normal auf "Deutsch (Apple)" und wenn ich das nach dem Start des RDP-Client auf "Deutsch" umschalte, dann funktioniert auch die Tastaturbelegung. Ich vermute, dass die Standardeinstellung "Deutsch (Apple)" vom RDP nicht richtig interpretiert wird.
    Hoffe, damit helfen zu können.
    VG Ingo

    Bei mir hat es geholfen. danke :)
    Freitag, 10. Januar 2014 08:32
  • Hallo,

    hat auch auf 2003 Server so geklappt!

    Alle Terminalverbindungen laufen nun mit Host Tastatursprache
    Auch hier sind alle Terminals mit einem Boot-Camp Apple / Win Rechner im Einsatz.

    Danke für die Lösung, das Problem war nervig.

    Mittwoch, 19. August 2015 08:41