none
Androidエミュレータが動作しません RRS feed

  • 質問

  • Visual Studio Community 2019Androidのアプリを作成しようとしているのですが、次のエミュレータは動作するのですが、これ以外のエミュレータは起動ができません。

    動作するエミュレータ

    名前      Galaxy Nexus

    基本デバイス  Galaxy Nexus

    プロセッサ       armeabi-v7a

    OS                  Kit Kat 4.4 - API 19

    Google APIs      (チェックを入れる)

    これ以外のエミュレータを作成しても、x86のものは一瞬黒いスマホの画像が表示されてすぐに画像が消えてしまいます。

    またarmのものは、スマホの画像にAndroidの文字が白く表示されるまでで、いくら待っても次に進みません。

    できれば私のスマホの画面(1920×1080ピクセル)と同じピクセル数のエミュレータでデバッグしたいのですが、うまくいきません。

    当方はモバイルアプリ開発については、全くの初心者です。

    当方の環境

    Visual Studio Community 2019 Version 16.2.3

    Windows 10 Pro. バージョン1903

    CPU     インテルCore2 Quad Q9550sHyper-Vなし、Intel VT-xあり)

    メモリ  GB

    以上、よろしくお願いします。


    • 編集済み fghck856 2019年8月22日 17:24 誤記修正
    2019年8月22日 17:21

すべての返信

  • fghck856さん、こんにちは。フォーラムオペレーターのHarukaです。
    MSDNフォーラムにご投稿くださいましてありがとうございます。

    問題を再現することができませんでした。
    ハードウェアアクセラレーションを開始してみてください。
    https://docs.microsoft.com/ja-jp/xamarin/android/get-started/installation/android-emulator/hardware-acceleration?tabs=vswin&pivots=windows#accelerating-with-haxmをご参照いただければと思います。

    どうぞよろしくお願いします。


    MSDN/ TechNet Community Support Haruka

    ~参考になった投稿には「回答としてマーク」をご設定ください。なかった場合は「回答としてマークされていない」も設定できます。同じ問題で後から参照した方が、情報を見つけやすくなりますので、
    ご協力くださいますようお願いいたします。また、MSDNサポートに賛辞や苦情がある場合は、MSDNFSF@microsoft.comまでお気軽にお問い合わせください。~

    2019年8月29日 8:33
    モデレータ
  • ご回答ありがとうございます。ご指摘のサイトで指示されたように入力したところ、intelhaxm の状態は RUNNING と表示されました。ハードウェアアクセラレーション(HAXM)は既に実行されていることになると思います。

    2019年8月29日 17:46