none
Azure AutoML uses only 1 core RRS feed

  • Question

  • Hi,

    I'm testing Azure AutoML in local mode, and only 1 core is used on my workstation (same on my server).

    no matter the max concurrent settings I put in place.

    so there is no parallel operation executed, no multi-threading.

    at least I'm faster than Azure nodes at fraction of the cost, but still surprised how badly optimized this API is compared to some R tools.(So I presume that an Azure VM is also under used... is it setup to cost us a lot by paying for big under used VM?)

    is there any special stuff to know I should setup on my PC? 

    Tuesday, November 5, 2019 1:42 PM

All replies

  • Hello Willgart1,

    You can use the setting max_cores_per_iteration to control the number of cores that would be available for AutoML to use. You can set it to -1 to use maximum available. You can find the setting in documentation here.

    Also, training multiple iterations or models in parallel is supported only in remote runs (I.e using AML compute etc)

    -Rohit

    Thursday, November 7, 2019 10:37 AM
    Moderator
  • Hi,

    Sorry, but it doesnt works.

    the max cores option did not change anything.

    maybe there is a missing library?

    I'll conduct additional tests today.

    Thursday, November 7, 2019 12:07 PM