locked
Cannot Install Microsoft .NET Framework 4 Beta 2 on Windows 7 RRS feed

  • Question

  • I've read through many posts in here and have tried many things including running .NET Cleanup Tool to no avail to resolve this problem.

    Here's some information for you to help me get to the bottom of this problem:

    1. Version of .NET Framework I am trying to install.

    Microsoft .NET Framework 4 Beta 2

    2. Where did I get it?

    http://www.microsoft.com/downloads/details.aspx?FamilyID=ded875c8-fe5e-4cc9-b973-2171b61fe982&displaylang=en

    3. Is this a pre-release, CTP or beta version? Which? (Beta#, CTP (Month Year), RC, etc)

    Beta 2

    4. What .NET Framework Patches do you currently have installed? 

    .NET Framework 3.5.1


    Here is the pertinent section of the log file with the error I receive from the installer:

    [3/10/2010, 13:32:40] Action: Performing Action on MSI at C:\34e531a4bbe0acd47ffe098391\netfx_Extended_x86.msi...
    [3/10/2010, 13:32:40]Log File C:\Users\Bartleby\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_20100310_133213233-MSI_netfx_Extended_x86.msi.txt exists and will be added to the Watson upload list
    [3/10/2010, 13:32:40]Calling MsiInstallProduct(C:\34e531a4bbe0acd47ffe098391\netfx_Extended_x86.msi, EXTUI=1
    [3/10/2010, 13:32:48] Returning IDOK. INSTALLMESSAGE_ERROR [A network error occurred while attempting to read from the file: C:\Windows\Installer\netfx_Extended_x86.msi]
    [3/10/2010, 13:32:50]MSI (C:\34e531a4bbe0acd47ffe098391\netfx_Extended_x86.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20100310_133213233-MSI_netfx_Extended_x86.msi.txt
    [3/10/2010, 13:32:50]PerformOperation returned 1603 (translates to HRESULT = 0x80070643)
    [3/10/2010, 13:32:50] Action complete
    [3/10/2010, 13:32:50]Error 1603:1316 is mapped to Custom Error: Retry
    [3/10/2010, 13:32:50]Retry 1 of 1 of custom error handling
    [3/10/2010, 13:32:50]Retry count over existing limit, not going to retry again.
    [3/10/2010, 13:32:50]OnFailureBehavior for this item is to Rollback.
    [3/10/2010, 13:32:50] Action: Performing actions on all Items...
    [3/10/2010, 13:32:50] Action complete
    [3/10/2010, 13:32:50] Action complete
    [3/10/2010, 13:32:50]Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:00:37).

    I've run msiinv.exe and it reports that .NET Framework 4 Extended Beta 2 is already installed:

    Microsoft .NET Framework 4 Extended Beta 2
    Product code: {6E405B40-3879-3C9B-9286-8D5E71258C35}
    Product state: (5) Installed.
    Package code: {494A30ED-AA3D-4691-89E9-D0827BB00629}
    Version: 4.0.21006
    AssignmentType: 1
    Publisher: Microsoft Corporation
    Language: 0
    Installed from: C:\769f9b8a2ad690b899ff4947a441b3\
       Package: netfx_Extended_x86.msi
    About link: http://go.microsoft.com/fwlink/?LinkId=149521
    Update link: http://go.microsoft.com/fwlink/?LinkId=149522
    Local package: C:\Windows\Installer\3420aed.msi
    Install date: 2009\12\13
    0 patch packages.

    I tried to remove the .NET Framework 4 Extended Beta 2 that msiinv reports as installed using msiexec /x {6E405B40-3879-3C9B-9286-8D5E71258C35}, but msiexec reported, "A network error occurred while attempting to read from the file:  C:\Windows\Installer\netfx_Extended_x86.msi"  When I do a Dir of the file, it is not found.

    This missing C:\Windows\Installer\netfx_Extended_x86.msi file is really causing problems.

    Any help anyone can provide to resolve this issue would be greatly appreciated.  Let me know if you require additional information from me.  Thanks.
    • Moved by YiChun Chen Thursday, March 11, 2010 10:47 AM .NET 4.0 issue (From:.NET Framework Setup)
    Wednesday, March 10, 2010 6:58 PM

Answers

  • Thanks for the suggestion Merrie.  I have already tried uninstalling from Add/Remove, but it clearly didn't fully remove everything.  I finally bit the bullet and used regedt32 to manually remove each and every key with .net framework 4 in it and that resolved the problem.  Thanks again for your help.
    Friday, March 12, 2010 5:49 AM

All replies

  • Hi BartlebyTheScrivener,

    I am moving this thread from Base ".Net Framework Setup" forum to the ".NET Framework 4 setup & deployment (Pre-Release versions)" forum, since the issue is related to .NET 4.0. There are more experts in the ".NET Framework 4 setup & deployment (Pre-Release versions)" forum.

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, March 11, 2010 10:47 AM
  • Hi,

    I'm sorry that you are having troubles installing the .NET Framework 4.  I will need to take a look at the complete install logs to narrow down the issue.  Could you collect your .Netfx4 setup logs following the instructions at http://blogs.msdn.com/heaths/pages/collect.aspx and post them somewhere we can access? (you can use skydrive.live.com to post the logs).  I'd be happy to take a look to see what has happened.

    Thanks,

    ~Merrie - MSFT
    --------------
    VS/ .NET Deployment Team
    Thursday, March 11, 2010 6:34 PM
  • Hi Merrie,

    Thanks for offering to help.  Here's the output of collect.exe:  http://cid-217c29a8f5b1ebbe.skydrive.live.com/self.aspx/.Documents/vslogs.cab

    I'm looking forward to resolving this issue.  Let me know if you require additional information from me.

    Thanks again.
    Thursday, March 11, 2010 9:11 PM
  • Hi,

    Your logs seem to indicate that while you are trying to install FX Beta2 you already have the Client portion of RC on your system.  My recommendation is to start by trying to remove both Client and Extended portions of the Framework manually from Add/Remove programs.  You will need to start with Extended and then uninstall Client second.  Once you've done that, try installing VS again and let me know if that fixes the problem.

    Thanks,
    ~Merrie - MSFT
    -----------------------------------
    VS/.NET Deployment Team
    Friday, March 12, 2010 12:58 AM
  • Thanks for the suggestion Merrie.  I have already tried uninstalling from Add/Remove, but it clearly didn't fully remove everything.  I finally bit the bullet and used regedt32 to manually remove each and every key with .net framework 4 in it and that resolved the problem.  Thanks again for your help.
    Friday, March 12, 2010 5:49 AM