locked
Using Excel interop v11 and V15 in the same project RRS feed

  • Question

  • Hello

    I am trying to develop a test program which will start Excel 11 or Excel 15 depending on which test button will be clicked.  So I have project structure like this:

    Test.exe
    ProxyOffice2003 (reference To Excel.interop v11)
    ProxyOffice2013 (reference to Excel.Interop v15)

    Button1 will create ProxyOffice2003 and Button1 will create the 2013 assembly. When I build Test.exe VS gives warning MSB3243 "cannot resolve conflict...V11...V15...arbitrary choosing V15...". Which makes sense, since both Excel.Interop have the same name and key.

    Is the only solution is to get rid of ProxyOffice2013, use only ProxyOffice2003 and let the Policy for V11 in the GAC redirect to V15, as it seems to do on my Window 7 test computer ?

    Thanks

    Tuesday, December 18, 2012 7:56 PM

Answers