locked
How to delete models from Azure Analysis Service RRS feed

  • Question

  • Hello experts,

    I wanted to know how I can delete models from Azure Analysis Service in Azure Portal. I've created some models and now I want to delete two of them.

    Thanks

    Friday, March 8, 2019 9:05 AM

Answers

  • Hi Shayan,

    Note: You can only delete an existing Analysis Services database in SQL Server Management Studio.

    Deleting an existing Analysis Services database deletes the database and all cubes, dimensions, and mining models in the database.

    To delete an Analysis Services database

    1. Connect to an Analysis Services instance.
    2. In Object Explorer, expand the node for the connected Analysis Services instance and ensure that the object to be deleted is visible.
    3. Right-click the object to be deleted and select Delete.
    4. In the Delete Object dialog box, click OK.

    For more details, refer “Modify or Delete an Analysis Services Database”.

    Hope this helps.

    Friday, March 8, 2019 9:20 AM

All replies

  • Hi Shayan,

    Note: You can only delete an existing Analysis Services database in SQL Server Management Studio.

    Deleting an existing Analysis Services database deletes the database and all cubes, dimensions, and mining models in the database.

    To delete an Analysis Services database

    1. Connect to an Analysis Services instance.
    2. In Object Explorer, expand the node for the connected Analysis Services instance and ensure that the object to be deleted is visible.
    3. Right-click the object to be deleted and select Delete.
    4. In the Delete Object dialog box, click OK.

    For more details, refer “Modify or Delete an Analysis Services Database”.

    Hope this helps.

    Friday, March 8, 2019 9:20 AM
  • Hi Shayan,

    Just checking in to see if the above answer helped. If this answers your query, do click “Mark as Answer” and Up-Vote for the same. And, if you have any further query do let us know.

    Tuesday, March 12, 2019 6:30 AM
  • We are running into a major issue with Analysis Services and Azure.

    We have a database that was set to READONLY via an auto-scaling script we implemented. An update script was run to set the database back to READ/WRITE, but when trying to deploy a model, it failed complaining that the context was read only, even though the properties showed it was set to read write.

    We decided to delete the database and do a fresh deploy. The database apparently deleted successfully, but when looking in SSMS, the database still appears, even though in Azure portal there are no databases present.

    What's even more disturbing is that all the objects appear under the database (tables, connections, roles), but when you right click an object to view the properties, it errors saying the database doesn't exist!

    Are there some major issues with deleting databases in Azure??

    And I thought read only was just a database level setting? I should be able to deploy a fresh database no problem. And yes, I am an administrator, so I have complete and total permissions on the server instance.

    Very very confused...!


    A. M. Robinson

    Friday, February 28, 2020 4:44 PM
  • Hi - I had the same issue the other day. Do you have query replicas? if so, I found sometimes the database would persist in the replica server and not synchronise correctly to the primary server. Scaling down to 0 waiting a few moments, and scaling up seemed to fix the issue
    • Edited by Harry Ault Thursday, April 9, 2020 4:03 PM
    Thursday, April 9, 2020 4:01 PM
  • Hi Harry,

    Thanks for sharing the solution which worked for you, which might be beneficial to other community members reading this thread. 

    Monday, April 13, 2020 3:48 AM