none
Timescale extension - max_locks_per_transaction parameters not accessible RRS feed

  • Question

  • I am using TimeScale extension with Azure Database for PostgreSQL.

    I have an error while executing queries "out of shared memory Hint: You might need to increase max_locks_per_transaction".

    The max_locks_per_transaction is not available in server parameters and I cannot setup the server as requested by timescale for lock settings :  https://docs.timescale.com/v1.3/getting-started/configuring#locks

    By the way, TimeScale extension is not really usable with Azure Database for PostgreSQL.

    Any idea or suggestion to set this parameter and to get a TimeScale server up&running properly ? 

    Thanks a lot for your support

    Sunday, May 26, 2019 1:43 AM

All replies