locked
Not able to install ServiceFabric in Ubuntu RRS feed

  • Question

  • Getting below error after doing sudo apt-get install servicefabricsdkcommon

    root@Linux-Service-Fabric:~# sudo apt-get install servicefabricsdkcommon
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     servicefabricsdkcommon : Depends: servicefabric (>= 6.4.625.1) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    Thursday, October 3, 2019 9:02 AM

All replies

  • Hi,

    Whats the version of Ubuntu which you are using?

    Ubuntu 16.04 is supported and 18.04 is not supported yet. Service fabric package is not yet packaged for Ubuntu18.04.

    Please try out with Ubuntu 16.04 and let me know if you face issues.

    Please refer to the similar github issue here

    Thursday, October 3, 2019 12:17 PM
    Owner
  • Hello,

    Any update on the issue?

    If the suggested answer helped you solve your query, do click on "Mark as Answer" and "Up-Vote" on the answer that helped you for the benefit of other community members.

    Thanks.
    Monday, October 7, 2019 11:53 AM
  • Hi Subbu,

    Did the above reply helped you to solve your problem?

    For the benefit of the community, Please click on "mark as answer" for the reply which helped you to solve your problem.


    Thursday, October 17, 2019 12:43 PM
    Owner