No Log Data, but there is Live Metrics Data RRS feed

  • Question

  • No log data showing up in AI from my prod server.  Live Metric data does appear.  I'm using the asp.net nuget packages in Visual Studio.  The ApplicationInsights.config, Web.config, and AI dlls are all the same on both servers.  The firewall is allowing all port 443 traffic on both servers.  I'm out of ideas.  Can you help?

    Wednesday, April 22, 2020 4:35 PM

All replies

  • Hi, Steve!

    First, I want to make sure I point out our documentation on setting up separate telemetry for your development, test, and production environments:



    When you say that you aren't seeing log data, are you talking about Monitoring > Logs in the Portal?  If that's the case, I have a couple clarifying questions for you:  Have you gotten logs in the past or is this a new deployment with Application Insights?  How long has it been since you deployed to production?  What are you seeing on very broad queries, like a simple "requests"?

    Monday, April 27, 2020 10:50 PM
  • This is a new deployment.  I can see the Live Metric data but the Monitoring > Logs are totally empty.  I have tried to use different instrumentation keys for the different environments and the results are always similar.  I can see 100% of the date in Azure that is generated from my laptop and development server, but only the Live Metric data on the production server.  
    Tuesday, April 28, 2020 12:24 PM
  • As it turns out, Live Metrics and Logs use different ingestion endpoints.  In addition to port 443, you'll need to whitelist the IPs listed in our documentation here (note that some are region specific):


    Tuesday, April 28, 2020 8:34 PM
  • Thanks for the information.  I'm going to have my firewall team add the outgoing whitelist IPs rules to the firewall. I'll post anther reply once I can get the rules in place and test the traffic again. 
    Wednesday, April 29, 2020 12:55 AM
  • My firewall team confirmed that all outgoing traffic on port 443 is allowed.  I opened a ticket with Microsoft to see if one of their support staff can find a resolution since the firewall logs show the traffic going to the correct IP addresses.  
    Thursday, April 30, 2020 12:04 PM
  • I have resolved this today by re-deploying the application instance.

    I have tried setting the instrumentation key in different ways, changed SDK versions, made changes in the ARM template properties, but I never got it working. After redeploying, it was fixed. 

    Friday, May 15, 2020 4:39 PM
  • Are you using the nuget package?  Also did you customize any of the code?  I haven't changed any code at all except for adding the instrumentation key.  I just installed from nuget and then manually copied all dlls and configs to the server. 
    Friday, May 15, 2020 5:51 PM
  • I rolled all my changes back, in the end nothing changed, I only redeployed. The SDK version is now updated to the latest, but that didn't make a difference earlier.
    Friday, May 15, 2020 6:43 PM