none
Web Service Excel Add In Error RRS feed

  • Question

  • I have chosen the 2013 or Later Excel option under request/response and added sample data. I ran the prediction on the sample data and received results, but when I attempt to add data from my spreadsheet I receive the following error:

    Error! {"error":{"code":"BadArgument","message":"Invalid argument provided.","details":[{"code":"InputParseError","target":"input1","message":"Parsing of input vector failed. Verify the input vector has the correct number of columns and data types. Additional details: Input string was not in a correct format.."}]}}

    Can someone help me with diagnosing the error?


    I've tried this with several web services and I am getting the same error, so I think I'm not performing some task correctly or I'm missing a step??
    • Edited by Kelly5094 Monday, August 13, 2018 10:56 PM
    Saturday, August 11, 2018 2:00 PM

All replies

  • Hi,

    We have a document about Excel add-in in Machine Learning service, can you please check it?

    https://docs.microsoft.com/en-us/azure/machine-learning/studio/excel-add-in-for-web-services

    Please tell me if you have further challenge.

    Regards,

    Yutong

    Thursday, August 16, 2018 10:54 PM
    Moderator
  • @Kelly5094 Did you find a resolution to this issue?  I am getting a similar error.


    • Edited by Lucas-Finco Monday, September 9, 2019 1:25 PM spelling
    Monday, September 9, 2019 1:24 PM
  • Hello Kelly,

    Could you try to use the sample data and then compare with the cell range that you have selected? The screen should look something like this.

    -Rohit

    Tuesday, September 10, 2019 5:11 AM
    Moderator