none
Azure Data Factory Linked Service connection error RRS feed

  • Question

  • I signed in login.eloqua.com and got the redirect url and paste it in the end point. and sitename\username but for some reason. Sitename is the company name right? I kept getting 400 Bad request. Please help. Why can't I connect it? is there some permission I need to do on Eloqua and Azure? Thanks!
    Wednesday, July 10, 2019 5:35 PM

All replies

  • Hi there,

    To determine your endpoint, login to https://login.eloqua.com with your credentials, then copy the base URL portion from the redirected URL with the pattern of xxx.xxx.eloqua.com..

    Yes, siteName is the company name you use to log in to Eloqua. You also have to use your username in the format 

    <site name>\\<user name>

    e.g. Eloqua\\Alice

    To determine your base URL:

    1. Send an authenticated request (in this example we use basic authentication, but OAuth2 is generally recommended as a more secure option):
       
       GET https://login.eloqua.com/id 
       Authorization: Basic XXXXX... 

      For more details, see basic authentication.

    2. If you receive a success response, the response body will look like:
       
       HTTP/1.1 200 OK
      Content-Type: application/json; charset=utf-8
      Content-Length: 824

      {
      "site": {
      "id": 42,
      "name": "MyTestInstall"
      },
      "user": {
      "id": 314,
      "username": "jane.smith",
      "displayName": "Jane Smith",
      "firstName": "Jane",
      "lastName": "Smith",
      "emailAddress": "jane.smith@eloqua.com"
      },
      "urls": {
      "base": "https://www05.secure.eloqua.com",
      "apis": {
      "soap": {
      "standard": "https://www05.secure.eloqua.com/API/{version}/Service.svc",
      "dataTransfer":"https://www05.secure.eloqua.com/API/{version}/DataTransferService.svc",
      "email": "https://www05.secure.eloqua.com/API/{version}/EmailService.svc",
      "externalAction": "https://www05.secure.eloqua.com/API/{version}/ExternalActionService.svc"
      },
      "rest": {
      "standard": "https://www05.secure.eloqua.com/API/REST/{version}/",
      "bulk": "https://www05.secure.eloqua.com/API/Bulk/{version}/"
      }
      }
      }
      }

    Can you please try again after making sure you have all the right values in the Linked Service?

    Ref - 

    https://docs.oracle.com/cloud/latest/marketingcs_gs/OMCAB/Developers/GettingStarted/Tutorials/determining-base-URLs.htm

    https://docs.microsoft.com/en-us/azure/data-factory/connector-oracle-eloqua#linked-service-properties

     https://docs.oracle.com/cloud/latest/marketingcs_gs/OMCAB/pdf/OracleEloqua_DeveloperGuide.pdf

    Hope this helps. 

    Thursday, July 11, 2019 10:58 AM
    Owner
  • Thank you for replying but it's still failing for me :( Not sure what's going on. I put the right base url, sitename and username. plus password. It takes forever to connect then say 404. Resource not found? Sometimes it pop this up too. "ERROR [IM004] [Microsoft][ODBC Driver Manager] Driver's SQLAllocHandle on SQL_HANDLE_ENV failed"
    • Edited by Khmercoder Thursday, July 11, 2019 5:19 PM
    Thursday, July 11, 2019 5:17 PM
  • Hi there,

    The error you mentioned can occur if you have an invalid or incorrect PATH variable. To check your PATH variable:

    1. Right-click My Computer
    2. Choose PROPERTIES | ADVANCED | ENVIRONMENT VARIABLES
    3. Locate the PATH variable and copy it"s contents to a text editor such as notepad

    Once you have done this you should now look for the following:

    1. A missing semicolon between the different application paths. Each application path in the list should be separated by a semicolon.
    2. Look for spaces between the semicolon and the next application path. Remove any spaces.
    3. If you have more than one Oracle installation, make sure the latest version appears in the PATH before any older versions. If you have uninstalled older versions and references still exist in the PATH then remove them.

    If the PATH appears fine then the issue may be rights related.

    1. Opened up Windows Explorer
    2. Navigated to Oracle | ora92
    3. Right clicked and selected properties
    4. Clicked on Securities tab
    5. Clicked on Authenticated Users
    6. Unchecked Read and Execute | Click Apply
    7. Rechecked Read and Execute | Click Apply
    8. Clicked ok to close window
    9. Restart server

    Hope this helps.

    Tuesday, July 16, 2019 6:49 AM
    Owner
  • Thank you for the reply again. Can you please tell me which Oracle software that I need to install for Eloqua? Because I didn't install any Oracle. Thanks!
    Tuesday, July 16, 2019 5:31 PM
  • Hi there,

    The Oracle I mentioned corresponds to the Oracle drivers that are used to connect. Ideally Azure Data Factory should take care of all drivers.

    For a deeper investigation and immediate assistance on this issue, if you have a support plan you may file a support ticket, else could you please send an email to AzCommunity@Microsoft.com with the below details, so that we can create a one-time-free support ticket for you to work closely on this matter. 

    Thread URL: https://social.msdn.microsoft.com/Forums/en-US/e6853919-b5c2-4c16-a3f3-26e8bd557cab/azure-data-factory-linked-service-connection-error?forum=AzureDataFactory
    Subscription ID:  <your subscription id>

    Please let me know once you have done the same.

    Wednesday, July 17, 2019 8:22 AM
    Owner
  • Hi there,

    Did you get a chance to raise a support ticket?

    Thursday, July 25, 2019 5:06 AM
    Owner
  • Hi there,

    Just wanted to check - was your issue resolved?

    Tuesday, July 30, 2019 10:14 AM
    Owner