locked
send Email from Acrobat Standard 9.0 32 Bit with Office 2010 64 Bit RRS feed

  • Question

  • Hello,

    aftern installing Office 2010 RTM 64 bit we get from different 16 Bit Applications like acrobat standard

    this message

    ---------------------------
    Microsoft Office Outlook
    ---------------------------
    Either there is no default mail client or the current mail client cannot fulfill the messaging request.  Please run Microsoft Outlook and set it as the default mail client.
    ---------------------------
    OK  
    ---------------------------

    Outlook is set as default which is also reflected in the corresponding registry keys like HKLM\Software\Clients\Mail and

    HKLM\Software\Wow6432Node\Clients\Mail.

    But both DLLPath entries are pointing to mapi32.dll

    It doesn't help to change the entry to olmapi32.dll which comes with Office 2010.

    Who can provide help?

     

    Regards

    RB

    Saturday, May 15, 2010 10:28 AM

Answers

  • Hello,

    meanwhile I solved the problem.

    The registry keys to the mapi dll has to be redirected to the old 32 bit version.

    I guess the fix will work for all 32 Bit applications which internally uses the MAPISendMail call.
    This 32 Bit call is translated with FixMapi.exe into 64 Bit adress space of outlook 2010 and

    Before changing any registry values, save your registry part with the export mechanism.

    I case of an error you can easily restore your original values by double clicking on the exported reg file.

    To fix the problems for office 2010 add to this registry values

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge]
    @="Outlook64Bridge"
    "DLLPathEx"="c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL"
    "DLLPath"="c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL"

    The path to the mapi32.dll might differ on your machine, so search the dll first to get the correct dll.
    Important is to get the x86 Version, which is the old 32 bit library.

    After applying this and setting the Outlook64Bridge as the default mail client in control console,
    I was able to send mails from 32 bit Acrobat with 64 bit outlook.

    Of course everything without guarantee etc.
    You know, each machine is different.

    Have fun!
    Michael

     

     

     

    • Marked as answer by _Red_Baron_ Sunday, May 16, 2010 5:49 PM
    Sunday, May 16, 2010 2:55 PM

All replies

  • Hello,

    meanwhile I solved the problem.

    The registry keys to the mapi dll has to be redirected to the old 32 bit version.

    I guess the fix will work for all 32 Bit applications which internally uses the MAPISendMail call.
    This 32 Bit call is translated with FixMapi.exe into 64 Bit adress space of outlook 2010 and

    Before changing any registry values, save your registry part with the export mechanism.

    I case of an error you can easily restore your original values by double clicking on the exported reg file.

    To fix the problems for office 2010 add to this registry values

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge]
    @="Outlook64Bridge"
    "DLLPathEx"="c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL"
    "DLLPath"="c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL"

    The path to the mapi32.dll might differ on your machine, so search the dll first to get the correct dll.
    Important is to get the x86 Version, which is the old 32 bit library.

    After applying this and setting the Outlook64Bridge as the default mail client in control console,
    I was able to send mails from 32 bit Acrobat with 64 bit outlook.

    Of course everything without guarantee etc.
    You know, each machine is different.

    Have fun!
    Michael

     

     

     

    • Marked as answer by _Red_Baron_ Sunday, May 16, 2010 5:49 PM
    Sunday, May 16, 2010 2:55 PM
  • Thanks for the instructions, but how can choose default mail client as Outlook64Bridge in control console?

    In Windows 7, Control Panel\Programs\Default Programs\Set Associations, does not allow to choose Outlook64Bridge.

    Samuli

     

     

     

     

    • Proposed as answer by Martin Br Tuesday, November 16, 2010 3:50 PM
    Wednesday, August 25, 2010 4:22 PM
  • You must do this:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge]
    @="Outlook64Bridge"
    "DLLPathEx"="c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL"
    "DLLPath"="c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL"

    and to set the Default Programs Association

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]
    @="Outlook64Bridge"

    Martin Brugger

    • Proposed as answer by Martin Br Wednesday, June 29, 2011 4:19 PM
    Tuesday, November 16, 2010 3:57 PM
  • I've also put:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]
    (Default)=Outlook64Bridge

     

    and now works great! This saves so much my time. I love you man!

    Wednesday, December 29, 2010 8:29 AM
  • Works perfectly with Acrobat X and W7/Outlook 2010 x64

    Thanks!

    Thursday, January 6, 2011 9:04 PM
  • What a life saver...  Worked like a charm with Acrobat X Pro and Win 7/Office 64-Bit!  Thank you so much!
    Thursday, January 13, 2011 8:02 PM
  • Did everything as stated above, and no joy :-(

    Windows 7 64 Bit, MS Office 2010 64 Bit, Acrobat Pro 9.4.1.

    Tuesday, February 8, 2011 5:12 PM
  • Using Acrobat 10.0.1 with a "Send using Email" link (ie: mailto functionality). Form is opening inside of Internet Explorer browser.

    Made the registry setting changes from this thread .

    1. Open up pdf with Email button
    2. Click button to send form via email
    3. Error message "There is no email program associated to perform the requested function. Please install...."
    4. Clicking "OK" kills the Alert ... and then...
    5. Outlook fires up and creates the email with the attachment

    Initially, if I leave the 'PreFirstRun" registry value in the "Mail" key ... it is the one that shows as an "Error" alert instead of the other error message listed above.

    Settings in Default Programs for MAPI are correctly showing as Microsoft Outlook.

    Any ideas??

    Tuesday, February 15, 2011 10:03 PM
  • You must do this:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge]
    @="Outlook64Bridge"
    "DLLPathEx"="c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL"
    "DLLPath"="c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL"

    and to set the Default Programs Association

    [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]
    @="Outlook64Bridge"

    Martin Brugger


    I've never done registry edits before, but I am frustrated enough to try.  Would anyone be kind enough to post the steps for a novice to add the registries listed to the HKEY with regedit?

    Thanks very much for the solution - I'm a little wobbly on the application . . .

    Thursday, February 24, 2011 3:35 AM
  • I may be a bit wobbly, but I added the keys with regedit and I placed the information into the values fields as instructed, but without the quotation marks (that threw me 1st time around).

    I kept looking for an internet settings or default programs setting where I would change to Outlook64Bridge, of course I couldn't find it.

    It didn't work until I edited the [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail] key to have Outlook64Bridge instead of Microsoft Outlook (I orginally thought that I fixed that when I added the [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Outlook64Bridge] value = Outlook64Bridge key).

    Now, all works as it should & I can send a PDF as an attachment directly from Acrobat Pro 9.4.2.  I'm thinking that there are many more frustrated Adobe users who have Windows 7 64 Bit, MS Office 2010 64 Bit, and the email issue.  Too bad Adobe couldn't code this as a patch or somesuch. 

    Thursday, February 24, 2011 2:29 PM
  • Hello,

    I upgraded to Adobe Reader X and now my fix mentioned above I found is not working anymore.

    Do you know a solution for Adobe Reader X?

    Michael.

    Friday, March 4, 2011 6:13 PM
  • This is not an Adobe problem, but an principal Windows 64/32 Bit boundary problem.

    Adobe can not automate that, because the solution above is only valid for people using 64 Bit outlook.
    The solution has to be adapted to other mail clients, if they do not use outlook 64 bit.

     

    Microsoft has implemented a 64/32 Bit process adapter for their mailing clients whic ist the fixmapi.exe.

     

    Other vendor would have to offer similiar things, but adobe can not know which verndor is using which adapter

    and how to configure it.
    Of course Adobe could document that on theit pages and provide a registry patch for all the outlook guys.

    But a general patch provide by adobe would be very difficult and not in the responsibility of the adobe software.

    The mail client vendors have to provide such things.

    Michael

    Friday, March 4, 2011 7:34 PM
  • Sorry for my massive replys her.

    After rebooting, the fix also works for Adobe Reader X.

     


    May be adobe cached some values in a loaded component.

    Michael

    Friday, March 4, 2011 8:13 PM
  • Glad to hear it.  Your explaination of possible reasons that Adobe hasn't addressed this with a patch makes some sense, but I'm selfishly not satisied that it didn't work out of the box.  Kind of felt like purchasing a computer with no external ports - works nice enough, but not very convenient . . .
    Friday, March 4, 2011 8:39 PM
  • Hi,

     

    Can anybody help me ? I can't get the fix to work. I've imported all the new keys into the registry but i still keep the error message no default mail client is setup ?

    I am using W7 64 bit with Office 2010 64-bit with Adobe Reader X:

     

    http://postimage.org/image/7mghhqp0/

    http://postimage.org/image/7o5odkys/

     

     

    What am i doing wrong ?

     

    thank you,

     

    Olivier




    Sunday, April 3, 2011 10:50 AM
  • Oliver,

    It looks to me as though you put the "DLLPath" & "DLLPathEx" in with the Outlook64Bridge.  On my computer I put them in separate folders underneath the Outlook64Bridge . . .

    My set up looks like this in regedit.exe:

    Mail
       Outlook64Bridge
                  (Default)   REG_SZ   Outlook64Bridge
             DLLPath
                  (Default)   REG_SZ   c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL
             DLLPathEx
                  (Default)   REG_SZ   c:\\Windows\\winsxs\\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7600.16385_none_ab2397727b134496\\MAPI32.DLL

    Your set-up will be slightly different, but I think the key is to have the the sub-folders under the "Outlook64Bridge" key.  This fix is working for both Adobe Acrobat Pro 9.4.2 & Adobe Reader X on my computer.

    Monday, April 4, 2011 5:55 PM
  • Hi CD,

     

    Thank you for your answer but i'm afraid i still didn't resolve the issue... I had indeed put the DLLPath and DLLPathEX within the Outlook64Bridge... But now that I changed this it still does not work ? I've tried with the path c:\Windows\System32 first with single \ and after that with double \\

    After that i looked for the path that resembles your setup and found a mapi32.dll as well in the winsys folder but still no success ?

    I probably am forgetting something or there is a mistype somewhere in the keys ? I've again included some images depicting my registry....

    somebody has a clue ?

    http://postimage.org/image/1vsa42kmc/

    http://postimage.org/image/1vwtu9xic/

    http://postimage.org/image/1vx8q41yc/

     

    thanx, Olivier


    PS

    I see under WOW6432Node the same structure as above, is this created in mirror ? I did not set the values myself?

    Tuesday, April 5, 2011 7:25 PM
  • Windows 7 64 bit with Office 2010 64 bit:

    Worked for me, Thanks. I had a newer version of the mapi32.dll so I referenced that one - Also remember to setup a mail profile, duh, when trying the solution on a different / next computer.

    C:\Windows\winsxs\x86_microsoft-windows-mapi_31bf3856ad364e35_6.1.7601.17514_none_ad54ab3a7801c830\mapi32.dll -- 11/20/2010

    Also: On my W7 system, in the Default Programs - Set Your Default Programs, I saw that Outook had 15 of 16 default  and that the MAPI -> sendmail was set to the Outlook64Bridge before I had a successful send. Now it shows Outlook again as having all the defaults and the Acrobat Submit button continues to work.

    And thanks _Red_Baron_ also

     

    Wednesday, April 13, 2011 6:32 PM
  • just to let you know that i switched to Office 32 bit without losing information or account settings.

    I backup my pst files and message rules as well as my onenote folders but there was no need to restore because everything is still in place.

     

    I decided to "downgrade" after reading lots of articles that say there is no advantage in using the 64 bit version in speed? I could not find the solution with the outlook64bridge thing....

     

    see you

    Friday, April 15, 2011 10:06 PM
  • Where is my log in to Shoreline Community College?
    Tarry Jim Masters
    Wednesday, April 27, 2011 2:37 PM
  • Where is my log in to Shoreline Community College?
    Tarry Jim Masters


    Tarry Jim Masters
    wwwShorelineCommunity College/help/
    Wednesday, April 27, 2011 2:38 PM
  • No simple log in notification?
    Tarry Jim Masters
    Wednesday, April 27, 2011 4:40 PM
  • No simple log in notification?
    Tarry Jim Masters


    Tarry Jim Masters
    Wednesday, April 27, 2011 4:41 PM
  • The suggested solution for adding Outlook64Bridge Worked like a charm

    Thanks for the help!

    Wednesday, May 18, 2011 9:41 PM