locked
Phone developer registration failed, error code 0x80004005 RRS feed

  • Question

  • I'm trying to get my Lumia 920 developer unlocked using Developer Phone Registration tool from Windows Phone 8 SDK with Live ID associated to my WP developer account, but keep getting an error:

    An error occuring registering your phone. Please try again. (ErrorCode:0x80004005).

    Restarted phone and PC several times, every time all goes the same way. What does this error mean?

    Thanks in advance, any help is appreciated!


    b.r., ap3rus


    Sunday, November 11, 2012 10:14 AM

Answers

  • It was hard to find, but at the end it's simple: reason why that was not working is that my device's name contained cyrillic characters. Once I renamed it to exclude all cyrillic characters it started working like a charm.


    b.r., ap3rus


    • Marked as answer by Vlad Nagorny Monday, November 26, 2012 11:58 PM
    • Edited by Vlad Nagorny Tuesday, November 27, 2012 12:01 AM
    Monday, November 26, 2012 11:58 PM

All replies

  • This error is mostly seen if Phone Registration tool is unable to read or access the Windows registry. Here is a related article on the same - http://support.microsoft.com/kb/295297?wa=wsignin1.0

    Try launching the Phone Registration Tool in Admin mode and then registering the phone. If that doesn't work, please try re-installing Windows Phone SDK 8.0 again.

    Monday, November 12, 2012 6:37 AM
  • Neither launching the tool in Admin mode, nor repairing, nor full uninstalling + reinstalling did not help. The problem is exactly the same - 0x80004005. I have Windows 8 x64 RU. How can I at least troubleshoot this problem? Is there any detailed logging available? Hoping for the answer, thanks.


    b.r., ap3rus


    • Edited by Vlad Nagorny Saturday, November 24, 2012 12:56 PM
    Saturday, November 24, 2012 12:54 PM
  • @Vlad - you mentioned that you are using Windows 8 x64 RU (Russian). Are you installing Russian language version of Windows Phone SDK 8.0 ? If not, which language flavor are you trying?

    If you are trying Russian language flavor and having issues, can you please try English flavor and let us know if the same issue is seen.

    Thanks,

    Satish

    Monday, November 26, 2012 4:05 AM
  • I'm installing English version of SDK upon of English version of Visual Studio 2012. I also tried to install English MUI and selecting English as a language of user's display language, but that did not help. 


    b.r., ap3rus


    Monday, November 26, 2012 11:46 AM
  • @Vlad - there is a similar post (http://social.msdn.microsoft.com/Forums/en-US/wptools/thread/6ebc3669-33a0-4094-95b8-bd7384df141f) where developers are having issues around developer unlock tool. Although, in your case the phone is detected but may be removing the device through Device Manager and re-attaching it can resolve the issue.

    I will try to investigate on this at my end.

    Monday, November 26, 2012 11:55 AM
  • Hi Satish,

    Removing/reattaching the device did not solve the issue. I've also checked that IP Over USB service can see my device, seems like those issues are not related from the first sight.

    I'm downloading evaluation VHD of EN-US Windows Server 2012 to try launching registration from within it.


    b.r., ap3rus

    Monday, November 26, 2012 5:14 PM
  • Hi Satish,

    Removing/reattaching the device did not solve the issue. I've also checked that IP Over USB service can see my device, seems like those issues are not related from the first sight.

    I'm downloading evaluation VHD of EN-US Windows Server 2012 to try launching registration from within it.


    b.r., ap3rus

    OK, I choose to install Windows 8 Enterprise Evaluation to meet requirements of SDK (installed English version), then the SDK (English as well) was installed. And then I tried to use Windows Phone Developer Registration tool to unlock my phone, and... meeting 0x80004005. Since the installation of Windows was completely clean, as well as installation of WP 8 SDK, coming to conclusion there's either something with my phone or with my Microsoft Account. I've tried to do the phone settings reset, that did not help.

    Any ideas?


    b.r., ap3rus






    • Marked as answer by Vlad Nagorny Monday, November 26, 2012 11:55 PM
    • Unmarked as answer by Vlad Nagorny Monday, November 26, 2012 11:55 PM
    • Edited by Vlad Nagorny Tuesday, November 27, 2012 12:02 AM
    Monday, November 26, 2012 11:11 PM
  • It was hard to find, but at the end it's simple: reason why that was not working is that my device's name contained cyrillic characters. Once I renamed it to exclude all cyrillic characters it started working like a charm.


    b.r., ap3rus


    • Marked as answer by Vlad Nagorny Monday, November 26, 2012 11:58 PM
    • Edited by Vlad Nagorny Tuesday, November 27, 2012 12:01 AM
    Monday, November 26, 2012 11:58 PM
  • @Vlad - That's Great.

    Can you please share (if it's alright with you :) ) the device name you had earlier and what did you change it to after which it started working.

    I am not an expert in languages so need a little help - as per you, change cyrillic characters solved the issue, cyrillic script is not same as Russian script, is that correct?

    Tuesday, November 27, 2012 1:11 AM
  • Hi Satish,

    By cyrillic script I was actually meaning Russian script, sorry for confusion :)

    The name before issue was solved was "кабан"; as soon as device was renamed to "kaban" the issue disappeared. 


    b.r., ap3rus


    Tuesday, November 27, 2012 9:39 PM
  • Had a same issue with registering my phone (Lumia 920) today (9 months after problem was reported).

    Vlad, thanks for solution even my phone name isn't as cool as it was:).

    Friday, August 30, 2013 2:41 PM
  • Victor, by the way after registration success you can safely change your device name back to whatever it was, it won't make anything broken afterwards :)

    // best regards
    Vlad Nagorny

    Friday, August 30, 2013 3:11 PM
  • Eeeeh.

    @Vlad, Thanks a lot, same error was here, with Japanese characters in name (チルノのスマホ).

    Saturday, October 12, 2013 2:41 AM
  • Oh my God you're a legend.

    Tao Wang

    Saturday, May 30, 2015 9:33 AM